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ESG Family Signal Generators
Option 201
1 The Real-Time cdma2000 Personality

This guide provides information specific to the Option 201 real-time cdma2000 personality. 
This chapter contains an overview of Option 201.

NOTE This option requires the installation of Option UN8 (hardware Revision C or 
greater), Real-Time Baseband Generator with TDMA Standards. Refer to the 
Option UN8 user’s and programming guide for information.
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The Real-Time cdma2000 Personality ESG Family Signal Generators
Overview Option 201
Overview
The Option 201 personality provides real-time, fully coded signal solutions for IS-2000 
with IS-95 backwards compatibility in both the forward (base station simulation) and 
reverse link (mobile simulation) modes. This option supports radio configurations (RC) 1–5 
in forward link and RC1–4 for reverse link, with both modes using spread rate one (SR1). 
IS-95 is supported using RC1 or RC2 while IS-2000 features are supported using RC3–5. 
Long and short coding, cyclic redundancy checks, convolutional or turbo encoding, 
interleaving, power control, and complex scrambling are all supported. Additional 
capabilities allow flexible channel configurations with individually adjustable power levels 
and data rates, customizable user data, and variable chip rates.

In order to provide IS-2000 test solutions, the Option 201 real-time cdma2000 personality 
requires that some of the BNC/SMB I/O connectors on the ESG function differently than 
what the connector labels state. These functionality changes are active only when using 
the Option 201 personality. For detailed descriptions of BNC I/O functionality, refer to 
“Forward and Reverse Link I/O Signal Descriptions and Timing Relationships” 
on page 4-9.

Forward Link

The forward link mode simulates a base station transmitter and supports RC1–5 with 
SR1. There is a single-ESG solution for IS-95 receivers (RC1 or RC2) and a two-ESG 
solution for IS-2000 receivers (RC3–5). The two-ESG solution allows for a more complex 
signal structure. A single ESG can be used to transmit a partial IS-2000 signal with a 
limited number of channels.

Paging, sync, and pilot channels are supported. An RC4 forward traffic link, as supported 
by the personality, is shown in Figure 1-1.

Figure 1-1. Forward Coding Path for an IS-2000 SR1 RC4 Traffic Channel
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Table 1-1 Forward Link Features by ESG Solution

Description 1-ESG 2-ESG

Fully coded channels including pilot, sync, paging, 
quick paging, and fundamental and supplemental 
traffic channels

● 1,2

1. IS-95 does not support quick paging.
2. One ESG can generate a group of channels including pilot, sync, paging, and 

RC1-RC2 fundamental or a group of channels including RC1-RC5 fundamental 
and RC3-RC5 supplemental channels. A single ESG cannot generate both groups 
of channels simultaneously.

●

Support for radio configurations 1–5 ● ●

Incremental data rates up to 307.2 kbps ●

Full control of the paging message stream 
(overhead and signaling messages)

● ●

Supports both convolutional and turbo encoding ● 3

3. IS-95 does not support turbo encoding.

●

Supports quasi-orthogonal functions 0–3 ● ●

User data insertion via user files or external data ● ●

Variable chip rates, 50 Hz to 1.3 MHz ● ●

Fully configurable sync channel base station 
parameters

● ●

OCNS channels ● ●
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Reverse Link

The Option 201 reverse link supports RC1–4 with SR1 and allows the operator to test the 
base station using either a single- or a two-ESG solution. The single ESG solution is viable 
for both IS-95 and IS-2000. The two-ESG solution is only for the IS-2000 format; this 
allows an additional reverse supplemental channel (R-SCH).

In the reverse link mobile setup display, there is an adjustable Trigger Advance field that 
is used to synchronize the RF output of the ESG to the base station timing signal. Another 
field, Trigger Edge, allows the ESG to trigger on the positive or negative going transition 
of the base station timing signal. Both of these fields are used in all radio configurations.

IS-95 is supported using RC1 or RC2 which utilizes a single, selectable channel type: 

• reverse access control channel (R-ACH)

• reverse fundamental channel (R-FCH)

• reverse supplemental channel (R-SCH)

IS-2000 features are supported using RC3 or RC4 and can use up to four channels on one 
ESG and five total with the second ESG. The channel types consist of the following:

• reverse pilot channel (R-PICH) (with or without gating)

• reverse dedicated control channel (R-DCCH)

• reverse common control channel (R-CCCH)

• reverse enhanced access channel (R-EACH)

• reverse fundamental channel (R-FCH)

• reverse supplemental channel (R-SCH)

Figure 1-2. shows the reverse fundamental and supplemental channel structure for RC4 
and Figure 1-3. shows the reverse channel spreading for RC3 and RC4, utilizing SR1 as 
implemented by the Option 201 personality.

Figure 1-2. RC4 Reverse Fundamental and Supplemental Channel
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Figure 1-3. RC3 and RC4, SR1 Reverse Link Spreading 

Table 1-2. Reverse Link Features by Radio Configuration

Description RC1 RC2 RC3 RC4

IS-95 backwards compatible ● ●

IS-2000 features ● ●

Pseudorandom number patterns ● ● ● ●

4-bit fixed data patterns ● ● ● ●

User defined data patterns ● ● ● ●

Incremental data rates up to 9.6 kbps ● 1

1. The maximum data rate applies to the fundamental and supplemental channels.

● 2

2. The maximum data rate applies to the fundamental and dedicated control channels.

Incremental data rates up to 14.4 kbps ● 1 ● 3

3. The maximum data rate applies to the fundamental channel.

High incremental data rates up to 307.2 kbps ● 4

4. The maximum data rate applies to the supplemental channel.

High incremental data rates up to 230.4 kbps ● 4

Power control bit settings ● ●

Adjustable frame offsets ● ● ● ●

Adjustable frame lengths ● ●

Convolutional encoding ● ● ● ●

Turbo encoding ● ●
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Option 201
2 Using Functions

This chapter provides information on how to use functions that are unique to Option 201. 
You can configure Option 201 using either one or two signal generators for both forward 
and reverse link. 

In this chapter, you will find individual sections for forward and reverse link. These 
sections provide information which will guide you through configuring a single-ESG 
solution, a two-ESG solution, and tests that can be performed. In addition, a 
troubleshooting section is included at the end of the chapter.

The material in this chapter is presented with the assumption that you have a working 
knowledge of both the ESG and CDMA and/or IS-2000.

For basic operating information, refer to the ESG quick start guide and user’s guide.

For information on the operational theory of Option 201, refer to chapter 4.

NOTE In this manual, IS-2000 is equivalent to cdma2000.

References to preset refer to normal, factory preset conditions (Utility > 
Power On/Preset > Normal), not user preset.

Hardkeys and softkeys are denoted by Bold text; data fields within a setup 
editor are denoted by a different font. This is an example of what that font 
looks like: Computer Font.

Examples:

I/Q > I/Q Source (Ext I/Q) > Int I/Q

CDMA2000 > BTS Setup > Filter

Hardkey Softkey Data Field
Real-Time cdma2000 Personality User’s and Programming Guide 2-1
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Forward Link Test Configurations and Measurements
This section will demonstrate a single-ESG and a two-ESG test configuration while 
utilizing the E4406A VSA Transmitter Tester for taking measurements. (Refer to the 
E4406A VSA Transmitter Tester User’s Guide and cdma2000 Measurement Guide for 
specific E4406A measurement information.) Included in this section, are examples of tests 
that can be performed with the Option 201 such as frame, block and bit error rate and how 
to create a paging message.

Single-ESG Forward Link Configuration

This section will guide you through setting up the ESG using four IS-95 backwards 
compatible channels with real-time signal generation capability. The ESG output is 
measured using the E4406A VSA Transmitter Tester.

Required Equipment

• 1 Agilent Technologies ESG-D or ESG-DP Family Signal Generator with Options UN8 
and 201

• 1 Agilent Technologies E4406A VSA Series Transmitter Tester with Option B78

• 3 BNC Cables

• 2 Type-N (m) to BNC (f) adapters

Single-ESG Forward Link Measurement Setup

1. Refer to Figure 2-1. and make the necessary connections between the ESG and the 
E4406A.

Figure 2-1. Single-ESG Forward Link Measurement Setup

2. Turn on the ESG and the E4406A VSA.
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Configuring the Single-ESG for Forward Link

NOTE The following signal generator settings are used for example purposes. 
Change them as needed for your device under test (DUT). 

1. Press Preset (factory defined, not user defined).

2. Press Frequency > 900 > MHz and then press Amplitude > –40 > dBm.

3. Press Mode > Real-time I/Q BaseBand (if it appears) > CDMA > CDMA2000.

4. Check that the following softkeys are set as indicated:

Link Forward Reverse:  Forward is highlighted

BBG Data Clock Ext Int:  Int is highlighted

5. Press More (1 of 2).

6. Check that the following softkeys are set as indicated:

Phase Polarity Normal Invert:  Normal is highlighted

IQ Map Rotation Std. Rotated:  Std. is highlighted

7. Press More (2 of 2).

The following figure displays the default values for the CDMA2000 forward link BTS 
setup data fields.

The following are brief descriptions of the available fields. Refer to Chapter 3 , “Softkey 
Reference” for more detailed information on each field.

NOTE If a field is grayed out, it cannot be edited.

Filter  This displays the current filter being used. In addition to the 
standard filters (Root Nyquist, Nyquist, Gaussian and User 
FIR), the four IS–95 filters can be used with all radio 
configurations.
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Even Sec Delay  This displays the delay of data transmission relative to the 
internal data clock. This is measured in units of chips with a 0.5 
chip resolution.

Spread Rate  This displays the spread rate being used and it cannot be 
changed.

Chip Rate   This displays the number of chips being spread and the amount 
of bandwidth being occupied. 

LC State  This displays the value of the long code that is available in the 
shift register. Setting a value other than 0 seeds the long code. 
For no long code, set to 00000000000.

PN Offset  This displays the current pseudorandom number offset value. 
This is the time offset in the short sequence code assigned to 
each base station to give a unique identity.

8. Press the BTS Setup softkey.

This opens the base transceiver station setup editor. The highlight bar can be moved by 
rotating the front panel knob or pressing the arrow keys.

9. Move the highlight bar to the LC State field and press Edit Item.

10. Press 1 > Enter.

The following figure displays the current BTS setup field values that will be used in this 
example.

11. Press Return. The CDMA2000 menu is now displayed.

12. Press Link Control. 

This accesses a channel control menu where the channels can be turned on or off, the 
channel type selected and parameters edited, and the code domain power adjusted.
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13. Press the following key sequences to configure the individual channels, starting with 
channel one. The channel parameters are shown in Table 2-1. 

NOTE The Channel Number softkey is always bold. This indicates that you do not 
have to press this softkey to change channel numbers. You can change 
channels by pressing the appropriate number and the Enter softkey, rotating 
the front panel knob, or using the arrow keys.

• 1 > Enter > Channel State Off On to On > Channel Setup > Power >
-7 > dB > Return

• 2 > Enter > Channel State Off On to On > Channel Setup > Power >
-13 > dB > Return

• 3 > Enter > Channel State Off On to On > Channel Setup > Power >
-10 > dB > Walsh > 8 > Enter > Radio Config > 1 > Enter > Return

• 4 > Enter > Channel State Off On to On > Channel Setup > Power >
-10 > dB > Return

14. Press Adjust Code Domain Power > Scale To 0dB.

Notice that the power levels have changed on each channel. This has scaled the channel 
power levels to the proper amplitudes for transmission (the sum log value of the new 
power levels equal zero). The power ratios between the channels remain unchanged.

NOTE Adjusting the code domain power works on active channels only.

15. Press Return. The CDMA2000 menu is now displayed.

16. Press CDMA2000 Off On. On is now highlighted and the CDMA2K and I/Q annunciators 
are displayed.

17. Check that the MOD ON annunciator is displayed on the ESG and press RF On/Off. The 
RF ON annunciator is now displayed.

Table 2-1. Forward Link Single-ESG Channel Parameters for RC1

Channel 
Number

Channel 
Type

Channel 
State

Channel 
Power

Walsh 
Code

Data Data Rate

1 F–PICH On −7.0 dB 0 N/A N/A

2 F–SYNCH On −13.0 dB 32 N/A N/A

3 F–FCH On −10.0 dB 8 PN9 9.60000 kbps

4 F–PCH On −10.0 dB 1 DEFAULT 9.60000 kbps
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Configuring the E4406A VSA for a Single-ESG Forward Link Measurement  

This section explains how to set up the E4406A VSA to display the forward link ESG 
parameters that were configured in the previous section. 

Perform the following steps to show the code domain display:

1. Press Preset.

2. Set the VSA to use an external reference and ensure that it is set to 10 MHz.

Press: System > Reference > Freq Ref Int Ext 

a. Press 10 > MHz.

b. Press the Freq Ref Int Ext softkey until Ext is underscored.

3. Choose the cdma2000 option.

Press: Mode > More (1 of 2) > cdma2000

4. Set the VSA is set to receive a base station signal.

Press: Mode Setup > Radio > Device BTS MS to BTS

5. Set the center frequency to 900 MHz.

Press: Frequency > 900 > MHz

6. Set the display span to view the full modulated signal.

Press: SPAN > 1.8 > MHz

7. Select the code domain measurement.

Press: Measure > More (1 of 2) > Code Domain

8. Set the VSA display for a Walsh code length of 128.

Press: Display > Base Code Length 64 128 to 128

This allows the F-SYNCH channel indicator to be shown in red. With the Base Code 
Length 64 128 softkey set to 64, the F-SYNCH channel is shown as yellow.

9.  Set the VSA to trigger on a rear external source.

Press: Meas Setup > More (1 of 3) > More (2 of 3) > Trig Source > Ext Rear

10. Press Restart.

This allows the VSA to take another single sweep measurement after all settings have 
been implemented.

11. Position a marker to read a channel.

a. Press the Marker hardkey.

b. Rotate the front panel knob to position the marker.

The marker displays a channel’s Walsh code spread factor, Walsh code, symbol rate, and 
power level (indicated as Channel Marker Information on the figure).
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12. Set the VSA to measure continuously.

Press: Meas Control > Measure Single Cont to Cont

NOTE The marker is easier to position when the VSA is set to measure a single 
sweep.

The following figure of the vector signal analyzer display illustrates that the code domain 
power levels shown on the ESG after scaling and adjusting the code domain power match 
those shown on the vector signal analyzer.

Using this Setup with a CDMA Mobile Phone  

To connect to a CDMA mobile phone, (because the ESG does not support bidirectional 
protocol handling) place the mobile phone in a test mode which enables it to process 
messages without full handshaking.

Channel Marker InformationChannel Marker
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Two-ESG Forward Link Configuration

This configuration provides more real-time CDMA channels, power levels, and higher 
radio configurations than a setup using only one signal generator. In addition, using two 
ESGs provides two RC3, RC4 or RC5 traffic channels, enabling you to test IS-2000 receiver 
designs.

The following example configures an IS-2000 stimulus containing pilot, synch, OCNS, and 
paging channels, as well as a fundamental and supplemental RC4 traffic channel.

Required Equipment

• 2 Agilent Technologies ESG-D or ESG-DP Family Signal Generators with Options UN8 
and 201

• 1 Agilent Technologies E4406A VSA Series Transmitter Tester with Option B78

• 12 BNC cables (See note prior to setup drawing for length requirements)

• 3 BNC tee splitters

• 3 Type-N (m) to BNC (f) adapters

Two-ESG Forward Link System Configuration Process

The two-ESG system configuration process is divided into the following subsections:

• “Two-ESG Forward Link Measurement Setup” on page 2-9

• “Configure ESG 1 for Forward Link” on page 2-10

• “Configure ESG 2 for Forward Link” on page 2-12

• “Adjust the Relative Power Mapping (Two-ESG Forward Link)” on page 2-15

• “Generate the Signal at the RF Output (Two-ESG Forward Link)” on page 2-17

• “Configuring the E4406A VSA for the Two-ESG Forward Link Measurement” on 
page 2-18
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Two-ESG Forward Link Measurement Setup

1. Refer to the Figure 2-2. and connect the two ESGs and the E4406A VSA Transmitter 
Tester as shown.

NOTE The following connections require short cables of equal length to reduce phase 
difference:

Data Clock ESG 1 and ESG 2 Input to RF Output on ESG 2
I Out and Q Out ESG 2 to I Input and Q Input on ESG 1
I Out and Q Out ESG 1 to I Input and Q Input on ESG 1

Figure 2-2. Two-ESG Forward Link Measurement Setup

2. Turn on the signal generators and the E4406A VSA.
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Configure ESG 1 for Forward Link

NOTE The following signal generator settings are used for example purposes. 
Change them as needed for your device under test (DUT). 

1. Press Preset (factory defined not user defined).

2. Press Frequency > 900 > MHz and then press Amplitude > -40 > dBm.

3. Press Mode > Real-time I/Q BaseBand (if it appears) > CDMA > CDMA2000.

4. Check that Forward is highlighted on the Link Forward Reverse softkey.

5. Press BBG Data Clock Ext Int. Ext is now highlighted.

6. Press More (1 of 2).

7. Check that the following softkeys are set as indicated:

Phase Polarity Normal Invert:  Normal is highlighted

IQ Map Rotation Std. Rotated:  Std. is highlighted

8. Press More (2 0f 2).

The following figure displays the default values for the CDMA2000 forward link BTS 
setup data fields for ESG 1.

The following are brief descriptions of the available fields. Refer to Chapter 3 , “Softkey 
Reference” for more detailed information on each field.

NOTE If a field is grayed out, it cannot be edited.

Filter  This displays the current filter being used. In addition to the 
standard filters (Root Nyquist, Nyquist, Gaussian and User 
FIR), the three IS–95 filters can be used with all radio 
configurations.
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Even Sec Delay  This displays the delay of data transmission relative to the 
internal data clock. This is measured in units of chips with a 0.5 
chip resolution.

Spread Rate  This displays the spread rate being used and it cannot be 
changed.

Chip Rate   This displays the number of chips being spread and the amount 
of bandwidth being occupied. 

LC State  This displays the value of the long code that is available in the 
shift register. Setting a value other than 0 seeds the long code. 
For no long code, set to 00000000000.

PN Offset  This displays the current pseudorandom number offset value. 
This is the time offset in the short sequence code assigned to 
each base station to give a unique identity.

9. Press the BTS Setup softkey.

This opens the base transceiver station setup editor. The highlight bar can be moved by 
rotating the front panel knob or pressing the arrow keys.

10. Move the highlight bar to the LC State field and press Edit Item.

11. Press 1 > Enter.

The following figure displays the current BTS setup field values that will be used in this 
example for ESG 1.

12. Press Return to open the CDMA2000 menu.

13. Press Link Control. 

This accesses a channel control menu where the channels can be turned on or off, the 
channel type selected and parameters edited and the code domain power adjusted.
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14. Press the following key sequences to configure the individual channels, starting with 
channel one. The channel parameters are shown in Table 2-2.

NOTE The Channel Number softkey is always bold. This indicates that you do not 
have to press this softkey to change channel numbers. You can change 
channels by pressing the appropriate number and the Enter softkey, rotating 
the front panel knob, or using the arrow keys.

• 1 > Enter > Channel State to On > Channel Setup > Power > −7 > dB > Return

• 2 > Enter > Channel Type to F-SYNCH > Channel State Off On to On > Channel Setup > 
Power > −13 > dB > Return

• 3 > Enter > Channel Type F-FCH OCNS to OCNS > Channel State Off On to On > 
Channel Setup > Power > −3.46 > dB > Walsh > 57 > Enter > Return

• 4 > Enter > Channel Type > F-PCH > Channel State to On > 
Channel Setup > Power > −10 > dB > Return

15. Press Return to open the CDMA2000 menu.

Configure ESG 2 for Forward Link

In addition to sourcing part of the CDMA signal, ESG 2 is used as the data clock for both 
ESGs.

1. Press Preset (factory defined not user defined).

2. Press Ampl > ALC Off On. Off is now highlighted.

The automatic leveling control is turned off when two ESGs are used together.

3. Press Frequency > 1.2288 > MHz and then press Amplitude > 20 > dBm.

This sets ESG 2 to be used as the chip clock and sets the amplitude to provide near TTL 
voltages to drive the data clock.

4. Press Mod On/Off. The MOD OFF annunciator is now displayed.

5. Press Mode > Real-time I/Q BaseBand (if it appears) > CDMA > CDMA2000.

6. Check that Forward is highlighted on the Link Forward Reverse softkey.

Table 2-2. ESG 1 Channelization Parameters

Channel 
Number

Channel 
Type

Channel 
State

Channel 
Power

Walsh 
Code

Data Rate

1 F-PICH On −7.0 dB 0 N/A

2 F-SYNCH On −13.0 dB 32 N/A

3 OCNS On −3.46 dB 57 N/A

4 F-PCH On −10.0 dB 1 9.60000 kbps
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7. Press BBG Data Clock Ext Int. Ext is now highlighted.

8. Press More (1 of 2).

9. Press Phase Polarity Normal Invert. Invert is now highlighted.

10. Check that Std. is highlighted on the IQ Map Rotation Std. Rotated softkey.

11. Press More (2 of 2).

The following figure displays the default values for the CDMA2000 forward link BTS 
setup data fields for ESG 2.

12. Press the BTS Setup softkey.

13. Move the highlight bar to the LC State field and press Edit Item.

14. Press 1 > Enter.

The following figure displays the current BTS setup field values that will be used in this 
example for ESG 2.
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15. Press Return to open the CDMA2000 menu.

16. Press Link Control. 

17. Press the following key sequences to configure the individual channels. The channel 
parameters are shown in Table 2-3.

• 3 > Enter > Channel State Off On to On > Channel Setup > Power > −10 > dB > 
Radio Config > 4 > Enter > Return

• 4 > Enter > Channel Type > F-SCH > Channel State Off On to On > Channel Setup > 
Power > −10 > dB > Walsh > 4 > Enter > Radio Config > 4 > Enter > Data Rate > 
153.6 kbps > Return

NOTE Due to hardware limitations, I/Q mapping can only support two channels 
with radio configurations greater than 2. Therefore, ESG 2 has only two 
active channels in this configuration.

18. Press Return. This opens the CDMA2000 menu.

Table 2-3. ESG 2 Channelization Parameters for RC4

Channel 
Number

Channel 
Type

Channel 
State

Channel 
Power

Walsh 
Code

Radio 
Config

Data Rate

1 F-PICH Off N/A N/A N/A N/A

2 F-SYNCH Off N/A N/A N/A N/A

3 F-FCH On −10.0 dB 10 4 9.60000 kbps

4 F-SCH On −10.0 dB 4 4 153.600 kbps
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Adjust the Relative Power Mapping (Two-ESG Forward Link)

Once the signal generators are configured as described in the previous sections, use the 
following steps to perform the relative power mapping procedure. Relative power mapping 
assures proper channel power levels between the two ESGs and an overall code domain 
power of 0 dB. For more information, see “Forward and Reverse Link Relative Power 
Mapping.” on page 4 -16.

1. Return to the CDMA2000 menu and press 2 Box Setup on both ESGs.

2. Refer to the following figures. Highlight the Voltage Other ESG data field on ESG 1 
and enter the Voltage This ESG value from ESG 2. Press V to terminate the entry.

The individual ESG voltage adjustments are made to align the channel voltages 
between the signal generators. This in turn adjusts the I/Q voltage scale. While this 
scales the channels relative to each other, it does not ensure the 0 dBm power level 
required for the code domain. This will be done later in the process.

3. Highlight the Voltage Other ESG data field on ESG 2 and enter the Voltage This 
ESG value from ESG 1. Press V to terminate the entry.

Notice that the IQ Voltage Scale value has changed on ESG 2.

a. Enter this value here. b. Enter this value here.

ESG 2

ESG 1



Using Functions ESG Family Signal Generators
Forward Link Test Configurations and Measurements Option 201
4. Refer to the following figures. Highlight the % Power Other ESG data field on ESG 1 
and enter the % Power This ESG value from ESG 2. Press Enter to terminate the entry. 

The percent power adjustment sets the parameters that will allow the scale to 0 dB 
function to scale all channels to 0 dB. This aligns the displayed power of both ESGs to 
match the code domain measurement values on the transmitter tester.

5. Highlight the % Power Other ESG data field on ESG 2 and enter the % Power This 
ESG value from ESG 1. Press Enter to terminate the entry.

6. Press Scale to 0dB on both ESGs. 

The voltage and power values may change to reflect the adjusted power levels.

NOTE Pressing Scale To 0dB on both ESGs scales the individual channel power 
levels so that the sum of the code domain power generated by both ESGs 
equals 0 dB. This does not change the total power, as set by the Amplitude key.

7. Press Return on both ESGs to open the CDMA2000 menu.

a. Enter this value here. b. Enter this value here.

ESG 2

ESG 1
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Generate the Signal at the RF Output (Two-ESG Forward Link)

This section describes the proper order that must be used to turn on the RF output and the 
Option 201 (cdma2000 personality). If for any reason the signal from ESG 2 is interrupted, 
whether by turning off the RF output, cdma2000 personality or ESG power, then the 
following process must be repeated.

1. Perform the following steps for ESG 2:

a. Press RF On/Off. The RF On annunciator is now displayed.

b. Press CDMA2000 Off On. On is now highlighted and the I/Q and CDMA2K 
annunciators are displayed.

NOTE If you generate the IS-2000 waveform on ESG 1 before ESG 2, an error 
message will appear.

2. Perform the following steps for ESG 1:

a. Press CDMA2000 Off On. On is now highlighted and the I/Q and CDMA2K 
annunciators are displayed.

b. Press I/Q > I/Q Source > Ext I/Q.

This combines the baseband signals from both ESGs into one. To return to the 
CDMA2000 menu, press: 

Mode > Real-time I/Q BaseBand (if it appears) > CDMA > CDMA2000

c. Press RF On/Off. The RF On annunciator is now displayed.
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Configuring the E4406A VSA for the Two-ESG Forward Link Measurement

This section shows you how to set up the E4406A VSA to display the forward link ESG 
parameters that were configured in the previous section. 

Perform the following steps to show the code domain display in bit reverse:

1. Press Preset.

2. Set the VSA to use an external reference and ensure that it is set to 10 MHz.

Press: System > Reference > Freq Ref Int Ext 

a. Press 10 > MHz.

b. Press the Freq Ref Int Ext softkey until Ext is underscored.

3. Choose the cdma2000 option.

Press: Mode > More (1 of 2) > cdma2000

4. Set the VSA to receive a base station signal.

Press: Mode Setup > Radio > Device BTS MS to BTS

5. Set the center frequency to 900 MHz.

Press: FREQUENCY > 900 > MHz

6. Set the display span to view the modulated signal.

Press: SPAN > 1.8 > MHz

7. Select the code domain measurement.

Press: MEASURE > More (1 of 2) > Code Domain

8. Set the VSA to display bit reverse.

Press: Display > Code Order Bit Reverse

Bit Reverse changes the view so you will see the number of channel indicators on the 
display that matches the number of channels that were transmitted. Whereas the 
Hadamard view can have more channel indicators than the number of channels 
transmitted.

9. Set the VSA display for a Walsh code length of 128.

Press: Display > Base Code Length 64 128 to 128

This shows all channel indicators in red. With the Base Code Length 64 128 softkey set to 
64, some channels are shown as yellow.

10. Set the VSA to trigger on a rear external source.

Press: Meas Setup > More (1 of 3) > More (2 of 3) > Trig Source > Ext Rear

11. Press Restart.

This allows the VSA to take another single sweep measurement after all settings have 
been implemented.
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12. Position a marker to read a channel.

a. Press the Marker hardkey.

b. Rotate the front panel knob to position the marker.

The marker displays a channel’s Walsh code spread factor, Walsh code, symbol rate, and 
power level (indicated as Channel Marker Information on the figure).

13. Set the VSA to measure continuously.

Press: Meas Control > Measure Single Cont to Cont

NOTE The marker is easier to position when the VSA is set to measure a single 
sweep.

The following figure shows the VSA code domain display for bit reverse using a forward 
link, 6-channel, two-ESG configuration.

Using this Setup with a CDMA Mobile Phone

To connect to a CDMA mobile phone, (because the ESG does not support bidirectional 
protocol handling) place the mobile phone in a test mode which enables it to process 
messages without full handshaking.

Channel Marker InformationChannel Marker
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Setting Up Quick Paging

Set up Quick paging on ESG 1 or ESG 2 in the two-ESG configuration. If the QPCH is set 
up on ESG 1, it is necessary to configure it so traffic channels from ESG 2 are not being 
transmitted at the same time. 

NOTE Quick paging is generated using both channel 3 and 4. If channel 3 is active 
when you turn on QPCH, channel 3 will turn off. Conversely, if QPCH is on 
when you activate channel 3, QPCH will turn off.

Perform the following steps to set up the quick paging channel for ESG 1 or ESG 2:

1. If ESG 2 is being used as the QPCH source, proceed to step 3. 

2. Press I/Q > I/Q Source > Int I/Q on ESG 1.

This prevents the active traffic channels on ESG 2 from being integrated with the 
ESG 1 signal.

3. Press Mode > CDMA > CDMA2000 > Link Control > 4 > Enter > Channel Type > QPCH.

4. Press the Channel Setup softkey to open the setup editor.

The following figure shows the quick paging channel data fields.

The following list describes the fields shown in the figure above. For more information 
on these fields, refer to Chapter 3 , “Softkey Reference.”

Power  Shows the current power setting.
Range: –40.0 dB through 0.0 dB

Walsh  Shows the current Walsh code value.
Range: 0 through 127
Default: 80

Data Rate  Shows the current data rate in kbps. 
Range: 2.4 kbps or 4.8 kbps
Default: 4.8 kbps
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Config Change  Shows the current value of the configuration change indicator.
Range: 
0 = none
1 = first
2 = second
3 = both 
Default: 3

Paging Indicator  Shows the current paging slot.
Range: 
2.4 kbps - 0 through 190, 191 turns all slots on, –1 all slots off
4.8 kbps - 0 through 382, 383 turns all slots on, –1 all slots off
Default: 0

NOTE Notice that the number of available paging slots is dependent on the data 
rate. The higher data rate allows for more slots.

Paging slots can be selected individually by entering a slot number, or all can 
be selected by entering 191 or 383, depending on the data rate currently 
showing in the Data Rate field. Entering -1 will turn all slots off when all 
slots have been selected.

5. Rotate the front panel knob or use the arrow keys to highlight the Paging Indicator 
field.

6. Enter 383 using the numeric keypad and press Enter.

For this example, you will only need to change the Paging Indicator field. However, to 
edit the other channel parameters, use the front panel arrow keys to navigate among 
the data fields. Highlight the desired data field and press Edit Item. Edit the data value 
and press Enter.

NOTE Selecting less than all paging slots (191 or 383) will not allow you to see the 
QPCH on the E4406A VSA code domain display. To view individual slots, it is 
recommended that a time-domain display be used.

7. Press Return > Channel State to On to activate the QPCH channel.
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Forward Link Frame Error Rate (FER), Block Error Rate (BLER), 
and Bit Error Rate (BER) Tests

This section describes real-time FER and BLER tests that can made using the forward link 
feature of Option 201. These measurements characterize the performance of an RF 
receiver under various interference conditions to ensure adequate operation in real-life 
environments.

FER provides a ratio of the number of frames received with CRC errors to those without 
errors. The FER tests specified for IS-95 and IS-2000 RF testing include the following:

• “Sensitivity and Dynamic Range” on page 2-24

• “Adjacent Channel Interference” on page 2-24

• “Fading and Multi-Path Distortions” on page 2-24

• “Single Tone Desensitization” on page 2-24

• “Intermodulation Spurious Response Attenuation” on page 2-24

NOTE The ESG does not contain the decoding capability necessary to perform the 
FER/BLER tests without externally connected, customer-supplied equipment. 
See the figure under “FER Test Setup” for an example of the external 
equipment needed to perform an automated test.

Similarly, BLER tests use a phone or external test equipment to maintain an account of 
erased blocks. FER and BLER tests are widely used, and help in design characterization, 
verification, and RF functional testing in manufacturing.

You can also use bit error rate measurements for design characterization, and to provide 
additional bit error information (see “Bit Error Rate (BER) Tests” on page 2-25).
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FER Test Setup

1.  Set up the equipment, using the figure below as a guide. This figure illustrates a 
generic FER/BLER measurement setup. Equipment varies among tests, and can 
include one or more interference sources and/or fading equipment.

For automated channel set up and instrument configuration, you can use a computer 
controlled system.

2. After you set up the equipment, configure the ESGs as described in “Two-ESG Forward 
Link Configuration” on page 2-8.

The signal generated by the ESG appears as a base station signal to the mobile phone. 
The phone synchronizes to the signal and reads the overhead channels. This process 
comprises the following steps:

a. ESG Pilot acquired
b. Sync channel acquired and decoded
c. Paging channel acquired and monitored

3. Place the phone in test mode.

NOTE The mobile device must have a test mode that enables it to deviate from the 
normal handshaking requirements and go into a manual control mode so that 
it can be controlled by a computer.

4. Issue test mode commands.

Instruct the mobile receiver, via test mode, to listen for a specific RC traffic channel on a 
specific Walsh code (for example, RC2, F-FCH, Walsh Code 47). The mobile set begins 
decoding the specified traffic channel.

5. Request the mobile to report the number of frames in error.

Once you have established this general measurement procedure, you can perform the 
various FER tests.
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Sensitivity and Dynamic Range

The sensitivity measurement provides the minimum power level at the receiver that 
results in a FER, which does not exceed a specified value.

For example, the test could determine the power level required to achieve less than 0.5% 
FER. Sensitivity helps to characterize a receiver’s ability to demodulate a low-level signal, 
and is a key measure of merit in receiver design; the higher a receiver’s sensitivity, the 
more accurately it receives signals, and the less power it requires from the base station.

Similarly, the receiver’s dynamic range is the input power range over which the FER does 
not exceed a specific value.

Adjacent Channel Interference

This test measures the sensitivity of a receiver in the presence of an adjacent channel 
signal.

Fading and Multi-Path Distortions

This test uses a channel simulator to apply fading and multi-path distortions to the signal 
source and measure the sensitivity of the receiver under varying distortion conditions.

Single Tone Desensitization

This test measures the ability of the receiver to receive a signal in the presence of a single 
tone at a given frequency offset away from its center frequency. FER provides the measure 
of merit.

Intermodulation Spurious Response Attenuation

This test measures a receiver’s ability to receive a signal in the presence of two interfering 
CW tones that produce intermodulation products in the band of the desired CDMA signal. 
FER provides the measure of merit.
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Bit Error Rate (BER) Tests  

You can perform bit error rate testing if the phone can provide layer 1 baseband decoding, 
and the ESG has both Option 201 and Option UN7 (see the following figure). 

In this method, the ESG provides pseudorandom data (PN9 or PN15) that the BER tester 
can recognize. The phone decodes the data and outputs the deframed data via a test 
connector, which is fed back to the ESG for BER measurements.

NOTE This BER test is not using I/Q data, but instead is using a TTL bit stream. 
Option UN7 operates only on bits and not I/Q signals.

Functional Testing of Algorithm Decoding

This section describes real-time functionality tests that can be performed to verify the 
operation of the mobile receiver and its supporting firmware. These tests include the 
following:

• “Unidirectional Messaging and Protocol Development” on page 2-26

• “Unidirectional Paging Channel Protocol Development” on page 2-26

• “Flexible Diagnostic Tests for Firmware” on page 2-26

• “Functional Tests on Single and Multiple Channels” on page 2-26

• “Response to Power Control Data” on page 2-26

Measurement Setup

An example of a measurement setup is shown on page 2-27. Test configurations vary, but 
usually include the following:

• an ESG Option 201

• a mobile receiver

• control and/or measurement equipment

• interconnections
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Unidirectional Messaging and Protocol Development  

Unidirectional means the one-way transmission from the signal generator to a mobile 
phone receiver. To verify messaging and protocol, transmit user-defined data to the mobile 
receiver and analyze how the firmware and hardware respond to the data.

This design activity helps identify firmware or hardware problems.

Unidirectional Paging Channel Protocol Development  

This is a subset of messaging and protocol development. Option 201 enables you to insert 
asynchronous paging messages into the paging channel. This enables the ESG to 
communicate with a mobile receiver in essentially the same way as a base station, which 
simplifies the development and verification of paging commands.

Flexible Diagnostic Tests for Firmware

You can test various portions of firmware, such as testing the following:

• all Walsh code and long code combinations
• all data rates
• convolutional and turbo coding
• any other parameter available

This is useful in regression testing.

Functional Tests on Single and Multiple Channels

You can perform functional call setup tests to ensure that decoding algorithms in the DSP 
are working properly. The test uses the various pilot, sync, and paging channels, and 
confirms that the mobile receiver can properly establish communication.

You can start by setting up a single channel, and systematically progress to a complete 
multi-channel call to verify receiver operation.

Trying one channel at a time helps to isolate design issues. You can also add an external 
fading simulator to verify operation in the midst of fading.

Response to Power Control Data

At all data rates, power control bits are 
transmitted at the same power level as data bits.

When you use a user-defined power control 
sequence, power puncturing occurs to cause the 
mobile phone’s power level to step up a specified 
amount, and then drop back down as shown in the 
example to the right.

You can define the number of steps. In this 
example, power puncturing is set to 4 Up/Dn.

This enables you to monitor the power and response of a mobile phone’s power control 
system. 
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The following figure shows another example of a mobile phone’s power response.

Functional Test Example

The following figure illustrates a functional test setup using an 
Agilent Technologies E7473A CDMA drive test system. For details about the drive test 
system, contact your local Agilent Technologies sales and service office.

The drive system enables you to monitor the signals generated by the ESG, and observe 
details such as pilot channel power, sync messages, and paging messages. 
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Making a Functional Test Measurement with the Drive Test System  

1. Configure the mobile phone as follows:

Connect it to the system and define the hardware project, the phone, and the port.

2. Configure the ESG as follows:

• set the frequency to that of the mobile phone

• set the amplitude to the appropriate level

• configure the pilot channel

• configure the sync channel and appropriate sync type

• configure the paging channel

• optionally, configure fundamental traffic channel(s)

• modify any other parameters as needed (such as PN offset)

3. Turn on the phone, load the driver test software and select the appropriate project.

4. Click the collection softkey, then click the icons titled phone virtual front panel and 
messages virtual front panel.

5. Cycle the phone’s power. This synchronizes it to the ESG and displays the sync and 
paging messages (see Figure 2-3. for an example).

The computer display windows show the transmitter’s signal strength, as well as the 
stream of messages received.

Figure 2-3. Drive Test System Monitoring Pilot, Sync, & Paging Channels
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Optional Testing:  You can test a receiver’s ability to track multiple base stations by 
independently configuring two ESGs as IS-95 or IS-2000 base stations with pilot, sync, 
traffic, and paging channels. A sync message from the mobile phone indicates that it can 
keep track of both base stations and select the one with the stronger pilot signal.

Creating a Synchronous Paging Message 

This section shows how to enter and transmit a user-defined paging message. A CDMA 
base station can be simulated using this feature of the ESG Option 201. 
(See TIA/EIA-95-B Section 7.1.3.4 for additional information.)

The figure above shows an example of a manually entered page message. The message is a 
bit representation of the General page message. See “Understanding the Forward Paging 
Channel” on page 4-17 for details.

Use the following steps to create a paging message.

1. Press Mode > CDMA > CDMA2000 > Link Control > Channel Number > 4 > 
Channel Type F-PCH > Channel Setup.

2. Use the front panel right arrow key to highlight DEFAULT.

3. Press Edit Item > User File > Create File.

4. Enter the bit pattern using the front panel numeric keys. The Offset field in the edit 
screen shows the file length in hexadecimal. Each row has a value of 20 hexadecimal. 

5. Press More > Rename and enter a file name. Press Enter.

6. Press Return to return to the Catalog of Binary/Bit Files. The file appears in the 
catalog listing.

7. Scroll to the created file to highlight it and press Select File. The file name appears in 
the Channel 4 menu screen Data field. 

8. Press Return > Channel State Off On until On is highlighted.

9. Press Return > CDMA2000 Off On until On is highlighted.

10. Press RF On/Off until RF ON is displayed. The signal generator will transmit the paging 
message.
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Reverse Link Test Configurations and Measurements
This section will demonstrate how to configure a single-ESG and a two-ESG test 
configuration. The two configurations will utilize IS-2000 compliant features while using 
an Agilent Technologies E4406A VSA Transmitter Tester for measurement purposes. 
(Refer to the E4406A VSA Transmitter Tester User’s Guide and cdma2000 Measurement 
Guide for specific E4406A measurement information.)

Single-ESG Reverse Link Configuration 

This section will guide you through configuring the ESG for IS-2000 using 4 channels with 
RC3. You will be shown how to step through the Option 201 reverse link menus, set Walsh 
codes, data rates, and data types.

Required Equipment

• 1 Agilent Technologies ESG-D or ESG-DP Family Signal Generator with Options UN8 
and 201

• 1 Agilent Technologies E4406A VSA Series Transmitter Tester with Option B78

• 2 BNC Cables

• 2 Type-N (m) to BNC (f) adapters

Measurement Setup

1. Refer to Figure 2-4. and connect the ESG to the E4406A.

Figure 2-4. Single-ESG Reverse Link Measurement Setup

2. Turn on the ESG and the E4406A VSA transmitter tester.
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Configuring the Single-ESG for Reverse Link

NOTE The following signal generator settings are used for example purposes. 
Change them as needed for your device under test (DUT). 

1. Press Preset (factory defined, not user defined).

2. Press Frequency > 900 > MHz and then press Amplitude > -40 > dBm.

3. Press Mode > Real Time I/Q BaseBand (if it appears) > CDMA > CDMA2000 >
Link Forward Reverse to Reverse.

4. Check that Int is highlighted on the BBG Data Clock Ext Int softkey.

5. Press More (1 of 2).

6. Check that Normal is highlighted on the Phase Polarity Normal Invert softkey.

7. Press More (2 of 2).

The following figure shows the default values for the reverse link data fields (which are 
used for this example). If you need to change these fields, press the Mobile Setup softkey, 
rotate the front panel knob, or press the arrows keys to move the highlight bar to the 
desired field and then press Edit Item. Press Return to revisit the CDMA2000 menu.

The following are brief descriptions of the available fields. Refer to Chapter 3 , “Softkey 
Reference” for more detailed information on each field.

NOTE If a field is grayed out, it cannot be edited.

Radio Config  This displays the current radio configuration (RC). RC1–4 can 
be entered with RC1 and RC2 being IS–95 compatible.
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Filter  This displays the current filter being used. In addition to the 
standard filters (Root Nyquist, Nyquist, Gaussian and User 
FIR), there are two IS–95 filters that can be used with RC3 and 
RC4, IS–95 and IS–95 Mod.

Even Sec Delay  This displays the delay of data transmission relative to the 
internal data clock. This is measured in units of chips with a 0.5 
chip resolution.

Spread Rate  This displays the spread rate being used.

Trigger Advance  This displays the offset in chips that is being used to align the 
RF output with the base station timing signal relative to the 
ESG internal even second clock. This is used to synchronize the 
ESG with the base station.

Trigger Edge  This sets the ESG to trigger on the rising or falling edge of the 
base station timing signal.

Chip Rate  This displays the number of chips being spread and the amount 
of bandwidth being occupied.

LC State  This displays the value of the long code that is available in the 
shift register. Setting a value other than 0 seeds the long code. 
For no long code, set to 00000000000.

LC Mask  This displays the current value for the mask. It is a 42-bit 
binary number that creates the unique identity of the long code 
and determines which values in the LC State are processed.

8. Press Link Control. 

This accesses a channel control menu where the channels can be turned on or off, the 
channel type selected and parameters edited, and the code domain power adjusted.

9. Press the following key sequences to configure the individual channels, starting with 
channel one. The channel parameters are shown in Table 2-4. 

NOTE The Channel Number softkey is always bold. This indicates that you do not 
have to press this softkey to change channel numbers. You can change 
channels by pressing the appropriate number and the Enter softkey, rotating 
the front panel knob, or using the arrow keys.

• 1 > Enter > Channel State Off On to On > Channel Setup > Power >
-7 > dB > Return

• 2 > Enter > Channel State Off On to On > Channel Setup > Power >
-13 > dB > Walsh > 10 > Enter > Data > Edit Item > PN Sequence > PN15 > Return

• 3 > Enter > Channel State Off On to On > Channel Setup > Power >
-10 > dB > Walsh > 14 > Enter > Return

• 4 > Enter > Channel State Off On to On > Channel Setup > Power >
-10 > dB > Walsh > 2 > Enter > Data > Edit Item > PN Sequence > PN15 > 
Data Rate > 19.2 > kbps > Return
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NOTE When setting the R-SCH Walsh code or data rate, ensure that the 
combination of the two is in accordance with IS-2000 specifications. Refer to 
“Reverse Link R-SCH Walsh Codes and Data Rates” on page 4-19 for more 
information.

10. Press Adjust Code Domain Power > Scale To 0dB.

Notice that the power levels have changed on each channel. This has scaled the channel 
power levels to the proper amplitudes for transmission (the sum log value of the new 
power levels equal zero). The power ratios between the channels remain unchanged.

NOTE Adjusting the code domain power will work on active channels only.

11. Press Return. The CDMA2000 menu is now displayed.

12. Press CDMA2000 Off On. On is now highlighted and the CDMA2K and I/Q annunciators 
are showing.

13. Check that the MOD ON annunciator is displayed on the ESG and press RF On/Off. The 
RF ON annunciator is now displayed.

Table 2-4. Reverse Link Single-ESG Channel Parameters for RC3

Channel 
Number

Channel 
Type

Channel 
State

Channel 
Power

Walsh 
Code

Data Data Rate

1 R–PICH On -7.0 dB 0 N/A N/A

2 R–DCCH On -13.0 dB 10 PN15 9.60000 kbps

3 R–FCH On -10.0 dB 14 PN9 9.60000 kbps

4 R–SCH On -10.0 dB 2 PN15 19.2000 kbps
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Configuring the E4406A VSA for a Single-ESG Reverse Link Measurement

This section shows you how to set up the E4406A VSA to display the reverse link ESG 
parameters that were configured in the previous section. 

Perform the following steps to show the code domain display in bit reverse:

1. Press Preset.

2. Set the VSA to use an external reference and ensure that it is set to 10 MHz.

Press: System > Reference > Freq Ref Int Ext 

a. Press 10 > MHz.

b. Press the Freq Ref Int Ext softkey until Ext is underscored.

3. Choose the cdma2000 option.

Press: Mode > More (1 of 2) > cdma2000

4. Set the VSA to receive a mobile signal.

Press: Mode Setup > Radio > Device BTS MS to MS

5. Set the center frequency to 900 MHz.

Press: Frequency > 900 > MHz

6. Set the display span to view the full modulated signal.

Press: SPAN > 1.8 > MHz

7. Select the code domain measurement.

Press: Measure > More (1 of 2) > Code Domain

8. Set the long code mask to zero.

Press: Meas Setup > More (1 of 3) > Long Code Mask > 0 > Done

9. Set the VSA to display bit reverse.

Press: Display > Code Order Bit Reverse

Bit Reverse changes the view so you will see the number of channel indicators on the 
display that matches the number of channels that were transmitted. Whereas the 
Hadamard view can have more channel indicators then the number of channels 
transmitted.

10. Press Restart.

This allows the VSA to take another single sweep measurement after all settings have 
been implemented.
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11. Position a marker to read a channel.

a. Press the Marker hardkey.

b. Starting with zero, count how many spaces to the desired channel from the left side 
of the display and enter the number (if it is on the Q side, 0.5 needs to be added to 
the number; for example 8.5, not 8).

c. Press Enter (softkey or front panel key).

The marker displays a channel’s Walsh code spread factor, Walsh code, symbol rate, and 
power level (indicated as Channel Marker Information on the figure).

12. Set the VSA to measure continuously.

Press: Meas Control > Measure Single Cont to Cont

NOTE The marker is easier to position when the VSA is set to measure a single 
sweep.

The following figure shows the VSA code domain display for bit reverse:

Channel Marker InformationChannel Marker
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Two-ESG Reverse Link Configuration

This section will guide you through configuring the two-ESG configuration for IS-2000 
using 5 channels. Four channels will be configured on ESG 1 and one additional reverse 
supplemental channel (R-SCH1) on ESG 2. The measurements will be made using the 
E4406A VSA Transmitter Tester. 

Required Equipment

• 2 Agilent Technologies ESG-D or ESG-DP Family Signal Generators with Options UN8 
and 201

• 1 Agilent Technologies E4406A VSA Series Transmitter Tester with Option B78

• 11 BNC Cables (See note prior to setup drawing for length requirements)

• 3 BNC Tee adapters

• 1 BNC coupler

• 3 Type-N (m) to BNC (f) adapters

System Configuration Process

The two-ESG system configuration process is divided into the following subsections:

• “Two-ESG Reverse Link Measurement Setup” on page 2-37

• “Configuring ESG 1 for Reverse Link” on page 2-38

• “Configuring ESG 2 for Reverse Link” on page 2-40

• “Adjust the Relative Power Mapping (Two-ESG Reverse Link)” on page 2-42

• “Generate the Signal at the RF Output (Two-ESG Reverse Link)” on page 2-44

• “Configuring the E4406A VSA for a Two-ESG Reverse Link Measurement” on page 2-45
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Two-ESG Reverse Link Measurement Setup

1. Refer to Figure 2-5. and connect the two ESGs and the E4406A VSA.

NOTE The following connections require short cables of equal length to reduce phase 
difference:

Data Clock ESG 1 and ESG 2 Input to RF Output on ESG 2
I Out and Q Out ESG 2 to I Input and Q Input on ESG 1
I Out and Q Out ESG 1 to I Input and Q Input on ESG 1

Figure 2-5. Two-ESG Reverse Link Measurement Setup

2. Turn on the ESGs and the E4406A VSA.
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Configuring ESG 1 for Reverse Link

NOTE The following signal generator settings are used for example purposes. 
Change them as needed for your device under test (DUT). 

1. Press Preset (factory defined not user defined).

2. Press Frequency > 900 > MHz and then press Amplitude > –40 > dBm.

3. Press Mode > Real-time I/Q BaseBand (if it appears) > CDMA > CDMA2000 >
Link Forward Reverse to Reverse.

4. Press the BBG Data Clock Ext Int softkey. Ext is now highlighted. 

5. Press More (1 of 2).

6. Check that Normal is highlighted on the Phase Polarity Normal Invert softkey.

7. Press More (2 of 2).

The following figure displays the default values for the CDMA2000 reverse link mobile 
setup data fields which are used for ESG 1. If there is a need to change any of the field 
values, press the Mobile Setup softkey, rotate the front panel knob or press the arrow 
keys to move the highlight bar to the desired field and then press Edit Item. Press Return 
to reopen the CDMA200 menu.

The following are brief descriptions of the available fields. Refer to Chapter 3 , “Softkey 
Reference” for more detailed information on each field.

NOTE If a field is grayed out, it cannot be edited.

Radio Config  This displays the current radio configuration (RC). RC1–4 can 
be entered with RC1 and RC2 being IS–95 compatible.
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Filter  This displays the current filter being used. In addition to the 
standard filters (Root Nyquist, Nyquist, Gaussian and User 
FIR), there are two IS–95 filters that can be used with RC3 and 
RC4, IS–95 and IS–95 Mod.

Even Sec Delay  This displays the delay of data transmission relative to the 
internal data clock. This is measured in units of chips with a 0.5 
chip resolution.

Spread Rate  This displays the spread rate being used and cannot be edited.

Trigger Advance   This displays the offset in units of chips that is being used to 
align the RF output with the base station timing signal relative 
to the ESG internal even second clock. This is used to 
synchronize the ESG with the base station.

Trigger Edge  This sets the ESG to trigger on the rising or falling edge of the 
base station timing signal.

Chip Rate  This displays the number of chips being spread and the amount 
of bandwidth being occupied.

LC State  This displays the value of the long code that is available in the 
shift register. Setting a value other than 0 seeds the long code. 
For no long code, set to 00000000000.

LC Mask  This displays the current value for the mask. It is a 42-bit 
binary number that creates the unique identity of the long code 
and determines which values in the LC State are processed.

8. Press Link Control. 

This accesses a channel control menu where the channels can be turned on or off, the 
type selected and edited, and the code domain power adjusted.

9. Press the following key sequences to configure the individual channels starting with 
channel one. The channel parameters are shown in Table 2-5. 

NOTE The Channel Number softkey is always bold. This indicates that you do not 
have to press this softkey to change channel numbers. You can change 
channels just by pressing the appropriate number and the Enter softkey, 
rotating the front panel knob, or using the arrow keys.

• 1 > Enter > Channel State Off On to On > Channel Setup > Power >
-7 > dB > Return

• 2 > Enter > Channel State Off On to On > Channel Setup > Power >
-13 > dB > Walsh > 10 > Enter > Data > Edit Item > PN Sequence > PN15 > Return

• 3 > Enter > Channel State Off On to On > Channel Setup > Power >
-10 > dB > Walsh > 7 > Enter > Return

• 4 > Enter > Channel State Off On to On > Channel Setup > Power >
-10 > dB > Walsh > 2 > Enter > Data >   Edit Item > PN Sequence > PN15 > 
Data Rate > 19.2 > kbps > Return
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NOTE When setting the R-SCH Walsh code or data rate, ensure that the 
combination of the two is in accordance with IS-2000 specifications. Refer to 
“Reverse Link R-SCH Walsh Codes and Data Rates” on page 4-19 for more 
information.

10. Press Return. The CDMA2000 top menu is now displayed.

Configuring ESG 2 for Reverse Link

In addition to sourcing part of the CDMA signal, ESG 2 is used as the data clock for both 
ESGs.

1. Press Preset (factory defined not user defined).

2. Press Ampl > ALC Off On to Off.

The automatic leveling control is turned off when two ESGs are used together.

3. Press Frequency > 1.2288 > MHz and then press Amplitude > 20 > dBm.

This sets ESG 2 to be used as the chip clock and sets the amplitude to provide near TTL 
voltages to drive the data clock.

4. Press Mod On/Off. The MOD OFF annunciator is now displayed.

5. Press Mode > Real-time I/Q BaseBand (if it appears) > CDMA > CDMA2000 >
Link Forward Reverse to Reverse.

6. Press the BBG Data Clock Ext Int softkey. Ext is now highlighted.

7. Press More (1 of 2).

8. Press the Phase Polarity Normal Invert softkey. Invert is now highlighted.

9. Press More (2 of 2).

10. Press the Mobile Setup softkey.

11. Press the appropriate arrow key or rotate the front panel knob to move the highlight 
bar to the Trigger Edge data field.

12. Press Edit Item > Rising > Return. 

Table 2-5. Reverse Link ESG 1 Channel Parameters for RC3

Channel 
Number

Channel 
Type

Channel 
State

Channel 
Power

Walsh 
Code

Data Data Rate

1 R–PICH On -7.0 dB 0 N/A N/A

2 R–DCCH On -13.0 dB 10 PN15 9.60000 kbps

3 R–FCH On -10.0 dB 7 PN9 9.60000 kbps

4 R–SCH On -10.0 dB 2 PN15 19.2000 kbps
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The following figure displays the current mobile setup field values that will be used for 
ESG 2 in this example.

Notice that Rising is now displayed in the Trigger Edge data field.

13. Press Link Control. 

14. Press the following key sequences to configure channel 2. The channel parameters are 
shown in Table 2-6. 

• 2 > Enter > Channel Type R-DCCH R-SCH to R-SCH > Channel State Off On to On > 
Channel Setup > Power > -9 > dB > Walsh > 6 > Enter > Data Rate > 38.4 > kbps > 
Data > Edit Item > PN Sequence > PN15 > Return

15. Press Return. The CDMA2000 top menu is now displayed.

Table 2-6. Reverse Link ESG 2 Channel Parameters for RC3

Channel 
Number

Channel 
Type

Channel 
State

Channel 
Power

Walsh 
Code

Data Data Rate

2 R–SCH On -9.0 dB 6 PN15 38.4000 kbps
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Adjust the Relative Power Mapping (Two-ESG Reverse Link)

Once the signal generators are configured as described in the previous sections, use the 
following steps to perform the relative power mapping procedure. Relative power mapping 
assures proper channel power levels between the two ESGs and an overall code domain 
power of 0 dB. For more information, see “Forward and Reverse Link Relative Power 
Mapping.” on page 4 -16.

1. Return to the CDMA2000 menu and press 2 Box Setup on both ESGs.

2. Refer to the following figures. Highlight the Voltage Other ESG data field on ESG 1 
and enter the Voltage This ESG value from ESG 2. Press V to terminate the entry.

The individual ESG voltage adjustments are made to align the channel voltages 
between the signal generators. This in turn adjusts the I/Q voltage scale. While this 
scales the channels relative to each other, it does not ensure the 0 dBm power level 
required for the code domain. This will be done later in the process.

3. Highlight the Voltage Other ESG data field on ESG 2 and enter the Voltage This 
ESG value from ESG 1. Press V to terminate the entry.

Notice that the IQ Voltage Scale value has changed on ESG 2.

a. Enter this value here. b. Enter this value here.

ESG 2

ESG 1
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4. Refer to the following figures. Highlight the % Power Other ESG data field on ESG 1 
and enter the % Power This ESG value from ESG 2. Press Enter to terminate the entry. 

The percent power adjustment sets the parameters that will allow the scale to 0 dB 
function to scale all channels to 0 dB. This aligns the displayed power of both ESGs to 
match the code domain measurement values on the transmitter tester.

5. Highlight the % Power Other ESG: data field on ESG 2 and enter the % Power This 
ESG value from ESG 1. Press Enter to terminate the entry.

6. Press Scale to 0dB on both ESGs. 

The voltage and power values may change to reflect the adjusted power levels.

NOTE Pressing Scale To 0dB on both ESGs scales the individual channel power 
levels so that the sum of the code domain power generated by both ESGs 
equals 0 dB. This does not change the total power, as set by the Amplitude key.

7. Press Return on both ESGs to open the CDMA2000 menu.

a. Enter this value here. b. Enter this value here.

ESG 2

ESG 1
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Generate the Signal at the RF Output (Two-ESG Reverse Link)

This section describes the proper order that must be used to turn on the RF output and the 
Option 201 (cdma2000 personality). If for any reason the signal from ESG 2 is interrupted, 
whether by turning off the RF output, cdma2000 personality or ESG power, then the 
following process must be repeated.

1. Perform the following steps for ESG 2:

a. Press RF On/Off. The RF On annunciator is now displayed.

b. Press CDMA2000 Off On. On is now highlighted and the I/Q and CDMA2K 
annunciators are displayed.

NOTE If you generate the IS-2000 waveform on ESG 1 before ESG 2, an error 
message will appear.

2. Perform the following steps for ESG 1:

a. Press CDMA2000 Off On. On is now highlighted and the I/Q and CDMA2K 
annunciators are displayed.

b. Press I/Q > I/Q Source > Ext I/Q

This combines the baseband signals from both ESGs into one. To return to the 
CDMA2000 menu, press Mode > Real-time I/Q BaseBand (if it appears) > CDMA > 
CDMA2000.

c. Press RF On/Off. The RF On annunciator is now displayed.
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Configuring the E4406A VSA for a Two-ESG Reverse Link Measurement

This section shows you how to set up the E4406A VSA to display the reverse link ESG 
parameters that were configured in the previous section. 

Perform the following steps to show the code domain display in bit reverse:

1. Press Preset.

2. Select the internal VSA frequency reference and ensure that it is set to 10 MHz.

Press: System > Reference > Freq Ref Int Ext 

a. Press 10 > MHz.

b. Press the Freq Ref Int Ext softkey until Int is underscored.

c. Ensure that On is underscored on the 10 MHz Out On Off softkey. If Off is underscored, 
press the 10 MHz Out On Off softkey until On is underscored.

3. Choose the cdma2000 option.

Press: Mode > More (1 of 2) > cdma2000

4. Set the VSA to receive a mobile signal.

Press: Mode Setup > Radio > Device BTS MS to MS

5. Set the center frequency to 900 MHz.

Press: Frequency > 900 > MHz

6. Set the display span to view the full modulated signal.

Press: SPAN > 1.8 > MHz

7. Select the code domain measurement.

Press: Measure > More (1 of 2) > Code Domain

8. Set the long code mask to zero.

Press: Meas Setup > More (1 of 3) > Long Code Mask > 0 > Done

9. Set the VSA to display bit reverse.

Press: Display > Code Order Bit Reverse

Bit Reverse changes the view so you will see the number of channel indicators on the 
display that matches the number of channels that were transmitted. Whereas the 
Hadamard view can have more channel indicators then the number of channels 
transmitted.

10. Press Restart.

This allows the VSA to take another single sweep measurement after all settings have 
been implemented.
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11. Position a marker to read a channel.

a. Press the Marker hardkey.

b. Starting with zero, count how many spaces to the desired channel from the left side 
of the display and enter the number (if its on the Q side, 0.5 needs to be added to the 
number; for example 8.5, not 8).

c. Press the Enter softkey or front panel key.

The marker displays a channel’s Walsh code spread factor, Walsh code, symbol rate, and 
power level (indicated as Channel Marker Information on the figure).

12. Set the VSA to measure continuously.

Press: Meas Control > Measure Single Cont to Cont

NOTE The marker is easier to position when the VSA is set to measure a single 
sweep.

The following figure shows the VSA code domain display for bit reverse using a reverse 
link, 5-channel, two-ESG configuration.

Channel Marker InformationChannel Marker
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Reverse Link Bit Error Rate (BER) and Frame Error Rate (FER) 
Tests

This section will demonstrate a generic test setup which applies to both IS-95 and IS-2000 
applications. The setup can be used to perform the following tests:

• Bit Error Rate (BER)

BER is the ratio of the number of bit errors to the total number of bits sent in a given 
time interval. The BER test allows you to check the BTS ability to properly receive and 
demodulate a signal.

This is accomplished by comparing the MS bit sequence output with a known reference 
bit sequence.

• Frame Error Rate (FER)

FER provides a ratio of the number of frames received with CRC errors to those without 
errors.

NOTE The ability to perform these tests properly is based upon the operator using 
known data that is common to both the ESG and the customer-supplied 
device. The customer-supplied device is used as the comparator.

The following measurements can be performed in conjunction with the BER or FER tests.

• Sensitivity and Dynamic Range

The sensitivity measurement provides the minimum power level at the BTS that 
results in a FER and does not exceed a specified value.

For example, the test could determine the power level required to achieve less than 
0.5% FER. Sensitivity helps to characterize the ability of the BTS to demodulate a 
low-level signal, and is a key measure of merit in receiver design; the higher the 
sensitivity of the BTS, the more accurately it receives signals, and the less power it 
requires from the base station.

Similarly, the dynamic range of the BTS is the input power range over which the FER 
does not exceed a specific value.

• Intermodulation

This test measures the ability of the BTS to receive a signal in the presence of two 
interfering CW tones that produce intermodulation products in the band of the desired 
CDMA signal. FER provides the measure of merit.

• Adjacent Channel Selectivity

This test measures the sensitivity of the BTS in the presence of an adjacent channel 
signal.
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Reverse Link Test Setup

The following test setup can be performed using either the single- or the two-ESG 
configuration. The two-ESG configuration would be used if an error rate test is needed for 
the additional R-SCH1. 

NOTE For a two-ESG configuration, the even second clock and the 10 MHz reference 
are connected to ESG 1, while the chip clock, if it is being used in place of the 
10 MHz reference, is connected to both ESGs.

1. Setup the equipment as shown in the above diagram and configure appropriately, 
depending on the connections and the number of ESGs used (refer to “Single-ESG 
Reverse Link Configuration” on page 2-30 or “Two-ESG Reverse Link Configuration” on 
page 2-36).

NOTE If an external chip clock is being connected to the DATA CLOCK BNC input, 
on the ESG front panel, instead of using an external 10 MHz reference, 
ensure that the BBG Data Clock Ext Int softkey has Ext highlighted.

2. Select the appropriate Trigger Edge field state (falling or rising) for the input BTS 
even second clock.

NOTE: Connect either a 10 MHz reference or a
chip clock source, but not both.

*

*

*
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3. Configure and turn on the channels to be tested, ensuring that the pilot channel is used 
in RC3 and RC4.

4. Turn on the CDMA2000 personality and ensure that the I/Q annunciator is displayed.

NOTE If this is a two-ESG configuration, refer to “Generate the Signal at the RF 
Output (Two-ESG Reverse Link)” on page 2-44 for instructions on activating 
the CDMA2000 personality.

5. Place the BTS in test mode.

6. Request the BTS to report the number of frames, symbols, or bits in error.

7. Perform any of the measurements as needed.
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Troubleshooting
Use the following checklists to help troubleshoot problems with Option 201.

NOTE In some cases, the ESG may allow invalid channel coding settings without 
reporting an error. If you experience problems, ensure that the settings of the 
ESG conform to IS-2000 standards.

Tips and Tricks

There is a Tips and Tricks section located on the Agilent Technologies ESG support web 
site that may provide you assistance in the operation of the Option 201 firmware. Perform 
the following steps to reach the appropriate web page:

1. Go to www.agilent.com/find/esg.

2. Select your ESG model under the Products list. 

3. Select Software Patches and Drivers in the next window under the Additional 
Information list.

4. Select the firmware version currently loaded on your ESG, shown under the Software 
Updates section.

The firmware version is displayed when the ESG is powered on or it can be viewed by 
pressing the following keys and viewing the listed field:

Utility > Instrument Info/Help Mode > Diagnostic Info > Firmware Revision

5. Locate the Tips and Tricks section and follow any instructions that may be appropriate 
to your situation.

Cannot Turn on CDMA2000

❏ At least one cdma2000 channel must be on.

ESG 10 MHz External Reference will not Lock

❏ The down-converted 10 MHz reference from the transmitter tester (signal analyzer), is 
not accurate enough to allow the ESG to lock on to it.

Can’t See Channels Displayed on Transmitter Tester

Ensure that the following are true:

❏ cdma2000 channels are on.

❏ cdma2000 personality is on (CDMA2K and I/Q annunciators are displayed). I/Q must be 
toggled on to modulate the RF output.

❏ ESG RF output is on (RF ON annunciator is displayed).

❏ ESG RF is modulated (MOD ON annunciator is displayed). On a two-ESG configuration, 
this would apply to ESG 1.
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❏ BTS is underscored for forward link and MS is underscored for reverse link on the 
Device BTS MS softkey located on the E4406A VSA.

Mode Setup > Radio > Device BTS MS

❏ The long code mask for reverse link (MS) on the E4406A VSA is set to zero.

❏ ESG baseband reference source is set to external (BBG Data Clock Ext Int softkey, Ext is 
highlighted) on both ESGs when the two-ESG configuration is used.

❏  ESG carrier signal power is higher than the receiver’s noise floor. (Increase the ESG 
carrier signal power level if the signal cannot be seen on the transmitter tester.)

❏ ESG OCNS channel power level is sufficient to increase the code domain power to the 
appropriate level without interfering with the other channels. (OCNS channel power 
may need to be reduced.)

❏ ESG active channels do not have conflicting Walsh codes.

❏ ESG 2 was turned on prior to ESG 1. Refer to the appropriate two-ESG RF signal 
generation procedure (“Generate the Signal at the RF Output (Two-ESG Forward 
Link)” on page 2-17 or “Generate the Signal at the RF Output (Two-ESG Reverse Link)” 
on page 2-44). If ESG 2 has been turned off and then turned back on while ESG 1 is 
transmitting, the signal will be affected.

❏ I/Q Source has been set to Ext I/Q for ESG 1, on a two-ESG configuration.

I/Q > I/Q Source > Ext I/Q

When Programming Two ESGs, Both Signal Generators Display the Same Values

❏ Each ESG must have a unique GPIB address.

Utility > GPIB/RS2-32 > GPIB Address

IQ Map Rotation Does Not Switch from Std. to Rotated

❏ Turn off 1 or 2 of the 4 channels. IQ Map Rotation is not allowed with 4 channels on.

Reverse Link Frame Error Rate too High

❏ Check that the relative power level difference among the active channels is not 
significant. 

❏ Ensure that the Walsh code and data rate combination are compliant with IS-2000 
specifications.
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3 Softkey Reference

This chapter lists, in alphanumerical order, the softkeys and associated data fields 
available with Option 201. 

Navigate among the data field entries using either the front panel knob or the arrow keys. 

For the SCPI commands that duplicate some of these softkeys remotely, see Chapter 5, 
"Remote Programming and Examples.”

To access the Option 201 softkeys, 
use the front panel Mode key.

If your signal generator has 
multiple options, the softkeys in 
the first menu enable you to 
access the various options. 
Press Real Time I/Q BaseBand to 
display the CDMA softkey.

NOTE

• The key paths provided in this chapter do not include the 
Real Time I/Q BaseBand softkey.

• If you do not see a softkey in the indicated menu, it may be on the 
next page of that menu; to display the next page, press the More 
softkey. Hardkeys and softkeys are denoted by Bold text; data fields 
by Courier Font. 
For example:

•

Location: Mode > CDMA > CDMA2000 > BTS Setup > Filter 

• All softkey and data field location pathways assume a factory preset 
condition.

                 Data FieldSoftkeysHardkey
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Symbols

% Power Other ESG

This field is used when a two-ESG system is being configured. After 
setting the channel powers of both ESGs, edit this field by entering the 
percent power value of the ESG that is paired with this one. The 
entered value sets up the parameters that will allow the scale to 0 db 
function to scale all active channels to 0 dB. See “Adjust the Relative 
Power Mapping (Two-ESG Forward Link)” on page 2-15.

NOTE For the single ESG setup, this field needs to be 0.0 percent.

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
2 Box Setup > % Power Other ESG

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > 2 Box Setup > % Power Other ESG

% Power This ESG

This field displays the percent power value of the ESG and is used when 
configuring a two-ESG system. Enter this value in the Percent Power 
Other ESG data field of the ESG that is paired with this ESG. See 
“Adjust the Relative Power Mapping (Two-ESG Forward Link)” 
on page 2-15.

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
2 Box Setup > % Power This ESG

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > 2 Box Setup > % Power This ESG
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Numerics

2 Box Setup

This key displays a table editor and softkeys that allow you to select 
and modify the parameters of the IQ voltage scale as well as adjust the 
total code domain power to 0 dB for the two-ESG configuration. 
See “IQ Voltage Scale” on page 3-51.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > 2 Box Setup

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > 2 Box Setup

307.2 Khz Clock

This key selects a 307.2 kHz clock as the output at the DATA CLK OUT 
rear panel BNC/SMB connector. Reverse link radio configuration 1 or 2 
is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Mobile Setup > Radio Config > 1 or 2 > Enter > Return > BNC MUX 
Settings > Data Clk Out > 307.2 Khz Clock

4.8 Khz Clock

This key selects a 4.8 kHz clock as the output at the DATA CLK OUT 
rear panel BNC/SMB connector. Reverse link radio configuration 1 or 2 
is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Mobile Setup > Radio Config > 1 or 2 > Enter > Return > BNC MUX 
Settings > Data Clk Out > 4.8 Khz Clock

5ms Clock

This key selects a 5 ms clock as the output at the DATA CLK OUT rear 
panel BNC/SMB connector. Reverse link radio configuration 3 or 4 is 
required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Clk Out > 5ms Clock
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10ms Clock

This key selects a 10 ms clock as the output at the DATA CLK OUT 
rear panel BNC/SMB connector. Reverse link radio configuration 3 or 4 
is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Clk Out > 10ms Clock

20ms Clock

This key selects a 20 ms clock as the output at the DATA CLK OUT 
rear panel BNC/SMB connector. Available in reverse link radio 
configurations 1 through 4.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Clk Out > 20ms Clock

40ms Clock

This key selects a 40 ms clock as the output at the DATA CLK OUT 
rear panel BNC/SMB connector. Reverse link radio configuration 3 or 4 
is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Clk Out > 40ms Clock

80ms Clock

This key selects an 80 ms clock as the output at the DATA CLK OUT 
rear panel BNC/SMB connector. Available in reverse link radio 
configuration 1 through 4.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Clk Out > 80ms Clock
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A

Adjust Code Domain Power

This key accesses a menu where you can adjust the code domain power 
to 0 dB, while either maintaining the existing power ratios or setting all 
power levels equal to one another.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
Adjust Code Domain Power

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > Adjust Code Domain Power

APCO 25 C4FM

This key, located in the Select (Filter) menu, selects an APCO 25 
specified C4FM filter. This is a Nyquist filter with an alpha of 0.2 that 
is combined with a shaping filter. 

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > APCO 25 C4FM

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
APCO 25 C4FM

Apply Bit Errors

This key appears in two places. Option UN7 is required.

Create File/Edit File Menu

This menu enables you to enter a specific number of bit errors or a 
percentage of bit errors in the current file.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Create File or Edit File > Apply Bit Errors
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Bit Errors Menu

The Apply Bit Errors key, in the Bit Error Menu, applies the currently 
selected bit-error percentage or number of bit errors to the current file.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Bit Errors (percent value) or Bit Errors (numeric 
value) > Apply Bit Errors

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Create File or Edit File > Apply Bit Errors > 
Bit Errors (percent value) or Bit Errors (numeric value) > Apply Bit Errors

Arb

This key selects a long code signal that repeats, approximately, every 26 
ms and is compatible with Arb formats.

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > LC Generation > Edit Item > Arb
3-6 Real-Time cdma2000 Personality User’s and Programming Guide



ESG Family Signal Generators Softkey Reference
Option 201 B
B

BBG Data Clock Ext Int

This key selects external or internal mode for the baseband generator 
data clock source. 

Ext  External uses the signal applied to the DATA CLOCK 
input as the data clock source.

Int  Internal uses the internal data clock as the data clock 
source.

Default: Int

Softkey Location: Mode > CDMA > CDMA2000 > BBG Data Clock Ext Int

Beta

This key is activated automatically when you select the Kaiser 
windowing function. The default Beta factor provides a good solution 
for optimizing out-of-band performance, adjacent channel power (ACP), 
without seriously compromising passband performance, error vector 
magnitude (EVM). 

Changing the Beta factor adjusts the trade-off between ACP and EVM:

• Decreasing the value improves EVM.

• Increasing the value improves ACP.

Range: 1.000 through 10.000

Default: 4.000

Softkey Location: Mode > CDMA > CDMA2000 > BTS Setup > Filter > 
Edit Item > Define User FIR > Load Default FIR > 
Root Nyquist, Nyquist, Gaussian or Rectangle > Window > Kaiser > Beta
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Bit Errors 
(numeric value)

This key enables you to specify the number of bit errors applied to the 
current file when you press the Apply Bit Errors terminator softkey. The 
percent Bit Errors softkey also updates to reflect the percentage of bit 
errors you have chosen.

Range: 0 through 98812

Default: 0

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Bit Errors (numeric value)

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Create File or Edit File > Apply Bit Errors > 
Bit Errors (numeric value)

Bit Errors 
(percent value)

This key enables you to specify the percentage of bit errors applied to 
the current file when you press the Apply Bit Errors terminator softkey. 
The numeric value Bit Errors softkey also updates to reflect the number 
of bit errors you have chosen. 

Range: 0.00 to 100

Default: 0.00

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH or F-PCH > 
Channel Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Bit Errors (percent value)

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Create File or Edit File > Apply Bit Errors > 
Bit Errors (percent value) 
3-8 Real-Time cdma2000 Personality User’s and Programming Guide



ESG Family Signal Generators Softkey Reference
Option 201 B
BNC MUX Settings

This key accesses a menu from which you can modify the output of the 
following rear panel BNC/SMB connectors:

• EVENT 1 (Forward and Reverse Link)

• DATA OUT (Forward and Reverse Link)

• DATA CLK OUT (Reverse Link Only)

• SYMBOL SYNC OUT (Reverse Link Only)

Softkey Location (Forward): Mode > CDMA > CDMA2000 > 
BNC MUX Settings

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Settings

BTS Setup

This key enables a table editor from which you can select and modify 
the parameters of the base transceiver station. Highlight the parameter 
you want to change and press the Edit Item softkey. Press a softkey or 
use the numeric keypad to change values contained in the table and 
press the appropriate softkey to terminate the entry.

The following figure shows an example of the forward link display for 
the BTS setup table editor.

Softkey Location: Mode > CDMA > CDMA2000 > BTS Setup
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C

Cdma Freq

This field displays the current CDMA channel frequency used to 
communicate with the mobile. To change the frequency, press the 
Edit Item softkey and enter the new value. 

Range: 0 through 2047

Default: 50

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > Cdma Freq

CDMA2000 

This key selects an advanced derivative of the TIA/EIA-95-B CDMA 
system. The interim standard name is IS-2000. “cdma2000” is the 
commercial name for the system.

Softkey Location: Mode > CDMA > CDMA2000

CDMA2000 
Off On

This key turns the cdma2000 modulation on or off. One channel, at 
least, must be on before the switching on cdma2000.

Default: Off

Softkey Location: Mode > CDMA > CDMA2000 > CDMA2000 Off On

Channel Number

This key selects the channel to be configured. Four channel selections 
are available, each corresponding to a CDMA channel type. 

Range: 1 through 4

Default: 1

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
Channel Number

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > Channel Number
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Channel Setup

This key moves the cursor to the table editor of the display from which 
you can select and modify the parameters of the selected channel. 

The ESG can be configured with up to four different channels or seven 
in a two-ESG solution depending on the radio configuration and link 
selection (forward or reverse).

Channel 1, Forward Link: 

Channel 1 has one channel type, forward pilot channel (F-PICH) and is 
available in radio configurations (RC) 1 through 5.

F-PICH is used to provide a phase reference for coherent 
demodulation and provide signal strength adjustments from the 
base station to the mobile.

The data field that you are able to configure and set up is listed below. 

For information on the data field, refer to the data field name in this 
chapter.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 
Channel Setup

Channel 1, Reverse Link:

Channel 1 has four different channel types: reverse access channel 
(R-ACH), reverse fundamental channel (R-FCH), reverse supplemental 
channel (R-SCH), and reverse pilot channel (R-PICH). These channel 
types are used by the mobile to communicate to the base station.

For Channel 1, R-ACH, R-FCH, and R-SCH are available only in radio 
configurations (RC) 1 and 2. R-PICH is available only in RC 3 and RC 4.

R-ACH is used to communicate short signals for call origination, 
responses to pages, or registrations. 

R-FCH is used to communicate higher-level data and control 
information.

R-SCH is used, in conjunction with R-FCH and other supplemental 
channels, to communicate higher data rate services.

R-PICH is used to provide a phase reference for coherent 
demodulation and provide signal strength adjustments.

Data Field F-PICH

Power RC 1-5
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The data fields that you are able to configure and set up are listed 
below for each channel type.

NOTE If RC 1 or 2 is selected, only a single selectable channel is available.

For information on each data field, refer to the data field name in this 
chapter.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Link Control > Channel Setup

Channel 2, Forward Link:

Channel 2 has two different channel types, forward supplemental channel 
(F-SCH) and forward synchronization channel (F-SYNC). For Channel 2, 
F-SCH and F-SYNC are available in radio configurations 1 through 5.

F-SCH is used, in conjunction with F-FCH or F-SCH, to 
communicate higher data rate services.

F- SYNC is used to provide a phase reference for coherent 
demodulation and provide signal strength adjustments.

The data fields that you are able to configure and set up are listed 
below for each channel type.

Data 
Fields

R-ACH R-FCH R-PICH R-SCH

Data RC 1-2 RC 1-2 RC 1-2

Data 
Rate

RC 1-2 RC 1-2

Frame 
Offset

RC 1-2 RC 1-2 RC 1-2 

Gating 
Rate

RC 3-4

PCB Data RC 3-4

Power RC 1-2 RC 1-2 RC 3-4 RC 1-2

Data Fields F-SCH F-SYNC

CDMA Freq RC 1-5

Data RC 3-5

Data Rate RC 3-5

DAYLT RC 1-5

F-SYNCH Type RC 1-5

Frame Offset RC 3-5
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For information on each data field, refer to the data field name in this 
chapter.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 2 > Enter > 
Channel Setup

Channel 2, Reverse Link:

Channel 2 has two different channel types, reverse dedicated control 
channel (R-DCCH) and reverse supplemental channel (R-SCH).

For Channel 2, R-DCCH and R-SCH are available only in radio 
configurations 3 and 4. 

R-DCCH is used to communicate higher-level data and control 
information.

R-SCH is used, in conjunction with the R-FCH, to communicate 
higher data rate services in the two ESG solution for cdma2000. If 
you select R-SCH, it will disable all other channels in the ESG.

LC Mask RC 3-5

LP_SEC RC 1-5

LTM_OFF RC 1-5

MIN_P_Rev RC 1-5

MSG Type RC 1-5

NID RC 1-5

P_PREV RC 1-5

Power RC 3-5 RC 1-5

PRAT RC 1-5 

QOF RC 3-5

Radio Config RC 3-5

Reserved RC 1-5

SID RC 1-5

SYS TIME RC 1-5

Turbo Coding RC 3-5

Walsh RC 3-5 RC 1-5

Data Fields F-SCH F-SYNC
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The data fields that you are able to configure and set up are listed 
below for each channel type.

For information on each data field, refer to the data field name in this 
chapter.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Link Control > 2 > Enter > Channel Setup

Channel 3, Forward Link:

Channel 3 has two different channel types, forward fundamental 
channel (F-FCH) and orthogonal channel noise simulator (OCNS). 

For Channel 3, F-FCH is available in radio configuration 1 through 5. 
OCNS works with channels that operate in RC 3 through RC 5.

F-FCH is used to communicate a combination of primary data, 
secondary data, signaling, and power control information.

OCNS is used to provide simulated noise in the channel.

The data fields that you are able to configure and set up are listed 
below for each channel type.

Data Fields R-DCCH R-SCH

Data RC 3-4 RC 3-4

Data Rate RC 3-4 RC 3-4

Frame Length RC 3-4 RC 3-4 

Frame Offset RC 3-4 RC 3-4

Power RC 3-4 RC 3-4

Turbo Coding RC 3-4

Walsh RC 3-4 RC 3-4

Data Fields F-FCH OCNS

Data RC 1-5

Data Rate RC 1-5

Frame Offset RC 1-5

LC Mask RC 1-5

PCntrl 
(Up/Dn)

RC 1-5

P Puncturing RC 1-5

Power RC 1-5 RC 3-5

QOF RC 1-5
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For information on each data field, refer to the data field name in this 
chapter.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 3 > Enter > 
Channel Setup

Channel 3, Reverse Link:

Channel 3 has one channel type, reverse fundamental channel (R-FCH) 
and is available only in radio configurations 3 and 4.

R-FCH is used to communicate higher-level data and control 
information. R-FCH can be used in conjunction with supplemental 
channels to communicate higher data rate services.

The data fields that you are able to configure and set up are listed 
below.

For information on each data field, refer to the data field name in this 
chapter.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Link Control > 3 > Enter > Channel Setup

Radio Config RC 1-5

Walsh RC 1-5 RC 3-5

Data Fields R-FCH

Data RC 3-4

Data Rate RC 3-4

Frame Length RC 3-4 

Frame Offset RC 3-4

Power RC 3-4

Walsh RC 3-4

Data Fields F-FCH OCNS
Real-Time cdma2000 Personality User’s and Programming Guide 3-15



Softkey Reference ESG Family Signal Generators
C Option 201
Channel 4, Forward Link:

Channel 4 has three different channel types, forward paging channel 
(F-PCH), forward supplemental channel (F-SCH), and quick paging 
channel (QPCH). 

For Channel 4, F-PCH is available in radio configurations 1 through 5. 
F-SCH and QPCH are available only in RC 3 through RC 5.

F-PCH is used to communicate control information and send pages 
from the base station to the mobile.

F-SCH is used to communicate higher rate data and control 
information.

QPCH is used to alert the mobile to receive a forward paging channel 
in the paging frame.

The data fields that you are able to configure and set up are listed 
below for each channel type.

For information on each data field, refer to the data field name in this 
chapter.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 4 > Enter > 
Channel Setup

Data Fields F-PCH F-SCH QPCH

Config Change RC 3-5 RC 3-5

Data RC 1-5 RC 3-5

Data Coding RC 3-5

Data Rate RC 1-5 RC 3-5 RC 3-5 

Frame Offset RC 3-5

LC Mask RC 1-5 RC 3-5

Paging 
Indicator

RC 3-5 RC 3-5

Power RC 1-5 RC 3-5 RC 3-5

QOF RC 3-5

RC RC 3-5

Turbo Coding RC 3-5

Walsh RC 1-5 RC 3-5 RC 3-5
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Channel 4, Reverse Link:

Channel 4 has three different channel types: reverse common control 
channel (R-CCCH), reverse enhanced access channel (R-EACH), and 
reverse supplemental channel (R-SCH).

For Channel 4, R-CCCH, R-EACH, and R-SCH are available only in 
radio configurations 3 and 4. 

R-CCCH is used to communicate digital control information from the 
mobile to the base station.

R-EACH is used to communicate short messages.

R-SCH is used with the R-FCH to communicate higher data rate 
services in the two-ESG solution for cdma2000. The R-SCH can be 
also used in a single-ESG solution.

The data fields that you are able to configure and set up are listed 
below for each channel type.

For information on each data field, refer to the data field name in this 
chapter.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Link Control > 4 > Enter > Channel Setup

Data Fields R-CCCH R-EACH RSCH

Data RC 3-4 RC 3-4 RC 3-4

Data Rate RC 3-4 RC 3-4 RC 3-4

Frame Length RC 3-4 RC 3-4 RC 3-4

Frame Offset RC 3-4 RC 3-4 RC 3-4

Power RC 3-4 RC 3-4 RC 3-4

Turbo Coding RC 3-4

Walsh RC 3-4 RC 3-4 RC 3-4
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Channel State 
Off On

This key turns the channel operating state off or on. 

Default: Off

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
1, 2, 3, or 4 > Enter > Channel State Off On

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 1, 2, 3, or 4 > Enter > 
Channel State Off On

Softkey Location (for Reverse RC 1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel State Off On 

Channel Type

This key accesses a menu from which you can select different channel 
types.

Forward:

Default:*

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
1, 2, 3, or 4 > Enter > Channel Type 

Channel 
Type

Chan. #1 Chan. #2 Chan. #3 Chan. #4

F-FCH RC 1-5, 3*

F-PCH RC 1-5

F-PICH RC 1-5, 3*

F-SCH RC 3*-5 RC 3*-5

F-SYNCH RC 1-5

OCNS RC 3-5

QPCH RC 3-5
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Reverse:

Default: *

**Only for two-ESG solution.

Softkey Location (Reverse RC 1 & RC 2): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Radio Config > 1 or 2 > Enter > 
Return > Link Control > Channel Type

Softkey Location (Reverse RC 3): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2 or 4 > Enter > Channel Type

Softkey Location (Reverse RC 4): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Radio Config > 4 > Enter > 
Return > Link Control > 2 or 4 > Enter > Channel Type

Channel Type 
F-FCH OCNS

This key appears when forward channel 3 is the active channel. This 
key selects either a forward fundamental channel or an orthogonal 
noise simulator channel.

F-FCH  The forward fundamental channel is the primary traffic 
channel for voice and low-speed data.

OCNS  The orthogonal noise simulator ensures a total code 
domain power of 0 dB.

Default: F-FCH

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 3 > Enter > 
Channel Type F-FCH OCNS

Channel 
Type

Chan. #1 Chan. #2 Chan. #3 Chan. #4

R-ACH RC 1-2

R-CCCH RC 3-4

R-DCCH RC 3*-4  

R-EACH RC 3-4

R-FCH RC 1-2 RC 3*-4

R-PICH RC 3*-4  

R-SCH RC 1-2 RC 3-4** RC 3*-4
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Channel Type
F-SYNCH F-SCH

This key appears when forward channel 2 is the active channel. This 
key selects either a forward synchronization channel or a forward 
supplemental channel.

F-SYNCH  This key selects a synchronization channel for 
transmitting data.

F-SCH  This key provides an additional channel for 
supplemental data.

Default: F-SYNCH

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 2 > Enter > 
Channel Type F-SYNCH F-SCH

Channel Type
R-DCCH R-SCH

This key appears when RC 3 or 4 is selected in reverse link and channel 
2 is the active channel. This key selects either a reverse dedicated 
control channel or reverse supplemental channel.

R-DCCH  The reverse dedicated control channel is used to 
communicate higher-level data and control information.

R-SCH  The reverse supplemental channel is used, in 
conjunction with the R-FCH, to communicate higher 
data rate service.

Default: R-DCCH

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Link Control > 2 > Enter > Channel Type R-DCCH R-SCH

Chip Clock

This key selects the chip clock as the output at the DATA CLK OUT 
rear panel BNC/SMB connector.

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Settings > Data Clk Out > Chip Clock
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Chip Rate

This field displays the current chip rate. The chip rate is equivalent to 
the spreading rate of the channel. Spreading rate 1 (SR1) is 
1.2288 Mcps. The default value is in accordance with the IS-2000 
specification. To change the chip rate, press the Edit Item softkey and 
enter the new value.

Range: 50 cps through 1.3 Mcps

Default: 1.2288 Mcps

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
BTS Setup > Chip Rate

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Chip Rate

Coded RCCCH

This key selects the baseband reverse common control channel data as 
the output at the DATA OUT rear panel BNC/SMB connector. Reverse 
link radio configuration 3 or 4 is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > Coded RCCCH

Coded RDCCH

This key selects the baseband reverse dedicated control channel data as 
the output at the DATA OUT rear panel BNC/SMB connector. Reverse 
link radio configuration 3 or 4 is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > Coded RDCCH

Coded REACH

This key selects the baseband reverse enhanced access channel data as 
the output at the DATA OUT rear panel BNC/SMB connector. Reverse 
link radio configuration 3 or 4 is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > Coded REACH

Coded RFCH

This key selects the baseband reverse fundamental channel data as the 
output at the DATA OUT rear panel BNC/SMB connector. Reverse link 
radio configuration 3 or 4 is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > Coded RFCH
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Coded RSCH

This key selects the baseband reverse supplemental channel data as 
the output at the DATA OUT rear panel BNC/SMB connector. Reverse 
link radio configuration 3 or 4 is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > Coded RSCH

Config Change

This field displays the status of the configuration change bits in the 
quick paging channel (QPCH). These bits are used by the base station 
to notify the mobile that a configuration change is required.

The 80 ms QPCH slot is divided into 4 equal portions. The last 2 bits of 
the second and fourth portions are the configuration change bits. These 
bits can be enabled or disabled by setting a value from 0 through 3 in 
the Config Change field. To edit the value, press the Edit Item softkey 
and enter a new value. The following table shows which bits are 
enabled for the values allowed:

Range: 0 through 3

Default: 3

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 
4 > Enter > Channel Type > QPCH > Channel Setup > Config Change

Copy File

This key copies the current file. You can then edit the new file. 

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3,or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Create File > 
Copy File

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File or Create File > Copy File

Config 
Change 
Value

 
Bits Enabled

0 All bits off

1 Last 2 bits of 2nd portion on

2 Last 2 bits of 4th portion on

3 Last 2 bits of 2nd and 4th portions on
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Create File 

This key creates a new bit file named Untitled and opens the bit file 
editor. With the softkeys that are displayed with this file, you can enter 
information, rename the file, copy the current file to a new file, and 
delete rows. 

Softkey Location (Forward): Mode > CDMA > Link Control > 2, 3, or 4 > 
Enter > Channel Type > F-SCH, F-FCH, or F-PCH > Channel Setup > Data > 
Edit Item > User File > Create File

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Create File
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Data

This field displays the data selection for the current channel. To change 
the data selection, press the Edit Item softkey and select from the 
softkey menus presented. 

Default: PN9

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
Link Control > 2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH or F-PCH > 
Channel Setup > Data

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data 

Data Field Location (for Reverse RC 1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel Type > 
R-ACH, R-FCH, or R-SCH > Channel Setup > Data

Data Clk Out

This key accesses a menu from which you can modify the clocked output 
at the DATA CLK OUT rear panel BNC/SMB connector in reverse link 
mode. Items selected from the accessed menu may change when 
switching between radio configuration 1 or 2 and radio configuration 3 
or 4.

Default: Chip Clock

Softkey Location: Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Settings > Data Clk Out

Data Out

This key accesses a menu from which you can modify the output at the 
DATA OUT rear panel BNC/SMB connector. In reverse link, an item 
selected from the accessed menu may change when switching between 
radio configuration 1 or 2 and radio configuration 3 or 4.

Default:
Forward Link: PC Ramp
Reverse Link: Long Code

Softkey Location (Forward): Mode > CDMA > CDMA2000 > 
BNC MUX Settings > Data Out

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Settings > Data Out
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Data Rate

This field displays the current data rate. The data rates available 
depend on the transmission setup including the radio configuration, 
channel, frame length, and frame offset value.

To change the data rate, press the Channel Setup softkey, use the front 
panel knob or arrow keys and highlight the Data Rate field, press the 
Edit Item softkey, and enter a new value. If the field is grayed out, it 
cannot be edited. Values between acceptable rates will be clipped to the 
nearest allowed value.

Table 3-1 and Table 3-2 show the data rates for radio configurations, 
channel types, and frame lengths. Channels that have fixed (R-ACH, 
4.8 kbps) or no data rates are not shown. Default data rates and data 
rates that are used only with specific frame lengths, are indicated by 
footnotes. 

NOTE When selecting a data rate for the R-SCH, you need to ensure it is 
compatible with the Walsh code being used. Due to the flexibility built 
into the ESG, it is possible to set a data rate with a Walsh code that is 
not within IS-2000 specifications. 

Table 3-1 Forward Link Data Rates

Forward Link

Data Rate 
(kbps)

F-PCH F-FCH F-SCH QPCH

1.2 RC 1

1.35

1.5 RC 3, 4

1.8 RC 2, 5

2.4 RC 1 RC 3–5

2.7 RC 3, 4

3.6 RC 2, 5

4.8 RC 1-5 RC 1, 3, 4 RC (3, 5)a

7.2 RC 2, 5

9.6 RC (1–5)1 RC (1, 3, 4)a

14.4 RC (2, 5)a

19.2 RC (3, 4)a

28.8 RC 5a

38.4 RC 3, 4

57.6 RC 5

76.8 RC 3, 4

115.2 RC 5

153.6 RC 3, 4
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a. Default value (ESG preset or power cycle)
b. Default value for 5 ms frame length
c. Default value for 10 ms frame length
d. Default value for 40 ms frame length
e. Default value for 80 ms frame length
f. 40 ms frame length value
g. 80 ms frame length value

230.4 RC 5

307.2 RC 4

1. Default value (ESG preset or power cycle)

Table 3-1 Forward Link Data Rates

Forward Link

Data Rate 
(kbps)

F-PCH F-FCH F-SCH QPCH

Table 3-2 Reverse Link Data Rates

Reverse Link

Data Rate 
(kbps)

R-DCCH R-FCH R-SCH R-CCCH R-EACH

1.2 RC 1 RC 1, 3g

1.35 RC 3f

1.5 RC 3 RC 3

1.8 RC 2, 4 RC 2, 4

2.4 RC 1 RC 1, 3fg

2.7 RC 3 RC 3 

3.6 RC 2, 4 RC 2, 4

4.8 RC 1, 3 RC 1, 3

7.2 RC 2, 4 RC 2, 4

9.6 RC 4b RC 1a, 3ab, 4b RC 1a, 3 RC 3, 4 RC 3, 4

14.4 RC 4a RC 2a, 4a RC 2a, 4

19.2 RC 3 RC 3, 4 RC 3, 4

28.8 RC 4

38.4 RC 3 RC (3, 4)abc RC (3, 4)abc

57.6 RC 4e

76.8 RC 3e

115.2 RC 4d

153.6 RC 3d

230.4 RC 4a

307.2 RC 3a
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Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
Link Control > Channel Number > 2, 3, or 4 > Channel Type > F-SCH, F-FCH, 
F-PCH, or QPCH > Channel Setup > Data Rate

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > 
Data Rate

DAYLT

This field displays the current daylight saving time offset status for the 
F-SYNCH. Choices are 00 (off) or 01 (on).

Default: 00

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > DAYLT

Default Message

This key selects the default message for the forward paging channel 
(F-PCH). When this key is selected, the word DEFAULT will appear in 
the Data field indicating that the default message is now ready to use.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 4 > Enter > 
Channel Type > F-PCH > Channel Setup > Data > Edit Item > 
Default Message

Define 
User FIR

This key displays a table editor from which you can create and modify 
FIR filters. The FIR table editor allows a maximum filter length of 1024 
coefficients, but the signal generator hardware is limited to 256 
coefficients and 32 symbols. The number of symbols equals the number 
of coefficients divided by the oversample ratio. 

NOTE If you enter more than 32 symbols or 256 coefficients, the signal 
generator cannot use the filter.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR
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Delayed 20ms Trigger

This key selects a signal output for the EVENT 1 rear panel BNC/SMB 
connector that identifies the location of the 20 ms data frame boundary. 

Softkey Location: Mode > CDMA > CDMA2000 > BNC MUX Settings > 
Event 1 > Delayed 20ms Trigger

Delayed 80ms Trigger

This key selects a signal output at either the EVENT 1 or DATA OUT 
rear panel BNC/SMB connector that identifies the location of every 
third PN sequence, as well as every fourth 20 ms data frame boundary. 

Softkey Location: Mode > CDMA > CDMA2000 > BNC MUX Settings > 
Event 1 or Data Out > Delayed 80ms Trigger

Delayed Even Second

This key selects an even second clock pulse with adjustable delay at the 
EVENT 1 rear panel BNC/SMB connector. The even second output 
provides a pulse every two seconds, which is used to synchronize other 
instruments in the test system. 

The even second delay can be adjusted to align the frame timing with 
the RF output. Refer to“Forward and Reverse Link I/O Signal 
Descriptions and Timing Relationships” on page 4-9.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > 
BNC MUX Settings > Event 1 > Delayed Even Second

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Settings > Event 1 > 
Delayed Even Second

Delete

This key accesses a menu from which you can select different ways of 
removing bits from a User File.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Create File > 
Delete

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File or Create File > Delete
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Delete All Rows

This key deletes all rows of the current data table. You are prompted for 
confirmation. 

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH >
Channel Setup > Data > Edit Item > User File > Delete All Rows

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Delete All Rows

Delete Bits

This key deletes the specified number of bits from the currently 
highlighted position.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Create File > 
Delete > Number of Bits > Delete Bits

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File or Create File > Delete > Number of Bits > 
Delete Bits

Delete File

This key deletes the highlighted file from the displayed catalog. You are 
prompted for confirmation.

Delete File is located in catalogs of files.

Delete To Beginning

This key deletes all bits from the currently highlighted bit to the 
beginning of the file.

Delete to Beginning is located in the bit file table editor menus.

Delete To End

This key deletes all bits from the currently highlighted bit to the end of 
the file.

Delete To End is located in the bit file table editor menus.
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Delete Row

This key deletes the highlighted row in the current table.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Delete Row

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User File > Delete Row

Display FFT

This key displays a graphical representation of the filter frequency 
response of a filter loaded into the FIR table editor (calculated using a 
fast Fourier transform). The following is an example of the frequency 
response of a Root Nyquist filter with an oversample ratio of 4.

To return to the FIR table editor and the menu keys, press Return.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Display FFT

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User File > Display FFT
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Display Impulse 
Response

This key displays a graphical representation of the filter impulse 
response over time of the filter loaded into the FIR table editor. The 
following is an example of the impulse response of a Root Nyquist filter 
with an oversample ratio of 4.

To return to the FIR table editor and the menu keys, press Return.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Display Impulse Response

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User File > Display Impulse Response
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Edit File

This key enables you to begin editing the selected file in the User File 
directory. You are asked to confirm converting binary files to bit files for 
editing.

NOTE There is no undo capability; bit files are saved after each modification.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File

Edit Item

This key allows the highlighted field value in the displayed table to be 
edited. For some fields, it accesses softkey selections.

Edit Item is located in the setup menus for the BTS, mobile, and 
channels. It is also located under the Define User Fir softkey.

Equal Powers

This key adjusts all channel powers to equal power settings that sum to 
0 dB.

NOTE This key is valid only for a single ESG configuration.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
Adjust Code Domain Power > Equal Powers

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > Adjust Code Domain Power > 
Equal Powers
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Even Sec Delay

This field displays the current value for the delay that aligns the RF 
with the even second clock pulse. To change the delay value, press the 
Edit Item softkey and enter a new value.

Range: 0.5 cps through 128 cps

Default: 17.5 cps

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
BTS Setup > Even Sec Delay

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Even Sec Delay

Even Second

This key selects the even second pulse as the output at the SYMBOL 
SYNC OUT rear panel BNC/SMB connector. This is an internal timing 
signal on the baseband generator. It precedes the actual RF output by 
approximately 18 chips.

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Settings > Symbol Sync Out > 
Even Second

Event 1

This key accesses a menu from which you can select the output signal of 
the EVENT 1 rear panel BNC/SMB connector. In reverse link, an item 
selected from the accessed menu may change when switching between 
radio configuration 1 or 2 and radio configuration 3 or 4.

Default: Delayed Even Second

Softkey Location (Forward): Mode > CDMA > CDMA2000 > 
BNC MUX Settings > Event 1

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Settings > Event 1

Ext

This key selects an external data source as the modulating data stream. 
See “Front Panel BNC/SMB Inputs” on page 4-9.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 2, 3, or 4 > 
Enter > Channel Type > F-SCH or F-FCH > Channel Setup > Data > 
Edit Item > Ext
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Ext Cdma Freq

This field becomes active when the F-SYNC TYPE is IS2000. This field 
sets the extended CDMA channel frequency that the mobile should be 
adjusted to receive. 

If this field is grayed-out, it indicates that this parameter is currently 
unavailable. 

Range: 0 through 2047 Hz

Default: 0

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Type > F-SYNCH > Channel Setup > EXT Cdma Freq
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F

Falling

This key configures the ESG to trigger on the falling edge of the signal 
applied to the PATTERN TRIG IN rear panel BNC/SMB connector.

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Trigger Edge > Edit Item > Falling

F-PCH

This key selects a forward paging channel, which is the digital control 
channel for the forward link.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 4 > Enter > 
Channel Type > F-PCH

F-SCH

This key selects a forward supplemental channel that operates in 
conjunction with the forward fundamental channel (F-FCH) to provide 
a higher data rate service.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 4 > Enter > 
Channel Type > F-SCH

F-SYNCH Type

This field displays the forward synchronization type. To change the 
type, press the Edit Item softkey and select a synchronization type from 
the displayed menu.

Default: JSTD8

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 
2 > Enter > Channel Setup > F-SYNCH Type
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Field1

This key accesses a menu from which you can set the field 1 
hexidecimal value for the forward paging long code mask. The default 
value is in accordance with the IS-2000 specification. 

Range: 0 through 1FFF

Default: 18CD

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 4 > Enter > 
Channel Type > F-PCH > Channel Setup > LC Mask > Edit Item > Field1

Field2

This key accesses a menu from which you can set the field 2 
hexidecimal value for the forward paging long code mask. The default 
value is in accordance with the IS-2000 specification.

Range: 0 through 1F

Default: 00

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 4 > Enter > 
Channel Type > F-PCH > Channel Setup > LC Mask > Edit Item > Field2 

Field3

This key accesses a menu from which you can set the field 3 
hexidecimal value for the forward paging long code mask. The default 
value is in accordance with the IS-2000 specification.

Range: 0 through FFF

Default: 000

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 4 > Enter > 
Channel Type > F-PCH > Channel Setup > LC Mask > Edit Item > Field3 

Filter

This field displays the currently selected filter type. To change the filter 
selection, press the Edit Item softkey. In the displayed menu you can use 
either the Select or Define User FIR softkey to select a filter type.

Default:
Forward Link: IS-95 w/EQ
Reverse Link: IS-95 Mod

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
BTS Setup > Filter

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter
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Filter Alpha

This key is accessed through either the Select (Filter) menu or the 
Load Default FIR menu from which you can change the FIR filter alpha 
parameter.

In the Select (Filter) Menu

This menu enables you to change the alpha parameter of the selected 
Root Nyquist or Nyquist filter. 

This key appears only after you choose a Root Nyquist or Nyquist filter. 
If a Gaussian filter is used, you will see Filter BbT. If any other filter is 
selected, you will see a Filter Factor N/A softkey that is grayed-out.

Range: 0.000 through 1.000

Default: 0.220

NOTE The default value of 0.220 or any entered value will change to 0.500 
when the Restore Default Filter softkey is selected.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > Nyquist or Root Nyquist > Filter Alpha

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
Nyquist or Root Nyquist > Filter Alpha

In the Load Default FIR Menu

This key enables you to restore the default alpha parameter of the Root 
Nyquist or Nyquist filter coefficients loaded into the FIR table editor. 

The filter alpha value is set to 0.350 at the factory. This value is not 
affected by a signal generator preset or by a power cycle.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > 
Nyquist or Root Nyquist > Filter Alpha

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Root Nyquist or Nyquist > Filter Alpha
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Filter BbT

This key is accessed through either the Select (Filter) menu or the 
Load Default FIR menu where you can change the 
bandwidth-multiplied-by-bit-time filter parameter.

In the Select (Filter) Menu

This menu enables you to change the BbT parameter of the selected 
Gaussian filter.

This key appears only after you choose a Gaussian filter. If a Root 
Nyquist or Nyquist filter is in use, you will see Filter Alpha. If any other 
filter is selected, you will see a Filter Factor N/A softkey that is 
grayed-out.

Range: 0 through 1.00

Default: 0.500

NOTE The default value of 0.500 or any entered value will change to 0.300 
when the Restore Default Filter softkey is selected.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > Gaussian > Filter BbT

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
Gaussian > Filter BbT

In the Load Default FIR Menu

This key enables you to restore the default BbT parameter of the 
Gaussian filter coefficients loaded into the FIR table editor. 

The Gaussian filter value is set to 0.500 at the factory. This value is not 
affected by a signal generator preset or by a power cycle.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Gaussian > 
Filter BbT

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item >
Define User FIR > Load Default FIR > Gaussian > Filter BbT
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Filter Factor N/A

This grayed-out softkey is displayed when the filter in use does not 
contain an adjustable alpha or BbT parameter (such as the IS-95 filter 
selections or a user-defined FIR filter). This softkey changes to 
Filter Alpha when Root Nyquist or Nyquist is selected, and Filter BbT 
when Gaussian is selected.

Softkey Location: Mode > CDMA > CDMA2000 > BTS Setup > Filter > 
Edit Item

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item 

Filter Symbols

This key enables you to define the number of symbols for the filter to be 
loaded into the FIR table editor. Although the FIR table editor allows a 
maximum of 32 symbols, with a maximum oversample ratio of 32, the 
selected FIR filter cannot have more than 256 coefficients. Select the 
number of symbols and the oversample ratio accordingly. A FIR filter 
with greater than 16 symbols will decrease the maximum symbol rate 
by half.

The filter symbols are set to 8 at the factory. This state is not affected by 
a signal generator preset or by a power cycle.

Range: 1 through 32

Default: 8

Softkey Location (Forward): Mode > CDMA > > BTS Setup > Filter > 
Edit Item > Define User FIR > Load Default FIR > Root Nyquist, Nyquist, 
Gaussian, or Rectangle > Filter Symbols

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Root Nyquist, Nyquist, Gaussian, or 
Rectangle > Filter Symbols

FIX4 

This key selects a fixed 4-bit data pattern that does not change from 
frame to frame. The data pattern repeats and fills the frame with the 
selected data. 

Range: 0000 through 1111 binary

Default: 0000

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH or F-FCH > Channel Setup > 
Data > Edit Item > FIX4 
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Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > FIX4

Softkey Location (for Reverse RC 1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel Type > 
R-ACH, R-FCH, or R-SCH > Channel Setup > Data > Edit Item > FIX4

Frame Length

This field displays the current frame length value. A frame is a basic 
timing interval in the CDMA system. 

The frame length depends on the radio configuration and channel type, 
and it affects the data rate and frame offset. Change the frame length 
by pressing the Channel Setup softkey, rotating the front panel knob, or 
pressing the arrow keys to highlight the Frame Length field. Then 
press the Edit Item softkey and enter a new value. If the field is 
grayed-out, you cannot change the value.

The following table lists the frame lengths by channel type and the 
default values.

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
Link Control > 4 > Enter > Channel Type > F-PCH > Channel Setup > 
Frame Length

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > 
Frame Length

Data Field Location (for Reverse RC1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel Type > 
R-ACH, R-FCH, or R-SCH > Channel Setup > Frame Length

Forward
Link

Reverse Link

Channel
Type

F-PCH R-ACH R-DCCH R-FCH1 R-SCH1 R-EACH R-CCCH

Allowed
Values

Not
adjustable

Not
adjustable

5 ms
20 ms

5 ms
20 ms

20 ms
40 ms
80 ms

5 ms
10 ms
20 ms

5 ms
10 ms
20 ms

Default 20 ms 20 ms 20 ms 20 ms 20 ms 20 ms 20 ms

1. Not adjustable in radio configurations 1 and 2.
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Frame Offset

This field displays the current frame offset value. The frame offset 
skews the traffic channel frames from system time in integer multiples 
of 1.25 ms.

The frame offset depends on the channel type, data rate, frame length, 
and radio configuration. Refer to the following table for available 
ranges:

Default: 0

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
Link Control > 2, 3, or 4 > Enter > Channel Type > 
F-FCH or F-SCH >Channel Setup > Frame Offset

Channel 
Type

Frame 
Offset

Frame
Length (ms)

Forward Link

F-FCH 0 - 15 20

F-SCH 0 - 15 20

Reverse Link

R-ACH 0-15 20

R-DCCH 0 - 3 5

0 - 15 20

R-FCH1

1. For RC 1–2, the frame offset is only 
0–15 with a 20 ms frame length.

0 - 3 5

0 - 15 20

R-SCH1 0 - 15 20

0 - 31 40

0 - 63 80

R-EACH 0 - 3 5

0 - 7 10

0 - 15 20

R-CCCH 0 - 3 5

0 - 7 10

0 - 15 20
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Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > 
Frame Offset

Data Field Location (for Reverse RC1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel Type > 
R-ACH, R-FCH, or R-SCH > Channel Setup > Frame Offset

Full

This key sets the gating rate to full causing all 16 power control groups 
to be transmitted. The gating rate field is only available on the reverse 
pilot channel.

Softkey Location: Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > Channel Setup > Gating Rate > 
Edit Item > Full
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G

Gating Rate

This field displays the current gated transmission of the mobile and is 
only available on the reverse pilot channel. To change the gating rate, 
press the Edit Item softkey. The subsequent menu lets you select either 
full, half, or quarter gating of the power control groups for 
transmission.

Default: Full (16 bits)

Data Field Location: Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > Channel Setup > Gating Rate

Gaussian

This key selects a Gaussian filter in either the Select (Filter) menu or 
the Load Default FIR menu.

In the Select (Filter) Menu

This key selects a Gaussian filter for use in the filter setup. Select the 
Filter Bbt softkey to change the filter bandwidth-multiplied-by-bit-time 
product value.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > Gaussian

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
Gaussian

In the Load Default FIR Menu

Select the Gaussian softkey followed by the Generate softkey. This loads 
the FIR table editor with the coefficient values for the Gaussian filter. 
The filter BbT and number of filter symbols are defined with the 
softkeys in this menu. If you change either parameter after loading the 
filter coefficients, press the Generate softkey again.

The Display Impulse Response and Display FFT softkeys in this menu 
graphically display the filter as it is currently defined in the FIR table 
editor. 

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Gaussian

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Gaussian
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Generate

This key creates a filter using the alpha value and number of symbols 
specified.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > 
Root Nyquist, Nyquist, Gaussian, or Rectangle > Generate

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Root Nyquist, Nyquist, Gaussian, 
or Rectangle > Generate

Goto

This key displays a menu from which you can select a new position in 
the current table editor or list of items.

Goto is located in the bit file editor menu.

Goto Bottom Row

This key moves the selection bar to the bottom row in the current table 
or list of items.

Goto Bottom Row is located in the table editor menus and in the catalogs 
of files.

Goto Middle Row

This key moves the selection bar to the middle row in the current table 
or list of items.

Goto Middle Row is located in the table editor menus and in the catalogs 
of files.

Goto Row

This key accesses a menu of softkeys that enable you to select a row or 
page in a table or list of items. 

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Goto Row

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Goto Row
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Goto Top Row

This key moves the selection bar to the top row in the current table or 
list of items.

Goto Top Row is located in the table editor menus and in the catalogs of 
files.
Real-Time cdma2000 Personality User’s and Programming Guide 3-45



Softkey Reference ESG Family Signal Generators
H Option 201
H

Half

This key sets the gating rate to half, causing 8 power control groups 
(every other bit) to be transmitted. The gating rate field is available 
only in the reverse pilot channel.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Link Control > Channel Setup > Gating Rate > Edit Item > Half

Hamming

This key applies the Hamming windowing function to the selected filter. 
Windowing improves out of band performance (ACP) by smoothing the 
filter’s transition to zero, but simultaneously degrades passband 
performance (EVM).

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Root Nyquist, 
Nyquist, Gaussian, or Rectangle > Window > Hamming

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Root Nyquist, Nyquist, Gaussian, 
or Rectangle > Window > Hamming

Hann

This key applies the Hann windowing function to the selected filter. 
Windowing improves out of band performance (ACP) by smoothing the 
filter’s transition to zero, but simultaneously degrades passband 
performance (EVM).

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Root Nyquist, 
Nyquist, Gaussian, or Rectangle > Window > Hann

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Root Nyquist, Nyquist, Gaussian, 
or Rectangle > Window > Hann
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Header

This key accesses a menu from which you can set the forward 
fundamental or supplemental channel long code mask header used to 
communicate with a particular mobile.

Range: 0000 through 03FF

Default: 0318

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 2, 3, or 4 > 
Enter > Channel Type > F-FCH or F-SCH > Channel Setup > LC Mask > 
Edit Item > Header
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I

I Out

This key outputs an internally generated I component of I/Q 
modulation to the DATA OUT rear panel BNC/SMB connector. 
Reverse link radio configuration 1 or 2 is required.

Softkey Location: Mode > CDMA  > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > I Out

Insert 

This key appears in two places:

In the Edit File and Create File Menus

This key accesses a menu that enables you to insert bits or a 
pseudorandom bit sequence into the current user file.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Create File > 
Insert

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File or Create File > Insert

In the Insert 1’s and Insert 0’s Menus

This key is used as an entry terminator causing the selected bits to be 
inserted into the current user file.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Create File > 
Insert 1’s or Insert 0’s > Number of Bits (enter desired amount of bits) > 
Insert

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File or Create File > Insert > Insert 1’s or 
Insert 0’s > Number of Bits (enter desired amount of bits) > Insert
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Insert 0’s

This key accesses the Bit File Editor where you are able to enter the 
desired number of 0’s at the current position in the user file.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Create File > 
Insert > Insert 0’s

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File or Create File > Insert > Insert 0’s

Insert 1’s

This key accesses the Bit File Editor where you are able to enter the 
desired number of 1’s at the current position in the user file. 

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Create File > 
Insert > Insert 1’s

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File or Create File > Insert > Insert 1’s

Insert PN9

This key appears in two places, as a menu access key and as a selection.

• As a menu access key, this key opens a menu from which you can 
adjust the seed of the 9-bit pseudorandom bit sequence and then 
insert the sequence. 

• As a selection, this key inserts a specified PN9 sequence at the 
current position.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter . Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Create File > 
Insert > Insert PN9 > Insert PN9

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup> Data > Edit 
Item > User File > Edit File or Create File > Insert > Insert PN9 > 
Insert PN9
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Insert PN15

This softkey appears in two places, as a menu access key and as a 
selection.

• As a menu access key, this key opens a menu from which you can 
adjust the seed of the 15-bit pseudorandom bit sequence and then 
insert the sequence. 

• As a selection, this key inserts a specified PN15 sequence at the 
current position.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Create File > 
Insert > Insert PN15 > Insert PN15

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File or Create File > Insert > Insert PN15 > 
Insert PN15

Insert Row

This key inserts a copy of the highlighted row in a table.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Insert Row

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Insert Row

IQ Map Rotation
Std. Rotated

This key selects a standard (square) or rotated (diamond) mode for the 
IQ map rotation. Typically, the rotated mode is used in a multi-ESG 
solution or when more than two rotated channels are desired. 

For forward link, it is possible to generate a third RC3, RC4, or RC5 
traffic channel from ESG 2. If three traffic channels are selected, a Code 
Power Err message will appear. Rotating the IQ map on ESG 1 and 
ESG 2 changes the IQ map such that three RC3, RC4, or RC5 traffic 
channels may be supported on ESG 2. 

By rotating the IQ maps on both ESGs, the 45 degree relative phase is 
maintained.
3-50 Real-Time cdma2000 Personality User’s and Programming Guide



ESG Family Signal Generators Softkey Reference
Option 201 I
For an example, refer to the following setup in which ESG 1 is rotated 
from square to diamond and ESG 2 is rotated from diamond to square:

ESG 1:  F-PICH and F-SYNCH rotated to diamond

ESG 2:  F-FCH, F-SCH and F-SCH, RC3 rotated to square

Default: Std.

Softkey Location: Mode > CDMA > CDMA2000 > 
IQ Map Rotation Std. Rotated

IQ Voltage Scale

This field displays the current voltage at the IQ ports. To change the 
voltage, press the Edit Item softkey and enter a new value. Since 
changing this value affects the total power, you will also see individual 
channel power adjustments. This value is assigned by performing the 
relative power mapping procedure. See “Adjust the Relative Power 
Mapping (Two-ESG Forward Link)” on page 2-15 or “Adjust the 
Relative Power Mapping (Two-ESG Reverse Link)” on page 2-42.

NOTE IQ Voltage Scale is used in the two-ESG configuration to adjust the 
relative power values of the channels between the two signal 
generators. See “Voltage Other ESG” on page 3-84.

Range: −40.0 dB through 0.00 dB

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
2 Box Setup > IQ Voltage Scale

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > 2 Box Setup > IQ Voltage Scale

IS-95

This key selects a standard cdmaOne IS-95 filter.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > IS-95 and IS-2000 > IS-95

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
IS-95 and IS-2000 > IS-95
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IS-95 and IS-2000

This key accesses a menu of IS-95 and IS-2000 filters.

Defaults: 
     Forward: IS-95 w/EQ
     Reverse: IS-95 Mod

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > IS-95 and IS-2000

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
IS-95 and IS-2000

IS-95 Mod

This key selects a modified version of the standard IS-95 filter. This 
filter is modified for improved adjacent channel power performance. 
The modification is done in a manner that meets the IS-95 error 
function criterion.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > IS-95 and IS-2000 > IS-95 Mod

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
IS-95 and IS-2000 > IS-95 Mod

IS-95 w/EQ

This key selects the standard IS-95 filter with the equalizer for phase 
compensation required by a base station.

Softkey Location: Mode > CDMA > CDMA2000 > BTS Setup > Filter > 
Edit Item > Select > IS-95 and IS-2000 > IS-95 w/EQ

IS-95 Mod w/EQ

This key selects a modified version of the standard IS-95 filter. This 
filter is modified for improved adjacent channel power performance, 
and includes the equalizer for phase compensation required by a base 
station. The filter modification is done in a manner that meets the 
IS-95 error function criterion.

Softkey Location: Mode > CDMA > CDMA2000 > BTS Setup > Filter > 
Edit Item > Select > IS-95 and IS-2000 > IS-95 Mod w/EQ
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IS2000

This key selects the forward synchronization type as defined by the 
IS-2000 CDMA standard.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 2 > Enter > 
Channel Setup > F-SYNCH Type > Edit Item > IS2000

IS95

This key selects the forward synchronization type as defined by the 
IS-95 CDMA standard.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 
2 > Enter > Channel Setup > F-SYNCH Type > Edit Item > IS95
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J

JSTD8

This key selects the forward synchronization type as defined by the 
JSTD8 CDMA standard.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 2 > Enter > 
Channel Setup > F-SYNCH Type > Edit Item > JSTD8
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K

Kaiser

This key applies the Kaiser windowing function to the selected filter. 
Windowing improves out of band performance adjacent channel power 
(ACP) by smoothing the filter’s transition to zero, but simultaneously 
degrades passband performance error vector magnitude (EVM). 

Selecting Kaiser also activates the Beta factor that you adjust to change 
the trade-off between optimized ACP or EVM. Decreasing the Beta 
factor value improves EVM; increasing the value improves ACP.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Root Nyquist, 
Nyquist, Gaussian, or Rectangle > Window > Kaiser

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Root Nyquist, Nyquist, Gaussian, or 
Rectangle > Window > Kaiser
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LC Generation

This field displays the current long code generation mode. To change 
the long code mode, highlight the LC Generation field, press the 
Edit Item softkey, and select either the Arb or Real Time mode. 

The Arb selection provides a long code signal that repeats, 
approximately, every 26 ms. This is the current signal generator 
behavior and is compatible with Arb formats.

The Real Time selection provides a long code signal that repeats, 
approximately, every 41 days and is compliant with the specification. 
This enables functions such as bit error rate (BER) testing. 

Default: Arb

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > LC Generation

LC Mask

This field displays the current long code mask value (in hexidecimal). 
This 42-bit binary number creates the unique identity of the long code. 

To change the LC Mask for the F-FCH or the F-SCH channel, edit the 
Header and the Permuted ESN values. To change the LC Mask for the 
F-PCH channel, edit the Field1, Field2, and Field3 values.

Range: 00000000 through 3FFFFFFFFFF

NOTE The storage register for the Long Code Mask allows a 42-bit binary 
number to be entered. However, it may be possible to enter a value 
larger than 42 bits, and in this instance, the register value would be 
unknown. 

Default:
Forward Link:

Channel 2: 31800000000
Channel 3: 31800000000
Channel 4: 319A0200000

Reverse Link: 0000000000

Data Field Location (Forward): Mode > CDMA > CDMA2000 > Link Control 
> 2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > Channel 
Setup > LC Mask

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > LC Mask
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LC State

This field displays the current long code seed value (in hexidecimal) 
used to generate the actual long code. The long code is a PN sequence 
that is used for scrambling in the forward channels and spreading in 
the reverse channels. To change the long code seed, press the Edit Item 
softkey and enter a new value.

Range: 00000000 through 3FFFFFFFFFF

NOTE The storage register for the Long Code State allows a 42-bit binary 
number to be entered. However, it may be possible to enter a value 
larger than 42 bits, and in this instance, the register value would be 
unknown. 

Default: 0000000000

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
BTS Setup > LC State

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > LC State

Link Forward Reverse

The key selects forward (BTS Setup) or reverse (Mobile Setup) link.

Default: Forward

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse 

Link Control

This key accesses a menu from which you can select a channel and 
modify its parameters.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control 

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control

Load Default FIR

This key accesses a menu of standard filters: Root Nyquist, Nyquist, 
Gaussian, and Rectangle. Selecting one of these filters displays a menu 
that is applicable to the filter type chosen. In this menu, the user will be 
able to select filter characteristics (if applicable), windowing, the 
number of symbols, and filter generation.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR
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Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR

Load From
Selected File

This key replaces the current filter information in a table editor with 
the information stored in the highlighted file.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load/Store > 
Load From Selected File

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load/Store > Load From Selected File

Load/Store

This key accesses a menu from which you can load the current table 
editor with filter values from files previously stored in the signal 
generator memory. You are able to save data to a file or delete a file.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load/Store

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load/Store

Long Code

This key selects the long code as the output at the DATA OUT rear 
panel BNC/SMB connector.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > Long Code

Long Code Sync

This key selects a signal that indicates the beginning of the long code as 
the output at the SYMBOL SYNC OUT rear panel BNC/SMB 
connector.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Symbol Sync Out > Long Code Sync
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LP_SEC

This field displays the current leap seconds value. To change the leap 
seconds value, press the Edit Item softkey and enter a new value.

Range: 00 through FF hexidecimal

Default: 00

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > LP_SEC

LTM_OFF

This field displays the current offset of local time (where 1 = 30 
minutes, 2 = 60 minutes, 3 = 90 minutes, and so on) from the system 
time. To change the offset, press the Edit Item softkey and enter a new 
value.

Range: 00 through 3F hexidecimal

Default: 00

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 
2 > Enter > Channel Setup > LTM_OFF
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MIN_P_REV

This field displays the current minimum protocol revision level value. 
To change the revision level, press the Edit Item softkey and enter a new 
value.

Range: 00 through FF hexidecimal

Default: 01

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > MIN_P_REV

Mirror Table

This key mirrors the current FIR table entries such that the table 
doubles in size, and the values in the top half of the table are duplicated 
in the bottom half of the table in reverse order.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Mirror Table

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Mirror Table

Mobile Setup

This key enables you to access the table editor from which you can 
select and modify the parameters of the mobile station. Highlight the 
parameter you want to change and press the Edit Item key.

The following figure shows an example of the display for the mobile 
setup table editor.
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Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Mobile Setup

Msg Type

This field displays the current message type value for the forward 
synchronization channel (F-SYNCH). The message types are displayed 
in hexidecimal notation. The message synchronizes the pilot PN 
sequence offset with the even second clock. To change the message, 
press the Edit Item softkey and enter a new value.

Range: 00 through FF hexidecimal

Default: 01

Data Field Location: Mode > CDMA > CDMA2000 > Link Control >
2 > Enter > Channel Setup > Msg Type
Real-Time cdma2000 Personality User’s and Programming Guide 3-61



Softkey Reference ESG Family Signal Generators
N Option 201
N

NID

This field displays the current network identification number for the 
base station. To change the identification number, press the Edit Item 
softkey and enter a new value.

Range: 0000 through FFFF hexidecimal

Default: 0001

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > NID

None

This key sets no windowing for the selected filter. The filter is optimized 
for maximum passband performance (EVM).

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Root Nyquist, 
Nyquist, Gaussian, or Rectangle > Window > None

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Root Nyquist, Nyquist, Gaussian, or 
Rectangle > Window > None

Number of Bits

This key makes the number of bits for the current operation the active 
entry. 

Number of Bits is located in the bit file editor menus.

Nyquist

This key selects the Nyquist (raised cosine) filter in either the Select 
(Filter) menu or the Load Default FIR menu.

In the Select (Filter) Menu

This key selects a Nyquist filter and returns the Select (Filter) menu.

Range: 0 through 1

Default Filter Alpha: 0.220

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > Nyquist
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Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
Nyquist

In the Load Default FIR Menu

Press the Nyquist softkey followed by Generate to load the FIR table 
editor with the coefficient values for a Nyquist filter. The filter alpha 
and number of filter symbols are defined with the softkeys in this 
menu. If you change either parameter after loading the filter 
coefficients, press the Generate softkey again. The Display Impulse 
Response and Display FFT softkeys in this menu graphically display the 
filter as it is currently defined in the FIR table editor.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Nyquist

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Nyquist
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Optimize FIR For 
(N/A)

This grayed-out key is displayed until a Root Nyquist or a Nyquist filter 
is selected. 

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Optimize FIR For (N/A) 

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Optimize FIR For (N/A) 

Optimize FIR For 
EVM ACP

This key allows optimization of the FIR filter between error vector 
magnitude and adjacent channel power. This key is only activated when 
Root Nyquist or Nyquist is selected for the filter.

• Highlight EVM to optimize a filter for minimized error vector 
magnitude. The EVM selection provides the most ideal passband.

• Highlight ACP to minimize adjacent channel power and improve 
stopband rejection.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > Root Nyquist or Nyquist > 
Optimize FIR For EVM ACP

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
Root Nyquist or Nyquist > Optimize FIR For EVM ACP

Oversample Ratio

This key enables you to set the oversampling ratio to be applied to the 
FIR filter design in the Define User FIR menu. Although the FIR table 
editor allows a maximum of 32 symbols, with a maximum oversample 
ratio of 32, the selected FIR filter cannot have more than 256 
coefficients. Select the number of symbols and the oversample ratio 
accordingly.

The oversample ratio is set to 4 at the factory. This state is not affected 
by an instrument preset or by a power cycle.

Range: 1 through 32

Default: 4
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Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Oversample Ratio

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Oversample Ratio
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P Puncturing

This field displays the on/off state for power puncturing. Press the 
Edit Item key and then Power Puncturing Off On to toggle between the on 
and off states. This is valid only for non-zero long code states.

When power puncture is on, the ESG punctures the output stream to 
insert power control bits. When off, no power control bits are inserted.

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 3 > 
Enter > Channel Setup > P Puncturing

P_REV

This field displays the current protocol revision level value. To change 
the revision level, press the Edit Item softkey and enter a new value.

Range: 00 through FF hexidecimal

Default: 01

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > P_REV

Page Down

This key displays the next page of entries.

Page Down is located in the table editor menus and in the catalogs of 
files.

Paging Indicator

This field selects which paging slots to enable for the quick paging 
channel. The slots are 80 ms in duration and start 20 ms before the 
zero-offset pilot PN sequence.

The slots align with the pilot PN sequence at every even second time 
mark (t mod 100 = 0, where t is the system time in 20 ms frames). The 
number of slots available depends on the data rate.

For example: If 50 is entered, you will only have a paging indicator at 
slot 50. If 191 is entered, you will enable all slots from 0 through 190 
(only for a data rate of 2.4 kbps). To change the number of paging 
indicators, press the Edit Item softkey and enter a new value.

Range: 0 through 190 (with 2.4 kbps data rate)
    191 enables all slots
     –1 disables all slots
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Range: 0 through 382 (with 4.8 kbps data rate)
    383 enables all slots
    –1 disables all slots

Default: 0, 4.8 kbps

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 4 > 
Enter > Channel Type > QPCH > Channel Setup > Paging Indicator

Page Up

This key displays the previous page of entries.

Page Up is located in the table editor menus and in the catalogs of files.

PCB Data

This field displays the current power control data bits in hexidecimal 
form. The PCB data field is only available on the reverse pilot channel. 

The power control bits are used to increase or decrease transmitted 
power from the mobile to the base station. The least significant bit 
indicates the first of 16 power control bits in a 20 ms frame. To change 
the power control bits, press the Edit Item softkey and enter a new value.

Range: 0000 through FFFF

Default: 0000

Data Field Location: Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > Channel Setup > PCB Data

PCntrl (Up/Dn)

This field displays the current number of power frame indicators. The 
signal generator uses the power frame indicators to command the 
mobile to increase or decrease power. The PCntrl (Up/Dn) field is only 
available on the forward fundamental channel type located on 
channel 3.

For example, if 4 is the selected value, it would cause the mobile to 
respond with 4 sequential power increases, then 4 power decreases. 
This pattern would continue indefinitely. To change the number of 
frames, press the Edit Item softkey and enter a new value.

Range: 1 through 80

Default: 1

NOTE PCntrl (Up/Dn) is only valid if Power Puncturing is enabled.

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 3 > 
Enter > Channel Setup > PCntrl (Up/Dn)
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This key selects the power control ramp as the output at the DATA 
OUT rear panel BNC/SMB connector.

Softkey Location: Mode > CDMA > CDMA2000 > BNC MUX Settings > 
Data Out > PC Ramp

Permuted ESN

This key displays a menu from which you can select the permuted 
electronic serial number for the long code mask used to identify a 
particular mobile.

Range: 00000000 through FFFFFFFF

Default: 00000000

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH or F-FCH > LC Mask > 
Edit Item > Permuted ESN

Phase Polarity 
Normal Invert

This key selects either normal or inverted phase polarity. 

• Highlight Normal to select the standard phase polarity for a signal.

• Highlight Invert to reverse the direction of phase rotation of the 
internal Q signal. 

The choices for this softkey are shared parameters for forward and 
reverse link. So, if Invert is selected in forward link, this will be the 
parameter for reverse link and vice versa.

Default: Normal

NOTE When configuring a two-ESG system in forward or reverse link, Invert 
must be selected on ESG 2.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > 
Phase Polarity Normal Invert

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Phase Polarity Normal Invert

Pilot

This key selects the pilot channel in the reverse link as the output at 
the DATA OUT rear panel BNC/SMB connector.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > Pilot
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PN9

This key selects an internally generated 9-bit pseudorandom number 
pattern as the data bits in various channels.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > PN Sequence > PN9

Softkey Location (Reverse): Mode > CDMA >CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > PN Sequence > PN9

Softkey Location (for Reverse RC 1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel Type > 
R-ACH, R-FCH, or R-SCH > Channel Setup > Data > Edit Item > 
PN Sequence > PN9

PN15

This key selects an internally generated 15-bit pseudorandom number 
pattern as the data bits in various channels.

Softkey Location (Forward): Mode > CDMA > CDMA2000 >Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > PN Sequence > PN15

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > PN Sequence > PN15

Softkey Location (for Reverse RC 1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel Type > 
R-ACH, R-FCH, or R-SCH > Channel Setup > Data > Edit Item > 
PN Sequence > PN15

PN Offset

This field displays the current pseudorandom number offset value. This 
is the time offset in the short sequence code assigned to each base 
station to give it a unique identity. To change the offset value, press the 
Edit Item softkey and enter a new value.

Range: 0 through 511

Default: 0

Data Field Location: Mode > CDMA > CDMA2000 > BTS Setup >
PN Offset
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This key displays a menu of available pseudorandom number 
sequences.

Range: PN9 or PN15

Default: PN9

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH or F-FCH > Channel Setup > 
Data > Edit Item > PN Sequence

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > PN Sequence

Softkey Location (for Reverse RC 1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel Type > 
R-ACH, R-FCH, or R-SCH > Channel Setup > Data > Edit Item > 
PN Sequence

PN Sync

This key selects a signal that indicates the start of the short code 
sequence as the output at the EVENT 1 rear panel BNC/SMB 
connector. 

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Settings > EVENT 1 > PN Sync

Power

This field displays the current channel power value. To change the 
channel power, press the Edit Item softkey and enter a new value.

Range: −40.0 dB through 0.00 dB

Default: 0.00 dB

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
Link Control > 1, 2, 3, or 4 > Enter > Channel Setup > Power

Data Field Location (Reverse): Mode > CDMA > CDMA2000 >
Link Forward Reverse > Link Control > 1, 2, 3, or 4 > Enter > 
Channel Setup > Power

Data Field Location (for Reverse RC 1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel Type > 
R-ACH, R-FCH, or R-SCH > Channel Setup > Power
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Power Puncturing
Off On

This key turns the power puncturing off or on. This parameter is valid 
only for non-zero long code states.

Default: On

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 3 > Enter > 
Channel Setup > P Puncturing > Edit Item > Power Puncturing Off On

PRAT

This field displays the current paging channel data rate value used by 
the base station. To change the data rate, press the Edit Item softkey and 
enter a new value.

Range: 00 through 03 hexidecimal

Default: 00

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > PRAT
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Q Out-no 1/2 Chip Delay

This key outputs an internally generated Q component of I/Q 
modulation with no 1/2 chip offset (I and Q digital signal clocks are 
synchronized) to the DATA OUT rear panel BNC/SMB connector. 
Reverse link radio configuration 1 or 2 is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > Q Out-no 1/2 Chip Delay

QOF

This field displays the current, quasi-orthogonal function channel 
value. To change the channel value, press the Edit Item softkey and 
enter a new value.

Range: 0 through 3

Default: 0

Data Field Location: Mode > CDMA > CDMA2000 > Link Control >
3 or 4 > Enter > Channel Type > F-FCH or F-SCH > Channel Setup > QOF

QPCH

This key selects a forward quick paging channel. This channel type 
enables the mobile to wake up and read the paging channel.

Softkey Location: Mode > CDMA > CDMA2000 > Link Control > 4 > Enter > 
Channel Type > QPCH

Quarter

This key sets the gating rate to one quarter causing 4 power control 
groups (every fourth bit) to be transmitted. The gating rate field is 
available only in the reverse pilot channel.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Link Control > Channel Setup > Gating Rate > Edit Item > Quarter
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R-ACH

This key selects a reverse access channel which is used for the 
transmission of short messages from a mobile to a base station. R-ACH 
is only available in radio configurations 1 and 2.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Mobile Setup > Radio Config > 1 or 2 > Enter > Return > Link Control > 
Channel Type > R-ACH

R-CCCH

This key selects a reverse common control channel which is used for the 
transmission of digital control information from a mobile to a base 
station.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Link Control > 4 > Enter > Channel Type > R-CCCH

R-EACH

This key selects a reverse enhanced access channel which is used for 
the transmission of digital control information from a mobile to a base 
station while operating in the basic access mode. It is used for 
transmission of short messages.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
Link Control > 4 > Enter > Channel Type > R-EACH

Real Time

This key selects a long code signal that repeats, approximately, every 41 
days and is compliant with the specification. This enables functions 
such as bit error rate (BER) testing.

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > LC Generation > Edit Item > 
Real Time

R-FCH

This key selects a reverse fundamental channel which carries 
higher-level data and control information from the mobile to the base 
station. The channel it resides on depends on the radio configuration 
(RC) being used. For RC 3 and RC 4, the R-FCH is a fixed channel that 
does not have a softkey.
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Softkey Location (for RC 1 & RC 2): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Radio Config > 1 or 2 > Enter > 
Return > Link Control > Channel Type > R-FCH

R-SCH

This key selects a reverse supplemental channel that operates in 
conjunction with the reverse fundamental channel to provide a higher 
data rate service. The channel it resides on depends on the radio 
configuration (RC) being used.

Softkey Location (for RC 1 & RC 2): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Radio Config > 1 or 2 > Enter > 
Return > Link Control > Channel Type > R-SCH

Softkey Location (for RC 3): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2 (only for 2-ESG solution) or 4 > 
Enter > Channel Type > R-SCH

Softkey Location (for RC 4): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Radio Config > 4 > Enter > 
Return > Link Control > 2 (only for 2-ESG solution) or 4 > Enter > 
Channel Type > R-SCH

Radio Config

This field displays the current radio configuration value. The radio 
configuration is a set of traffic channel transmission formats that define 
parameters such as data rates and modulation characteristics. Radio 
configurations 1 and 2 are IS-95 backwards compatible.

To change the radio configuration value, press the Edit Item softkey and 
enter in a new value.

Range:
Forward Link:

3 through 5 (F-SCH)
1 through 5 (F-FCH)

Reverse Link: 
       1 through 4

Default: 3

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
Link Control > 2, 3, or 4 > Enter > Channel Type > F-FCH or F-SCH > 
Channel Setup > Radio Config

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Radio Config
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Rectangle

This key selects a one-symbol-wide rectangle filter in either the Select 
(Filter) menu or the Load Default FIR menu.

In the Select (Filter) Menu

Select a rectangle FIR filter for use in the filter setup.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > Rectangle

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
Rectangle

In the Load Default FIR Menu

Pressing the Rectangle softkey followed by the Generate softkey, loads 
the FIR table editor with the coefficient values for a rectangle filter.

The Display Impulse Response and Display FFT softkeys in this menu 
graphically display the filter as it is currently defined in the FIR table 
editor.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Rectangle

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Rectangle

Rename

This key accesses a menu from which you can rename the current file. 

Rename is located in the bit file editor menus.

RESERVED

This field displays the current reserved bit setting for the forward 
synchronization channel. These reserved bits in the frame structure of 
this channel may be used in the future. Presently, all bits that are 
marked as reserved bits, should be set to “0” in all frames. The base 
station and mobile will ignore the reserved bits.

Default: 0

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > RESERVED
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Reset Defaults

This key resets the current output settings of the rear panel BNC/SMB 
connectors to the original factory defaults.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > 
BNC MUX Settings > Reset Defaults

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Setting > Reset Defaults

Restore Default Filter

This key replaces the current FIR filter with the default filter. In 
addition, for the filter characteristics located in the Filter > Edit Item > 
Select > Nyquist, Root Nyquist, or Gaussian path, it will change the 
following filter parameters to the value shown:

• Filter alpha to 0.500

• Filter Bbt to 0.300

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Restore Default Filter

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Restore Default Filter

Rising

This key configures the ESG to trigger on the rising edge of the signal 
applied to the PATTERN TRIG IN of the rear panel BNC/SMB 
connector.

Data Field Location: Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Trigger Edge > Edit > Rising

R/F Bit

This grayed-out field text indicates that, currently, the Reserved/Flag 
Bit is not applicable. The Reserved Flag Bit is part of the frame quality 
indicators.

Default: N/A

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 3 or 4 > 
Enter > Channel Type > F-FCH or F-SCH >Channel Setup > R/F Bit
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Root Nyquist

This key selects a Root Nyquist (root-raised cosine) filter in either the 
Select (Filter) menu or the Load Default FIR menu.

In the Select (Filter) Menu

This key selects a Root Nyquist FIR filter and returns the Select (Filter) 
menu.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > Root Nyquist

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
Root Nyquist

In the Load Default FIR Menu

Pressing the Root Nyquist softkey followed by the Generate softkey, loads 
the FIR table editor with the coefficient values for a Root Nyquist filter. 
The filter alpha and number of filter symbols are defined with the 
softkeys in this menu. If you change either parameter after loading the 
filter coefficients, press the Generate softkey again.

The Display Impulse Response and Display FFT softkeys in this menu 
graphically displays the filter as it is currently defined in the FIR table 
editor.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Root Nyquist

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Root Nyquist
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Scale To 0dB

This key adjusts the code domain power so that the total power is 0 dB. 
When the power is adjusted, the ratios between individual channel 
power values are maintained.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
1, 2, 3, or 4 > Enter > Adjust Code Domain Power > Scale To 0dB

Or: Mode > CDMA > CDMA2000 > Link Control > 2 Box Setup > 
Scale To 0dB

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 1, 2, 3, or 4 > Enter > 
Adjust Code Domain Power > Scale To 0dB

Or: Mode > CDMA > CDMA2000 > Link Forward Reverse > 2 Box Setup > 
Scale To 0dB

Seed

This key accesses a menu from which you can set the initial value of the 
pseudorandom bit sequence.

Range:
PN9 Seed: 000 through 1FF
PN15 Seed: 0000 through 7FFE

Default:
PN9 Seed: 000
PN15 Seed: 0000

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 > Enter > Channel Type > F-SCH, F-FCH, or F-PCH > 
Channel Setup > Data > Edit Item > User File > Edit File or Edit File > 
Insert PN9 or Insert PN15 > Seed

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File > Edit File or Edit File > Insert PN9 or Insert PN15 > 
Seed
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Select

This key accesses a menu from which you can select a filter type. You 
can select from standard filter types, such as Root Nyquist, Nyquist, 
Gaussian, several IS-95 filters, User FIR, Rectangle, APCO 25 C4FM, 
and UN3/4 GSM Gaussian.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select

Select File

This key selects a file in the displayed catalog of binary/bit files.

Select File key is located in the catalogs of files.

SID

This field displays the current system identification value. To change 
the SID, press the Edit Item softkey and enter a new value.

Range: 0000 through 7FFF hexidecimal

Default: 0007

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > SID

Spread Rate

This field displays the current spread rate value. The grayed-out text in 
this field indicates that you cannot change the value.

Default: 1

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
BTS Setup > Spread Rate

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Spread Rate
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Store To File

This key accesses a menu from which you can name the file to be stored 
in the catalog of files.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load/Store > Store To File

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load/Store > Store To File

Symbol Sync Out

This key accesses a menu from which you can modify the output of the 
SYMBOL SYNC OUT rear panel BNC/SMB connector in reverse link 
mode. Items selected from the accessed menu may change when 
switching between radio configuration 1 or 2 and radio configuration 3 
or 4.

Default: Even Second

Softkey Location: Mode > CDMA > CDMA2000 > 
Link Forward Reverse > BNC MUX Settings > Symbol Sync Out

SYS_Time

This field displays the current system time value in hexidecimal. To 
change the system time, press the Edit Item softkey and enter a new 
value.

Range: 000000000 through FFFFFFFFF 

Default: 000000000

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 2 > 
Enter > Channel Setup > SYS_Time
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Tail Bits

This field displays the current tail bits value (hexidecimal). The 
grayed-out text in this field indicates that you cannot change the value.

Default: 00

Data Field Location: Mode > CDMA > CDMA2000 > Link Control > 3 or 4 > 
Enter > Channel Type > F-FCH or F-SCH > Channel Setup > Tail Bits

Trigger Advance

This field displays the current number of chips that the trigger is 
advanced. The trigger advance is referenced to the ESG even second 
clock and is used to synchronize the ESG with the base station. The 
base station’s timing signal is input at the PATTERN TRG IN rear 
panel BNC/SMB connector.

NOTE Changing the trigger advance value may cause the signal generator to 
lose synchronization with the base station signal. 

Range: 0 through 2455999

Default: 18

Data Field Location: Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Trigger Advance

Trigger Edge

This field indicates whether the ESG will trigger on the rising or the 
falling edge of the base station trigger signal. To change the trigger 
edge selection, press Edit Item and then press either the Falling or the 
Rising softkey.

Default: Falling

Data Field Location: Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Trigger Edge

Turbo Coding

This field indicates whether turbo coding is turned off or on. To change 
the status, press the Edit Item softkey and then toggle the 
Turbo Coding Off On softkey to the desired state.

Default: Off
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Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
Link Control > 2 or 4> Enter > Channel Type > F-SCH > Channel Setup > 
Turbo Coding

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2 or 4 > Enter > Channel Type > 
R-SCH > Channel Setup > Turbo Coding

Turbo Coding 
Off On

This key toggles the turbo coding operating state off or on and is used in 
both forward and reverse link. 

Turbo coding is valid for forward supplemental channels with a radio 
configuration of 3, 4, or 5 and can only be used with the following data 
rates: 

RC 3:  19.2, 38.4, or 76.8 kbps

RC 4:  19.2, 38.4, 76.8, or 153.6 kbps

RC 5:  28.8, 57.6, or 115.2 kbps

Turbo coding is valid for reverse supplemental channels with a radio 
configuration of 3 or 4 and is constrained by frame lengths and data 
rates. The following list shows the frame lengths and data rate settings 
that are applicable with turbo coding: 

RC 3 (20ms frame length):   19.2, 38.4, 76.8, or 153.6 kbps

RC 3 (40ms frame length):   9.6, 19.2, 38.4, 76.8, or 153.6 kbps

RC 3 (80ms frame length):   4.8, 9.6, 19.2, 38.4, or 76.8 kbps

RC 4 (20ms frame length):   28.8, 57.6, or 115.2 kbps

RC 4 (40ms frame length):   14.4, 28.8, 57.6, or 115.2 kbps

RC 4 (80ms frame length):   7.2, 14.4, 28.8, or 57.6 kbps

Default: Off

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2 or 4 > Enter > Channel Type > F-SCH > Channel Setup > Turbo Coding > 
Edit Item > Turbo Coding Off On

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2 or 4 > Enter > Channel Type > 
R-SCH > Channel Setup > Turbo Coding > Edit Item > 
Turbo Coding Off On
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UN3/4 GSM Gaussian

This key selects a UN3/4 delay compatible, GSM, Gaussian filter with a 
0.300 fixed BbT.

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > UN3/4 GSM Gaussian

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse> Mobile Setup > Filter > Edit Item > Select > 
UN3/4 GSM Gaussian

User File

This key accesses a menu from which you can select a user-defined file 
to be used as a data bit pattern. 

Softkey Location (Forward): Mode > CDMA > CDMA2000 > Link Control > 
2, 3, or 4 >Enter > Channel Type > F-FCH or F-SCH > Channel Setup > 
Data > Edit Item > User File

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 2, 3, or 4 > Enter > Channel Type > 
R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > Channel Setup > Data > 
Edit Item > User File

Softkey Location (for Reverse RC 1 & RC 2): Mode > CDMA > 
CDMA2000 > Link Forward Reverse > Mobile Setup > Radio Config > 
1 or 2 > Enter > Return > Link Control > Channel Type > 
R-ACH, R-FCH, or R-SCH > Channel Setup > Data > Edit Item > User File

User FIR

This key accesses a menu from which you can select a user-defined FIR 
file. 

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Select > User FIR 

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > Select > 
User FIR
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Voltage This ESG

This field displays the total voltage of the active channels in this ESG 
and is used when configuring a two-ESG system. Enter this value in the 
Voltage Other ESG data field of the ESG that is paired with this ESG. 
See “Adjust the Relative Power Mapping (Two-ESG Forward Link)” 
on page 2-15.

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
2 Box Setup > Voltage This ESG

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > 2 Box Setup > Voltage This ESG

Voltage Other ESG

This field is used when configuring a two-ESG system. Edit this field to 
enter the total voltage value of the paired ESG after setting the channel 
powers of both ESGs. The entered value enables the scale to 0 dB 
function to align the channel voltages between the signal generators. 
The IQ voltage scale will automatically be generated once this value 
has been entered. See “Adjust the Relative Power Mapping (Two-ESG 
Forward Link)” on page 2-15.

NOTE For the single ESG setup, this field needs to be 0.0 V.

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
2 Box Setup > Voltage Other ESG

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > 2 Box Setup > Voltage Other ESG
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Walsh

This field displays the current Walsh code (orthogonal code) values that 
are assigned uniquely to each user in a cell. Walsh code ranges are 
dependent on channel type, radio configuration, data rates and frame 
length.

To change the Walsh code, press the Edit Item softkey and enter a new 
value. If the text is grayed-out in this field, you cannot change the 
value.

The R-SCH for RC1 and RC2 does not have a Walsh code value.

NOTE When selecting a Walsh code for the R-SCH, you need to ensure it is 
compatible with the data rate being used. Due to the flexibility built 
into the ESG, it is possible to set a Walsh code with a data rate that is 
not within IS-2000 specifications. 

Ranges:

Channel
Type

Radio
Configuration

Walsh
Code

Bit Rate
(kbps)

Frame
Length (ms)

Forward Link

F-PICH 0

F-SYNCH 0 - 63

F-FCH 0 - 63

OCNS 0 - 63

F-PCH 0 - 63

F-SCH 3 0 - 31 ≤ 19.2

0 - 15 38.4

0 - 7 76.8

0 - 3 153.6

4 0 - 63 ≤ 19.2

0 - 31 38.4

0 - 15 76.8

0 - 7 153.6

0 - 3 307.2

5 0 - 31 ≤ 28.8

0 - 15 57.6

0 - 7 115.2

0 - 3 230.4

QPCH 1 - 127
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Channel
Type

Radio
Configuration

Walsh
Code

Bit Rate
(kbps)

Frame
Length (ms)

Reverse Link

R-PICH 0

R-DCCH 3 0 - 15 9.6 5 or 20

4 0 - 15 14.4 20

R-EACH 3 - 4 0 - 7 9.6 20

19.2 20 or 10

38.4 20, 10, or 5

R-FCH 3 0 - 15 1.5 20

2.7

4.8

9.6 20 or 5

4 0 - 15 1.8 20

3.6

7.2

14.4

R-SCH 3 0 - 7 1.2 80

1.35 40

1.5 20

2.4 80 or 40

2.7 20

4.8 80, 40, or 20

9.6 80, 40, or 20

19.2 80, 40, or 20

38.4 80, 40, or 20

76.8 80, 40, or 20

153.6 80, 40, or 20

307.2 20

4 1.8 80, 40, or 20

3.6 80, 40, or 20

7.2 80, 40, or 20

14.4 80, 40, or 20

28.8 80, 40, or 20

57.6 80, 40, or 20

115.2 40 or 20

230.4 20

RCCCH 3 - 4 0 - 7 9.6 20

19.2 20 or 10

38.4 20, 10, or 5
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Defaults:

Data Field Location (Forward): Mode > CDMA > CDMA2000 > 
Link Control > 1, 2, 3, or 4 > Enter > Channel Setup > Channel Type > 
F-PICH, F-FCH, F-SCH, F-SYNCH, F-PCH, or QPCH > Walsh

Data Field Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Link Control > 1, 2, 3, or 4 > Enter > 
Channel Type > R-PICH, R-DCCH, R-FCH, R-SCH, R-EACH, or R-CCCH > 
Channel Setup > Walsh

Channel
Type

Radio
Configuration

Walsh
Code

Bit Rate
(kbps)

Frame
Length (ms)

Forward Link

F-PICH 0

F-SYNCH 32 1.2 20

F-FCH 1 10 9.6 20

OCNS 61

F-PCH 1 9.6 20

F-SCH 3 12 19.2 20

F-SCH 4 14 19.2 20

F-SCH 5 14 28.8 20

QPCH 80 4.8 20

Reverse Link

R-PICH 0

R-DCCH 3 8 9.6 20 

R-DCCH 4 8 14.4 20 

R-FCH 3 4 9.6 20

R-FCH 4 4 14.4 20

R-SCH 3 1 307.2 20

R-SCH 4 1 230.4 20

R-CCCH 3 - 4 2 38.4 20

R-EACH 3 - 4 2 38.4 20
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Window

This key accesses a menu from which you can apply a windowing 
function to the selected filter. The default is to use no windowing which 
optimizes the passband response (EVM). Several windowing selections 
are provided in this menu to smooth the filter’s transition to zero. 
Windowing improves adjacent channel power performance (ACP) but 
simultaneously degrades EVM.

Default: None

Softkey Location (Forward): Mode > CDMA > CDMA2000 > BTS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > 
Root Nyquist or Nyquist > Gaussian or Rectangle > Window

Softkey Location (Reverse): Mode > CDMA > CDMA2000 > 
Link Forward Reverse > Mobile Setup > Filter > Edit Item > 
Define User FIR > Load Default FIR > Root Nyquist or Nyquist > 
Gaussian or Rectangle > Window
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Z

Zi 

This key selects the in-phase portion of the reverse fundamental 
channel as the output at the DATA OUT rear panel BNC/SMB 
connector. Reverse link radio configuration 3 or 4 is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse > 
BNC MUX Settings > Data Out > Zi

Zq 

This key selects the quadrature portion of the reverse fundamental 
channel as the output at the DATA OUT rear panel BNC/SMB 
connector. Reverse link radio configuration 3 or 4 is required.

Softkey Location: Mode > CDMA > CDMA2000 > Link Forward Reverse >
BNC MUX Settings > Data Out > Zq
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Option 201
4  Operation

This chapter contains detailed information that will help you understand the operation of 
your Option 201 signal generator(s). 

The chapter is divided into the following sections:

• “Understanding the Single-ESG Configuration” on page 4-2

• “Understanding the Two-ESG System Configuration” on page 4-3

• “Forward and Reverse Link Channel Structures” on page 4-6

• “Forward and Reverse Link I/O Signal Descriptions and Timing Relationships” 
on page 4-9

• “Forward and Reverse Link Relative Power Mapping” on page 4-16

• “Understanding the Forward Paging Channel” on page 4-17

• “Option 201 Operational Characteristics” on page 4-19
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Understanding the Single-ESG Configuration

The Option 201 single-ESG configuration provides IS-95 receiver design testing in forward 
and reverse link and IS-2000 receiver designs in reverse link.

This configuration utilizes internal I/Q triggering. The rear panel EVENT 1 BNC/SMB 
connector provides an even second clock with adjustable delay. The even second output 
provides a pulse every two seconds and can be used to synchronize other instruments in 
the test system. The even second delay can be adjusted to align the frame timing with the 
RF output.

Forward Link Capabilities

The Option 201 forward link, single-ESG setup is used for testing IS-95 compatible 
receiver designs. It provides four IS-95 backwards compatible channels with real-time 
generation capability. In addition to providing IS-95 compatibility, a partial IS-2000 signal 
can be transmitted using up to four IS-2000 channels. The single-ESG setup provides the 
following forward link channel types: pilot, sync, paging, supplemental (RC3–5), and 
OCNS (optional) or RC1 (or RC2) fundamental traffic channels. The RC1 and RC2 traffic 
channels are IS-95 backwards compatible.

Reverse Link Capabilities

The Option 201 reverse link, single-ESG setup provides IS-95 backwards compatibility in 
RC1 and RC2. These radio configurations provide a single selectable channel type: R-ACH, 
R-FCH, or R-SCH. Within these radio configurations, you can perform tests by sending 
short signaling messages, simulating response to pages, and sending data using the 
fundamental or supplemental traffic channels.

IS-2000 testing is accomplished using RC3 and RC4. These radio configurations allow fully 
coded signals with up to four channels consisting of the following types: R-PICH, R-DCCH, 
R-FCH, R-SCH, R-CCCH, and R-EACH. The R-PICH allows adjustable gating and power 
control bit (PCB) puncturing. The traffic channels provide frame length and offset 
adjustments, incremental data rates and selectable Walsh codes.
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Understanding the Two-ESG System Configuration

The Option 201 two-ESG configuration allows for more complex signal transmission in 
both the forward and reverse links for testing IS-2000 receiver designs. The two-ESG 
configurations require that both sources route the I/Q signals through the rear panel 
BNC/SMB outputs into the ESG 1 front panel I/Q inputs where ESG 1 combines the 
signals from the two sources. This system configuration uses ESG 2 as an external data 
clock for ESG 1 and ESG 2. Because the two sources are unable to communicate with one 
another, there is a power mapping process that must be performed in order for the 
combined signals to be transmitted at the proper code domain power level (refer to 
“Forward and Reverse Link Relative Power Mapping” on page 4-16 for more information).

Converting a Two-ESG System to a Single-ESG Configuration

Due to the power mapping requirements of a two-ESG system, the conversion from a 
two-ESG to a single-ESG configuration requires that you preset the ESG to factory-defined 
settings. This will ensure that the values previously entered in the power mapping process, 
are reset to zero. Failure to preset the ESG may result in inaccurate code domain power 
levels while trying to use the single-ESG configuration. Refer to Chapter 2, “Using 
Functions,” for information on configuring a single ESG.

Forward Link Capabilities

In addition to providing up to five IS-95 channels, the forward link two-ESG system 
configuration provides an IS-2000 solution in situations where more real-time CDMA 
channels, power levels, or higher radio configurations are required. The two-ESG setup 
provides the following forward link channel types: pilot, sync, paging, OCNS (optional), 
RC1–5 fundamental and RC3–5 supplemental traffic channels.

The Option 201 forward link has the ability to transmit IS-95 (RC1–2) and IS-2000 
(RC3–5) traffic channels simultaneously. However, this may cause a Code Power Err 
message to appear. When this error is displayed, I/Q distortion may be present on the 
transmitted signal. Because of this, transmitting IS-95 and IS-2000 channels 
simultaneously is not recommended. 

Generating a Third Forward Link RC3, RC4, or RC5 Traffic Channel

For situations where the resulting power deviation is not a concern, Option 201 also 
supports the capability for a third RC3, RC4, or RC5 traffic channel (with some 
limitations) provided by the baseband generator in ESG 2. 

On ESG 2, the channel 3 or 4 F-SCH may be selected as the second supplemental traffic 
channel. However, if three RC3, RC4 or RC5 traffic channels are selected, a Code Power 
Err message will appear on the ESG display. This is because the number of points required 
for I/Q mapping exceeds the number of points available and some I/Q distortion may be 
present. This will result in some symbols having errors associated with them and the code 
domain will exhibit some artifacts. The following section, “Forward Link I/Q Map 
Rotation,” explains how to compensate for this condition when three traffic channels are 
used.
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Forward Link I/Q Map Rotation

In situations where Code Power Err appears, while generating a third traffic channel, the 
ESG allows a 45 degree rotation of the I/Q map to alleviate this error. Rotating the I/Q map 
on both ESG 1 and ESG 2 allows the generation of three RC3, RC4, or RC5 traffic channels 
on ESG 2. 

While using rotated I/Q maps, only two channels can be generated on ESG 1. For example, 
a forward link pilot channel and a forward link sync channel on ESG 1, and a forward 
fundamental traffic channel and two forward supplemental traffic channels on ESG 2.

Because both constellations are rotated, they maintain a 45 degree orientation to each 
other and decoding remains valid.

Reverse Link Capabilities

In addition to having the same capabilities as the single ESG for IS-2000, the Option 201 
reverse link two-ESG configuration allows for a fully coded signal to be transmitted with 
up to five channels, four on ESG 1 and an additional R-SCH on ESG 2. The IS-2000 
features of the two-ESG system use RC3 and RC4 which allows for higher data rates and 
turbo coding. This complex signal structure allows for a more thorough testing of the base 
station functionality.

Forward and Reverse Link System Functionality

Figure 4-1. illustrates how the separate sections of the IS-2000 frame are generated by 
separate baseband generators, one within ESG 1 and another within ESG 2. The two 
sections of the frame are then combined at the I/Q inputs of ESG 1 and modulated to the 
carrier by the RF section within ESG 1. After carrier frequency and amplitude are 
introduced, the IS-2000 signal is output to the DUT through the RF output of ESG 1. The 
RF section of ESG 2 is utilized to supply the data clock for both baseband generators. 
(Alternatively, an external function generator, where the reference frequency is locked in 
with the system, may be used to supply the data clock.) 
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Figure 4-1. Block Diagram of the Two-ESG IS-2000 System
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Forward and Reverse Link Channel Structures
The following subsections list the channel structures that are supported on the ESG(s). 
The structures should be implemented as shown in the tables.

Forward Link Supported Channel Structures
Table 4-1. IS-95 Forward Link Supported Channel Structures

IS-95 Compatible Channels

Channel 1 Channel 2 Channel 3 Channel 4

F-PICH

F-PICH F-SYNCH

F-PICH F-FCH (RC1–2)

F-PICH F-PCH

F-PICH F-SYNCH F-FCH (RC1–2)

F-PICH F-SYNCH F-PCH

F-PICH F-SYNCH F-FCH (RC1–2) F-PCH

F-PICH F-SYNCH OCNS F-PCH
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Table 4-2. IS-2000 Forward Link Supported Channel Structures

ESG 1 ESG 2

Ch 1 Ch 2 Ch 3 Ch 4 Ch 1 Ch 2 Ch 3 Ch 4

F-PICH

F-PICH F-SYNCH

F-PICH F-FCH (RC3–5)

F-PICH F-PCH

F-PICH F-SYNCH F-FCH (RC3–5)

F-PICH F-SYNCH F-PCH

F-PICH F-SYNCH F-FCH (RC3–5) F-PCH

F-PICH QPCH

F-PICH F-SYNCH QPCH

F-PICH F-SYNCH OCNS F-PCH F-FCH (RC3–5)

F-PICH F-SYNCH OCNS F-PCH F-SCH (RC3–5) F-FCH (RC3–5)1

1. Using IS-95 backwards compatible traffic channels (RC1–2) with IS-2000 traffic channels (RC3–5) may 
generate an error message (Code Power Err) and cause I/Q distortion.

F-PICH F-SYNCH OCNS F-PCH F-FCH (RC3–5)1 F-SCH (RC3–5)

F-PICH F-SYNCH OCNS F-PCH F-SCH (RC3–5) F-FCH (RC3–5)1 F-SCH (RC3–5)2

2. Use of an additional supplemental channel on ESG 2 to generate a third traffic channel, may cause 
I/Q distortion. Refer to “Generating a Third Forward Link RC3, RC4, or RC5 Traffic Channel” on page 4-3 for 
detailed information.
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Reverse Link Supported Channel Structures

Table 4-3. RC1 and RC2 Reverse Link Supported Channel Structure

Channel 1

R-FCH

R-ACH

R-SCH

Table 4-4. RC3 and RC4 Reverse Link Supported Channel Structures

ESG 1 ESG 2

Ch 1 Ch 2 Ch 3 Ch 4 Ch 1 Ch 2 Ch 3 Ch 4

R-PICH1

1. These are the only channel structures that allow quarter- and half-gating.

R-PICH R-DCCH

R-PICH F-FCH

R-PICH R-DCCH F-FCH

R-PICH F-FCH R-SCH0

R-PICH R-DCCH F-FCH R-SCH0

R-PICH R-DCCH F-FCH R-SCH0 R-SCH1

R-PICH1 R-EACH

R-PICH1 R-CCCH
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Forward and Reverse Link I/O Signal Descriptions and 
Timing Relationships

The following subsections describe the functionality and timing relationships of various 
BNC/SMB I/O connectors for forward and reverse link on the Option 201 signal generator. 
Option 201 changes some of the standard characteristics of the signals normally used on 
some of the BNC/SMB I/O connectors. This is done for IS-2000 applications. Some output 
connectors have additional output signal selections, which are stated within the 
descriptions. For a description of the additional output capabilities, refer to Chapter 3 , 
“Softkey Reference.”

Connector descriptions are divided into three subsections: front panel BNC/SMB inputs, 
rear panel BNC/SMB inputs, and rear panel BNC/SMB outputs.

Diagrams are provided on page 4-13, page 4-14, and page 4-15 that show the timing 
relationship between rear panel BNC/SMB inputs and outputs.

Front Panel BNC/SMB Inputs

DATA (Forward Link)

This connector is used for data input.

The external data input can only be used by F-FCH or F-SCH channels. If these two 
channel types are assigned external data, the same data is input to both the F-FCH 
and F-SCH channels. Both channel types must be assigned radio configurations with 
the same modulation symbol rate. 

The serial data must be input at the modulation symbol rate and aligned with the 
internal F-FCH (or F-SCH) modulation symbol clock. Coded and framed data must be 
aligned with internal frame timing.

For RC1 and RC2 channel types, the symbol data input timing aligns with internal 
frame timing. For RC3–5, the I/Q symbol pair, for a given frame position, must input 
two I/Q symbol pair periods before that frame position. The I and Q symbol data is 
sampled at the end of the symbol period and must be stable.

The external data is input at the modulation symbol node and is spread with the 
decimated long code. Subsequently, power control symbol puncturing (for F-FCH 
channel types only), Walsh coding, and I/Q mapping are applied. 

Serial data clock and frame timing can be generated from the chip clock and even 
second outputs. See the following section, “Rear Panel BNC/SMB Outputs.” 

DATA CLOCK (Forward and Reverse Link)

This connector is used for a chip clock input. 

This input is used for the external reference input (generally a 1.2288 MHz TTL or 
CMOS signal) for data and baseband generation. This input is active only after 
toggling the baseband data generator clock from internal to external. 
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Rear Panel BNC/SMB Inputs

ALT PWR IN (Forward Link)

This connector is used for a Long Code State Latch strobe input. 

The leading edge of the long code state latch strobe input is latched and sampled by 
the chip clock. The current state of the long code is latched and held until the next 
trigger input. Subsequently, the long code state held in the latch can be read via the 
GPIB or RS-232 ports.

BURST GATE IN (Forward and Reverse Link)

This connector is used for an even second synchronization input. 

The even second signal is used for frame and long code alignment between the two 
signal generators, ESG 1 and ESG 2. If the even second input edge from the second 
signal generator (ESG 2) does not align with the internal even second of ESG 1, the 
frame timing and long code state are reset. The burst gate input is edge-sensitive. It 
can be left high or low without causing a system reset.

PATTERN TRIG IN (Forward and Reverse Link)

This connector is used for a system reset trigger input. 

This system reset trigger ensures frame and long code timing alignment. The reset 
trigger is used to align ESG 2 with ESG 1 in a two-ESG configuration. In addition, 
the trigger is used to align a reverse link configuration with the base station. Any 
change in the state of ESG 1 requiring a reset of long code and channel frame timing, 
will generate a system reset trigger at the ESG 2 rear panel PATTERN TRIG IN and 
re-synchronize the signal generators. When the ESG(s) is being used as a mobile 
station, the reset signal is provided by the BTS via the PATTERN TRIG IN connector 
on the single ESG or ESG 1 in the two-ESG configuration.
4-10 Real-Time cdma2000 Personality User’s and Programming Guide



ESG Family Signal Generators Operation
Option 201 Forward and Reverse Link I/O Signal Descriptions and Timing Relationships
Rear Panel BNC/SMB Outputs

DATA OUT (Forward Link)

This connector is used for the power control group bit state output. It has an 
additional output capability through the softkey menus.

The state of the power control bit (used for power control puncturing during the 
current power control group) is output on this BNC/SMB connector. The output is 
aligned with data generation timing and leads the baseband and RF outputs by 
approximately 17 chips (even second delay). This output can be used to synchronize 
receiver measurements of mobile power output.

There is one other output signal selection for this connector which is a delayed 80 ms 
trigger.

DATA OUT (Reverse Link)

This connector is used for the long code output. It has additional output capabilities 
through the softkey menus.

This connector provides an external output for the current long code being processed. 
The beginning of the long code occurs two chips after a system reset, leads the 
SYMBOL SYNC OUT signal by 257 chips in RC1–2 and 1 chip in RC3–4, and leads 
the delayed even second signal by approximately 17 chips (even second delay). The 
long code rear panel output occurs prior to the RF output.

The other selections for this connector allow the output of channel coded data for 
most types of channels, and the in-phase or quadrature portion of the fundamental 
channel.

DATA CLK OUT (Forward Link and Reverse Link)

This connector provides an external output for the chip clock. For reverse link, it has 
an additional output capability through the softkey menus.

The chip clock provides a 1.2288 MHz TTL signal with one-chip wide pulses that is 
used for the timing to determine when events will occur. The BTS timing and the 
system resync signals both start at the first available rising chip clock pulse edge. All 
other signal start times are counted using the chip clock pulses relative to the first 
pulse occurrence of the timing or resync signal. The trigger advance, even second 
delay, and the other internal leading chips, relative to the delayed even second 
signal, are counted using the one-chip wide chip clock pulse.

In reverse link, there are other selectable clock rates, 1 group for RC1–2 and another 
for RC3–4.
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EVENT 1 (Forward and Reverse Link)

This connector is used for the delayed even second output. It has additional output 
capabilities through the softkey menus.

This connector provides a one-chip wide signal output with variable delay from the 
internal data generation even second. The delay is adjustable (via the front panel 
user interface or remote interface, Even Sec Delay) to allow even second alignment 
with baseband and RF outputs. Data generation timing leads the baseband and RF 
outputs by approximately 17 chips (even second delay).

In forward link, there are two other trigger signals available, a delayed 20 and 80ms 
signal.

For reverse link, there is one other softkey selection for the output which is PN Sync. 
The PN Sync is a signal that indicates the start of the short code.

EVENT 2 (Forward Link)

This connector is used for the system reset output. 

The system reset trigger outputs whenever a PN offset value changes or differences 
in frame and long code timing alignment are apparent between the signal 
generators. Any change in the state of ESG 1 PN offset value (or other change 
requiring a reset of long code and channel frame timing) will generate a chip-wide 
system reset trigger output at the ESG 1 rear panel EVENT 2 OUT.

EVENT 2 (Reverse Link)

This connector is used for the system reset output. 

The system reset trigger occurs whenever the input BTS timing signal (PATTERN 
TRIG IN connector) and the ESG’s delayed even second clock are not aligned. In the 
two-ESG configuration, the BTS timing signal is connected to ESG 1. When the reset 
occurs, ESG 1 Event 2 connector outputs a reset signal to the ESG 2 PATTERN 
TRIG IN connector. This ensures that both ESGs align properly with the BTS timing 
signal. 

SYMBOL SYNC OUT (Forward and Reverse Link)

This connector is used for the even second output. For reverse link, it has an 
additional output capability through the softkey menus.

The one-chip-wide even second signal is aligned with the internal data generation 
timing. It is used for frame and long code alignment between the two signal 
generators, ESG 1 and ESG 2. If the even second input edge from the ESG 2 does not 
align with the internal even second from ESG 1, the frame timing and long code state 
are reset. 

In reverse link, there is a Long Code Sync selection which provides a trigger to 
signal the start of the long code.
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Forward Link I/O Timing Relationships

Figure 4-2. illustrates the forward link timing relationships between the signals at the 
rear panel BNC/SMB output and input connectors. Signal states are referenced to the chip 
clock provided at the DATA CLK OUT connector.

Figure 4-2. Forward Link Timing Diagram
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Reverse Link I/O Timing Relationships

Reverse link has two different timing diagrams, one for RC1–2 (Figure 4-3.) and another 
for RC3–4 (Figure 4-4.). Both diagrams illustrate the timing relationships between the 
signals at the rear panel BNC/SMB output and input connectors. Signal states are 
referenced to the chip clock provided at the DATA CLK OUT connector.

Figure 4-3. Reverse Link I/O Timing Diagram for RC1–2
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Figure 4-4. Reverse Link I/O Timing Diagram for RC3–4
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Forward and Reverse Link Relative Power Mapping

The Option 201 two-ESG system configuration, used in the forward and reverse modes, 
require adjustments to the code domain power of each active channel in order to achieve 
the expected IS-2000 code domain power output. 

Once a test system has been properly connected and configured, a power mapping 
procedure must be performed to ensure accurate code domain power levels. This procedure 
is the same for both forward and reverse link. 

ESG 1 and ESG 2 cannot communicate channel power level information between the two 
signal generators. The Relative Power Mapping Procedure solves this problem. 

This procedure ensures that the individual channel power levels generated on ESG 1 are 
aligned with the channel power levels produced by ESG 2 to achieve the expected IS-2000 
code domain power levels. 

By making adjustments to percent power paired and total voltage paired, the power output 
of the second baseband generator is matched to the first, resulting in a 0 dB overall system 
code domain output power value. 

Voltage Other ESG values and % Power Other ESG values must be input to ESG 1 and 
ESG 2 via the front panel user interface or by executing SCPI commands via remote 
interface. See “Adjust the Relative Power Mapping (Two-ESG Forward Link)” on page 2-15.

NOTE To ensure accuracy, the Relative Power Mapping Procedure must be repeated 
everytime a channel power level setting is modified on either ESG.

In the forward link mode, there is an OCNS that generates orthogonal noise in the code 
domain. If specific forward link channel power levels are required, adjusting the power 
level of orthogonal noise is an easy way to add fill-in power in order to achieve the required 
code domain power output while keeping the original channel power values intact.
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Understanding the Forward Paging Channel
The signal generator can play a paging message file through the forward paging channel 
(F-PCH), channel 4. The paging file can contain one or more messages with a maximum 
file length of 512 bytes. The messages are continuously played (synchronous paging 
messages) whenever the paging channel is active. 

You can use the five default paging messages contained in the signal generator’s default 
paging file or a user-defined paging message file. 

The default paging message file contains the five messages shown below. These messages 
are played continuously in consecutive paging slots. 

• System parameters message 
msg = 01 06 00 00 1C 00 04 1D
 08 00 09 C0 9F 00 14 F3

59 99 17 9C 00 44 47 83
07 1C 81 4C 0

• Access parameters message
msg = 02 06 00 00 00 4F 40 00

 00 00 02 80 08 80 0

• Neighbor list message
msg = 03 06 01 80 48 16 81 80

19 81 B0 1C 81 E0 0

• CDMA channel list message
msg = 04 06 00 60 0

• General page message
msg = 11 08 5C 80 0

These default paging file messages can be played manually (see “Creating a Synchronous 
Paging Message” on page 2-29) or remotely (see “F-PCH Data” on page 5-10).

In addition to the default paging file, the signal generator allows a user paging file to be 
defined. Allowable messages are defined in the IS-95 standard. The user-defined paging 
file can be 512 bytes (4096 bits) in length.

Using a SCPI command, a one-time message (asynchronous paging message) may be 
inserted into the F-PCH paging stream. When the SCPI command is received, and the 
current message is completed, the one-time message is inserted into the paging message 
stream. After the one-time message has played, the paging channel reverts to the original 
paging file messages. (See “F-PCH Message” on page 5-11.)

The next section details the paging message format.
Real-Time cdma2000 Personality User’s and Programming Guide 4-17



Operation ESG Family Signal Generators
Understanding the Forward Paging Channel Option 201
Forward Link User-Defined Paging Messages

Every paging message consists of a header followed by the bit representation of the 
message. The header portion of the paging message is the message length in bits and is 
padded to the left with zeros to get the required 16-bit length. 

The General page message, shown previously, is used as an example for creating user- 
defined messages in a paging file. (Refer to TIA/EIA-95-B Section 7-89 for information on 
the General page message.) The figure below shows the signal generator’s paging file 
editor screen and the bit representation for the General page message. The General page 
message consists of the 16-bit header followed by the bit representation of the hexadecimal 
message. 

NOTE The row numbers in the Offset field can be used to count the number of bits 
in the Binary Data field. Each row number differs by a hexadecimal value of 
20 (32 in decimal). Therefore, each row can have a maximum of 32 bits 
(8 groups of 4 bits). This information allows you to quickly determine the 
length of your file.

If the General page message is used as a one-time message, it is described as follows:

The header has a hexadecimal value of 22 (0000 0000 0010 0010), which represents the 
number of bits in the paging message (34 in decimal). The bit value of the General page 
message is 0001 0001 0000 1000 0101 1100 1000 0000 00. This message can be played 
as a one-time message using a remote SCPI command (see “F-PCH Message” 
on page 5-11). The message format is <bit count>, <datablock>. The following SCPI 
command will output the General page message.

[SOURce]:RADio:CDMA2000:[:BBG]:FORWard:FPCH:SETup:MESSage 34,#17 0022 
0001 0001 0000 1000 0101 1100 1000 0000 0

For more information on the command format and downloading files, see the 
programming guide, Chapter 3, “Remote Data Transfer.” 

Header 
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Option 201 Operational Characteristics
The following subsections describe some of the unique operational characteristics that may 
be encountered while you configure the Option 201 signal generator.

Walsh Codes

This section will explain some of the different characteristics that may apply while 
entering Walsh code values.

Conflicting Walsh Code Values

In both forward and reverse link, the ESG will allow entering the same Walsh code for 
multiple channels. However, once the channels with the same Walsh codes are turned on, a 
settings conflict error is generated (error number and type will be shown in the lower left 
corner of the display). The error text can be viewed by pressing the following keys:

Utility > Error Info

Pressing the Clear Error Queue(s) softkey will clear all error messages.

Reverse Link R-SCH Walsh Codes and Data Rates 

Walsh code, data rate, and frame length values are dependent upon one another. With the 
flexibility that the ESG allows, it is possible to enter a Walsh code and data rate 
combination for the R-SCH that is not in accordance with IS-2000 specifications. Using 
such a combination is not recommended and may cause an increase in the FER. 

R-PICH Gating

R-PICH quarter- or half-gating is only allowed in the following channel configurations:

• R-PICH active

• R-PICH and R-CCCH active

• R-PICH and R-EACH active

Reverse Link Filters

There are four filters that have or start with the naming convention of IS-95: IS-95, 
IS-95 w/EQ, IS-95 Mod, and IS-95 Mod w/EQ. All four filters are accessible from the 
reverse link, CDMA2000 menu by pressing Mobile Setup > Filter > Edit Item > Select > 
IS-95 and IS-2000. Of these four filters, only the following two should be used in reverse link:

• IS-95

• IS-95 Mod

The IS-95 w/EQ and the IS-95 Mod w/EQ filters are used for forward link. Their purpose is 
to simplify the mobile receiver design for receiving base station transmissions. Using them 
in reverse link may cause the mobile station signal to be indiscernible.
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Forward and Reverse Link Couplings

Couplings are safeguards/buffer limits that will cause a state or field value to change when 
an invalid condition occurs. In some instances, a coupling may not allow a current state to 
change until a certain condition is met. For example, in some fields on the ESG, if an illegal 
value is entered in one field that violates the IS-2000 specifications for other fields, it may 
cause the value in the other fields to reset to their default values. Refer to Chapter 3 , 
“Softkey Reference,” for information on specific fields and softkey default values.

Some of the conditions that cause the couplings to initiate will also generate error 
messages. When an error message is generated, you will see an error message number and 
type appear in the lower left corner of the ESG display. To view error messages, press 
Utility > Error Info. If more than one message is available, press the View Next Error Message 
softkey to display the next error message. To clear error messages, press the Clear Error 
Queue(s) softkey.

Couplings for Option 201 are shown in the following lists:

Applies to Forward and Reverse Links

• The CDMA2000 Off On softkey cannot be set to On until at least one channel is active.

Applies to Forward Link

• Radio configuration changes will reset the data rate if it is not applicable to the new 
radio configuration.

• Turbo coding is turned off if a data rate is entered that is not applicable to this feature.

• The Walsh code for a channel will be reset if an invalid data rate is entered for the same 
channel.

• Channel three will turn off when the QPCH, on channel four, is turned on (QPCH 
requires channels 3 and 4 to operate). 

• QPCH, on channel four, will turn off if channel three is turned on.

Applies to Reverse Link

The reverse link couplings are explained in detail in the following list and are summarized 
in Table 4-5.

• Radio configuration changes will reset the Frame Length, Data Rate and Frame 
Offset fields to default values for all channel types in the newly selected radio 
configuration. In addition, the Turbo Coding field will be set to Off.

• Frame length changes will reset the Frame Offset and Data Rate fields to default 
values.

• Turbo coding is turned off if a data rate is entered that is not applicable to this feature.

• When R-SCH1 (channel two) is turned on, channels one, three, and four will turn off. 

• If R-SCH1 (channel two) is on and the R-PICH, R-FCH, or the R-SCH0 is turned on, 
then the R-SCH1 on channel two will change to the R-DCCH and remain on.

• If the R-CCCH or the R-EACH (channel four) is selected, channels two and three will 
turn off.
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• If the R-CCCH or the R-EACH is on and the R-DCCH or the R-FCH is turned on, 
channel four will remain on, but the channel type will change to R-SCH0.

• R-PCH quarter- and half-gating will reset to full when invalid channels are turned on.

Shared Forward and Reverse Link Parameters

Shared parameters are values or settings that are valid in both forward and reverse link. 
For example, if the value for the Even Sec Delay field on the ESG is changed in forward 
link, this new value will also be valid when the user changes to reverse link (this assumes 
that the Preset softkey has not been used when changing between links).

The following is the list of shared parameters:

• Even Sec Delay data field

• Chip Rate data field

• BBG Data Clock Ext Int softkey

• Phase Polarity Normal Invert softkey

Table 4-5. Reverse Link Couplings

Coupling 
Affects

Action Performed to Initiate Coupling

RC 
Change

Frame 
Length 
Change

Data 
Rate 
Change

R-DCCH, 
R-FCH, or 
R-SCH0 on

R-SCH1 
(Ch 2) 
on

R-PICH, 
R-FCH, or 
R-SCH0 on

R-CCCH 
or 
R-EACH 
on

R-DCCH 
or R-FCH 
on

Frame Length ●

Frame Offset ● ●

Data Rate ● ●

Turbo coding ● ●

R-PCH Gating ●

Channels 1, 3, 
and 4

●

R-SCH1 (Ch 2) ● ●

Channels 2 and 
3

●

R-CCCH or 
R-EACH

●
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ESG Family Signal Generators
Option 201
5 Remote Programming and Examples

This chapter describes Option 201 SCPI commands and provides programming examples.

The descriptions of commands include syntax requirements, ranges, restrictions, queries, 
and status at *RST.
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cdma2000 Subsystem SCPI Command Reference
Use the following SCPI commands to remotely set the controls and parameters associated 
with the cdma2000 communications standard. The commands are listed in alphabetical 
order by subject.

Adjust Code Domain Power

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:PADJust EQUal|SCALe

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:PADJust EQUal|SCALe

Execute this command to set the code domain power. 

EQUal  sets the channel power levels so that all channels are of equal power and 
the total power equals 0 dB.

NOTE The EQUal command is only for a single-ESG configuration.

SCALe  scales all of the current channel powers so that the total power equals 0 dB 
while maintaining the previous power ratios between the individual 
channels.

BBG Data Clock External Internal

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BBCLock INT[1]|EXT[1]
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BBCLock?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BBCLock INT[1]|EXT[1]
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BBCLock?

Execute this command to select the data clock source.

Choices: INT (internal data clock) or EXT (external data clock) 

*RST Value: Internal
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cdma2000 State

[:SOURce]:RADio:CDMA2000[:BBG][:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:STATe]?

Execute this command to set the operating state of cdma2000.

Choices: ON (1) or OFF (0)

*RST Value: OFF

cdma2000 Link

[:SOURce]:RADio:CDMA2000[:BBG]:LINK FORWard|REVerse
[:SOURce]:RADio:CDMA2000[:BBG]:LINK?

Execute this command to select either forward or reverse link cdma2000.

*RST Value: Forward

Chip Rate

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:CRATe <50 cps - 1.3 Mcps>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:CRATe?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:CRATe <50 cps - 1.3 Mcps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:CRATe?

Execute this command to adjust the chip rate. The default value (1.228800 Mcps) is in 
accordance with the IS-2000 specification.

Range: 50 cps through 1.3 Mcps

*RST Value: 1.228800 Mcps

Even Second Delay

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:ESDelay <0.5 - 128.0>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:ESDelay?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:ESDelay <0.5 - 128.0>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:ESDelay?

Execute this command to modify the even second clock pulse. The even second clock pulse 
sets the delay to align the RF with the trigger.

Range: 0.5 through 128 cps

*RST Value: 17.5 cps
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Filter Configuration - Alpha, BbT, Optimization, Type

NOTE For information regarding user FIR filter creation and downloading, see the 
ESG Family Signal Generators Programming Guide.

Filter Alpha (for Nyquist or Root Nyquist)

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:ALPHa <0.0 - 1.0>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:ALPHa?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:ALPHa <0.0 - 1.0>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:ALPHa?

Execute this command to change the alpha value on the Nyquist or Root Nyquist filter. 
This command is effective only after choosing the Root Nyquist (RNYQuist)or Nyquist 
(NYQuist)filter; it does not effect other types of filters.

Range: 0.000 through 1.000

*RST Value: 0.220

Filter BbT (for Gaussian)

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:BBT <0 - 1.0>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:BBT?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:BBT <0 - 1.0>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:BBT?

Execute this command to change the bandwidth-multiplied-by-bit-time filter value. This 
command is effective only after choosing the Gaussian (GAUSsian) filter; it does not affect 
other types of filters.

Range: 0.100 through 1.000

*RST Value: 0.500
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Filter Optimization (for Nyquist or Root Nyquist)

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:CHANnel EVM|ACP
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:CHANnel?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:CHANnel EVM|ACP
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:CHANnel?

Execute this command to optimize a filter for minimized error vector magnitude (select 
EVM) or for minimized adjacent channel power (select ACP). 

*RST Value: EVM

Filter Type

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer RNYQuist|NYQuist|GAUSsian| 
RECTangle|IS95|IS95_EQ|IS95_MOD|IS95_MOD_EQ|AC4Fm|UGGaussian|"<User FIR>"
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer RNYQuist|NYQuist|GAUSsian|
RECTangle|IS95|IS95_EQ|IS95_MOD|IS95_MOD_EQ|AC4Fm|UGGaussian|"<User FIR>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

Execute this command to select a filter type. The following filter choices are available:

RNYQuist  Root Nyquist

NYQuist  Nyquist

GAUSsian  Gaussian

RECTangle  Rectangle

IS95  IS-95

IS95_EQ  IS-95 with equalizer

IS95_MOD  IS-95 modified

IS95_MOD_EQ  IS-95 modified with equalizer

AC4Fm  APCO 25 C4FM

UGGaussian  UN3/4 delay compatible, fixed 0.300 BbT, GSM Gaussian

"User FIR"  User-defined FIR
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Forward cdma2000 Setup

Data Out

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:DOUT PCRamp|D80Trigger
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:DOUT?

Execute this command to set the output of the DATA OUT rear panel BNC/SMB connector.

*RST Value: PC ramp

Event 1

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVENt DESecond|
D20Trigger|D80Trigger
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVENt?

Execute this command to set the output at the EVENT 1 rear panel BNC/SMB connector.

*RST Value: Delayed Even Second

Forward Fundamental Channel Setup

F-FCH Data

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA PN9|PN15|FIX4|
"<file name>"|EXT
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA?

Execute this command to configure the data field for the forward fundamental channel. 
The choices are the following:

PN9  Pseudorandom bit pattern

PN15  Pseudorandom bit pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file in the catalog of binary files

EXT  External input data pattern

*RST Value: PN9
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F-FCH Data Rate

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:
RATE <RC dependent:1.2, 1.5, 1.8, 2.4, 2.7, 3.6, 4.8, 7.2, 9.6, 
14.4kbps>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:RATE?

Execute this command to adjust the data rate for the forward fundamental channel. The 
choices are the following:

*RST Value: 9.6 kbps (RC3)

F-FCH FIX4

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA:FIX4?

Execute this command to select a fixed 4-bit data pattern to be repeated as necessary to fill 
the selected data area.

Range: 0 through 15

*RST Value: 0000

F-FCH Frame Offset

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:FOFFset?

Execute this command to set the frame offset value.

Range: 0 through 15

*RST Value: 0

F-FCH Long Code Mask ESN

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask:
ESN <0 - 0xFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask:ESN?

Execute this command to set the permuted electronic serial number (ESN) for the long 
code mask. This is used to identify a particular mobile.

Range: 0 through 0xFFFFFFFF

*RST Value: 0

RC1: 1.2, 2.4, 4.8, or 9.6 kbps Default: 9.6 kbps

RC2: 1.8, 3.6, 7.2, or 14.4 kbps Default: 14.4 kbps

RC3: 1.5, 2.7, 4.8, or 9.6 kbps Default: 9.6 kbps

RC4: 1.5, 2.7, 4.8, or 9.6 kbps Default: 9.6 kbps

RC5: 1.8, 3.6, 7.2, or 14.4 kbps Default: 14.4 kbps
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F-FCH Long Code Mask Header

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask:
HEADer <0 - 0x3FF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask:HEADer?

Execute this command to set the header for the long code mask. This is used to identify a 
particular mobile.

Range: 0 through 0x3FF

*RST Value: 318 hexadecimal

F-FCH Long Code Mask Query

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask?

Execute this command to output the contents of the long code mask field for the forward 
fundamental channel.

F-FCH Power

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:POWer?

Execute this command to set the power for the forward fundamental channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

F-FCH Power Control (Up/Down)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:PRAMp <1 - 80>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:PRAMp?

Execute this command to display the current number of power frame indicators. The signal 
generator uses the power frame indicators to command the mobile to increase or decrease 
power. For example, if 4 is the selected value, it will cause the mobile to respond with 4 
sequential power increases, then 4 power decreases. This pattern will continue indefinitely.

Range: 1 through 80

*RST Value: 1

F-FCH Power Puncturing State

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:PPUNcture ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:PPUNcture?

Execute this command to set the power puncturing operating state for the forward 
fundamental channel.

Choices: ON (1) or OFF (0)

*RST Value: ON
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F-FCH Quasi-orthogonal Function

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:QOF <0 - 3>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:QOF?

Execute this command to set the quasi-orthogonal function channel value.

Range: 0 through 3

*RST Value: 0

F-FCH Radio Configuration

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:RCONfig <1 - 5>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:RCONfig?

Execute this command to set the radio configuration value for the forward fundamental 
channel.

Range: 1 through 5

*RST Value: 1

F-FCH State

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH[:STATe]?

Execute this command to set the operating state for the forward fundamental channel.

Choices: ON (1) or OFF (0)

*RST Value: OFF

F-FCH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:WALSh?

Execute this command to set the Walsh code for the forward fundamental channel.

Range: 0 through 63

*RST Value: 10
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Forward Paging Channel Setup

F-PCH Data

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:DATA DEFault|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:DATA?

Execute this command to configure the data field for the forward paging channel. A 
user-defined file can have a maximum length of 512 bytes. See “Understanding the 
Forward Paging Channel” on page 4-17.

*RST Value: Default

F-PCH Data Rate

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:RATE 4.8kbps|9.6kbps
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:RATE?

Execute this command to set the data rate for the forward paging channel.

*RST Value: 9.6 kbps

F-PCH Long Code Mask Field 1

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F1 <0 - 0x1FFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F1?

Execute this command to set the value for field 1 for the forward paging channel long code 
mask.

Range: 0 through 0x1FFF

*RST Value: 18CD hexadecimal

F-PCH Long Code Mask Field 2

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F2 <0 - 0x1F>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F2?

Execute this command to set the value for field 2 for the forward paging channel long code 
mask.

Range: 0 through 0x1F

*RST Value: 0

F-PCH Long Code Mask Field 3

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F3 <0 - 0xFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F3?

Execute this command to set the value for field 3 for the forward paging channel long code 
mask.

Range: 0 through 0xFFFF
5-10 Real-Time cdma2000 Personality User’s and Programming Guide



ESG Family Signal Generators Remote Programming and Examples
Option 201 cdma2000 Subsystem SCPI Command Reference
*RST Value: 0

F-PCH Long Code Mask Query

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask?

Execute this command to output the contents of the long code mask field for the forward 
paging channel.

F-PCH Message 

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:MESSage <bit_count>, 
<datablock>

Execute this command to send a bit count and a data block to queue up messaging to the 
paging channel. This command can be used to generate a one-time page message 
(asynchronous paging message). After the message is played, the signal generator reverts 
to the original paging file messages. See Chapter 3 “Remote Data Transfer,” in the 
programming guide for details on formatting the datablock.

F-PCH Power

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:POWer?

Execute this command to set the power for the forward paging channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

F-PCH State

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH[:STATe]?

Execute this command to set the operating state for the forward paging channel.

Choices: ON (1) or OFF (0)

*RST Value: OFF

F-PCH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:WALSh?

Execute this command to set the Walsh code for the forward paging channel.

Range: 0 through 63

*RST Value: 1
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Forward Pilot Channel Setup

F-PICH PN Offset

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:PNOFfset <0 - 511>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:PNOFfset?

Execute this command to set the PN offset for the forward pilot channel.

Range: 0 through 511

F-PICH Power

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:POWer?

Execute this command to set the power for the forward pilot channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

F-PICH State

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh[:STATe]?

Execute this command to set the operating state for the forward pilot channel.

*RST Value: OFF

Forward Supplemental Traffic Channel Setup

F-SCH Data

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA PN9|PN15|
FIX4|"<file name>"|EXT
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA?

Execute this command to configure the data field for the forward supplemental traffic 
channel. The choices are the following:

PN9  Pseudorandom bit pattern

PN15  Pseudorandom bit pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file in the catalog of binary files

EXT  External input data pattern

*RST Value: PN9
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F-SCH Data Rate

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:
RATE <RC dependent: 19.2, 28.8, 38.4, 57.6, 76.8, 115.2, 153.6, 230.4, or 
307.2kbps>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:RATE?

Execute this command to set the data rate for the forward supplemental traffic channel. 
The choices are the following:

*RST Value: 19.2 kbps (RC3)

F-SCH FIX4

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA:
FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA:FIX4?

Execute this command to select a fixed 4-bit data pattern that repeats as necessary to fill 
the selected data area.

Range: 0 through 15

*RST Value: 0000

F-SCH Frame Offset

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:FOFFset?

Execute this command to set the frame offset value.

Range: 0 through 15

Default Value: 0

F-SCH Long Code Mask ESN

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask:
ESN <0 - 0xFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask:ESN?

Execute this command to define the permuted electronic serial number (ESN) for the long 
code mask. This is used to identify a particular mobile.

Range: 0 through 0xFFFFFFFF

*RST Value: 0

RC3: 19.2, 38.4, 76.8, or 153.6 kbps Default: 19.2 kbps

RC4: 19.2, 38.4, 76.8, 153.6, or 307.2 kbps Default: 19.2 kbps

RC5: 28.8, 57.6, 115.2, or 230.4 kbps Default: 28.8 kbps
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F-SCH Long Code Mask Header

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask:
HEADer <0 - 0x3FF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask:HEADer?

Execute this command to set the header for the long code mask, which is used to identify a 
particular mobile.

Range: 0 through 0x3FF 

*RST Value: 318 hexadecimal

F-SCH Long Code Mask Query

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask?

Execute this query to output the contents of the long code mask field for the forward 
supplemental traffic channel.

F-SCH Power

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:POWer?

Execute this command to set the power for the forward supplemental traffic channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

F-SCH Quasi-orthogonal Function

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:QOF <0 - 3>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:QOF?

Execute this command to set the quasi-orthogonal function value for the traffic channel.

Range: 0 through 3

*RST Value: 0

F-SCH Radio Configuration

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:RCONfig <3 - 5>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:RCONfig?

Execute this command to set the radio configuration value for the forward supplemental 
traffic channel.

Range: 3 through 5

*RST Value: 3
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F-SCH State

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2[:STATe]?

Execute this command to set the operating state for the forward supplemental traffic 
channel.

Choices: ON (1) or OFF (0)

*RST Value: OFF

F-SCH Turbo Coding State

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:TCODe ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:TCODe?

Execute this command to set the turbo coding operating state for the forward 
supplemental traffic channel.

Choices: ON (1) or OFF (0).

*RST Value: OFF

F-SCH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:WALSh?

Execute this command to set the Walsh code for the forward supplemental traffic channel.

Range: 0 through 63

*RST Value: 1

Forward Synchronization Channel Setup

F-SYNCH CDMA Frequency

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:CFRequency <0 - 2047>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:CFRequency?

Execute this command to set the CDMA channel frequency for the forward 
synchronization channel.

Range: 0 through 2047

*RST Value: 50

F-SYNCH Daylight Savings Time Offset

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:DAYLt <0 - 1>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:DAYLt?

Execute this command to set the daylight savings time offset for the forward 
synchronization channel, where 0 = off and 1 = on.

*RST Value: 0
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F-SYNCH Extended Frequency

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:
ECFRequency <0 - 2047>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:ECFRequency?

Execute this command to set the extended CDMA frequency.

Range: 0 through 2047

*RST Value: 0

F-SYNCH Long Code State

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:
LCSTate <0 - 0x3FFFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LCSTate?

Execute this command to set the long code seed used to generate the long code for the 
forward synchronization channel.

Range: 0 through 0x3FFFFFFFFFF

*RST Value: 0

F-SYNCH Leap Seconds

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LPSec <0 - 255>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LPSec?

Execute this command to set the leap seconds value for the forward synchronization 
channel.

Range: 0 through 255

*RST Value: 0

F-SYNCH Local Time Offset

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LTMoff <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LTMoff?

Execute this command to set the current local time offset for the forward synchronization 
channel, where 1= 30 minutes, 2= 60 minutes, 3= 90 minutes, and so on.

Range: 0 through 63

*RST Value: 0

F-SYNCH Minimum Protocol Revision Level

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:MPREv <0 - 255>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:MPREv?

Execute this command to set the minimum protocol revision level for the forward 
synchronization channel.

Range: 0 through 255
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*RST Value: 1

F-SYNCH Message Type

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:MSGType <0 - 255>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:MSGType?

Execute this command to set the message type value for the forward synchronization 
channel.

Range: 0 through 255

*RST Value: 1

F-SYNCH Network Identification

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:NID <0 - 65535>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:NID?

Execute this command to set the network identification value for the forward 
synchronization channel.

Range: 0 through 65535

*RST Value: 1

F-SYNCH Power

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:POWer?

Execute this command to set the power level for the forward synchronization channel.

Range: 0 dB through –40 dB

*RST Value: 0 dB

F-SYNCH Paging Channel Data Rate

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:PRATe <0 - 3>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:PRATe?

Execute this command to set the BTS paging rate.

Range: 0 through 3

*RST Value: 0

F-SYNCH Protocol Revision Level

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:PREV <0 - 255>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:PREV?

Execute this command to set the protocol revision level for the forward synchronization 
channel.

Range: 0 through 255

*RST Value: 1
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F-SYNCH Reserved Field

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:RESErved?

Execute this command to query the reserved field value. Currently, base stations and 
mobiles ignore reserved bits, so the reserved field should be set to “0” with the query 
returning the same value (see “RESERVED” on page 3-75 for more information).

*RST Value: 00

F-SYNCH State

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc[:STATe]?

Execute this command to set the operating state for the forward synchronization channel.

Choices: ON (1) or OFF (0).

*RST Value: OFF

F-SYNCH System Identification

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:SID <0 - 32767>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:SID?

Execute this command to set the system identification for the forward synchronization 
channel.

Range: 0 through 32767

*RST Value: 7

F-SYNCH System Time

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:
SYSTime <0 - 0xFFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:SYSTime?

Execute this command to set the system time value for the forward synchronization 
channel.

Range: 0 through 0xFFFFFFFFF

*RST Value: 0

F-SYNCH Type

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:
STYPe IS95|JSTD8|IS2000
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:STYPe?

Execute this command to select the forward synchronization channel type.

Choices: IS95, JSTD8, or IS2000.

*RST Value: JSTD8
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F-SYNCH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:WALSh?

Execute this command to set the Walsh code for the forward synchronization channel.

Range: 0 through 63

*RST Value: 32

IQ

IQ Map Rotation

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQRotation STANdard|ROTated
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQRotation?

Execute this command set the IQ map rotation to either standard or rotated (45 degrees) 
mode. Rotated mode is usually used in a multi-ESG setup where more than two rotated 
channels are desired. See “IQ Map Rotation Std. Rotated” on page 3-50.

*RST Value: Standard

IQ Percent Power Other

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:PPOTher <0 - 4>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:PPOTher?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:PPOTher <0 - 4>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:PPOTher?

Execute this command to set the percent power of the paired ESG after setting the powers 
of both ESGs. The value to enter is obtained by querying the other ESG (see “IQ Percent 
Power Query”). Once this is done, the Scale to 0 function will take into account the IQ 
power of both ESGs. 

NOTE For the single-ESG setup, leave this set to 0.0 percent.

*RST Value: 0.000000
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IQ Percent Power Query

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:PPOWer?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:PPOWer?

Execute this query on each ESG in a two-ESG configuration to output the value of the 
current IQ percent power. This value can then be entered into the paired ESG by using the 
appropriate SCPI command in the “IQ Percent Power Other” section.

IQ Voltage Scale

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:SCALe <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:SCALe?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:SCALe <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:SCALe?

Execute this command to adjust the total IQ output power. This value is filled in 
automatically after setting the IQ Voltage Other ESG value of both ESGs. Because 
changing this value affects total power, you will also see individual channel power 
adjustments. 

Range: 0 dB through –40 dB

*RST Value: 0 dB

IQ Total Voltage Other ESG

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:TVOTher <0 - 4V>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:TVOTher?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:TVOTher <0 - 4V>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:TVOTher?

Execute this command to set the total voltage value of the paired ESG after setting the 
powers of both ESGs. The value to enter is obtained by querying the other ESG (see “IQ 
Total Voltage Query”). After setting this value, the IQ voltage scale will be automatically 
generated.

NOTE For the single-ESG setup, leave this set to 0.0 V.
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IQ Total Voltage Query

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][FORWard]:IQ:TVOLtage?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:TVOLtage?

Execute this query on each ESG in a two-ESG configuration to output the value of the 
current total voltage. This value can then be entered into the paired ESG by using the 
appropriate SCPI command in the “IQ Total Voltage Other ESG” section.

OCNS Channel Setup

OCNS Power

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:POWer?

Execute this command to set the power for the orthogonal channel noise simulator.

Range: 0 dB through –40dB

*RST Value: 0.00 dB

OCNS State

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS[:STATe]?

Execute this command to set the operating state for the orthogonal channel noise 
simulator.

Choices: ON (1) or OFF (0)

*RST Value: OFF

OCNS Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:WALSh?

Execute this command to set the Walsh code for the orthogonal channel noise simulator.

Range: 0 through 63

*RST Value: 61

Phase Polarity

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:POLarity[:ALL] NORMal|INVerted
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:POLarity[:ALL]?
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Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:POLarity[:ALL] NORMal|INVerted
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:POLarity[:ALL]?

Execute this command to set the phase polarity to either normal or inverted. Inverted 
mode inverts the internal Q signal, reversing the direction of phase rotation.

*RST Value: Normal

Quick Paging Channel Setup

QPCH Configuration Change

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:CCI <0 - 3>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:CCI?

Execute this command to select the configuration change indicator for the quick paging 
channel.

Range: 0 through 3

*RST Value: 3

QPCH Data Rate

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:
RATE 2.4kbps|4.8kbps>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:RATE?

Execute this command to set the data rate for the quick paging channel.

Choices: 2.4 kbps or 4.8 kbps

*RST Value: 4.8 kbps

QPCH Paging Indicator

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:PI <0 - 383>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:PI?

Execute this command to select the paging slots for the quick paging channel.

Range: 0 through 383

*RST Value: 0

QPCH Power 

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:POWer?

Execute this command to set the power for the quick paging channel.

Range: 0 dB through –40dB

*RST Value: 0.00 dB
5-22 Real-Time cdma2000 Personality User’s and Programming Guide



ESG Family Signal Generators Remote Programming and Examples
Option 201 cdma2000 Subsystem SCPI Command Reference
QPCH State

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH[:STATe]?

Execute this command to set the operating state for the quick paging channel.

Choices: ON (1) or OFF (0)

*RST Value: OFF

QPCH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:WALSh <0 - 127>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:WALSh?

Execute this command to set the Walsh code for the quick paging channel.

Range: 0 through 127

*RST Value: 80

Reverse Access Channel Setup

R-ACH Data

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA?

Execute this command to configure the data field for the reverse access channel. The 
choices are the following:

PN9  Pseudorandom bit pattern

PN15  Pseudorandom bit pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file in the catalog of binary files

*RST Value: PN9

R-ACH Data Rate

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:RATE?

Execute this command to query the data rate for the reverse access channel. 

*RST Value: 4.8 kbps
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R-ACH FIX4

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA:FIX4?

Execute this command to select a fixed 4-bit data pattern to be repeated as necessary to fill 
the selected data area.

Range: 0 through 15

*RST Value: 0000

R-ACH Frame Length

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:FLENgth?

Execute this command to query the frame length for the reverse access channel.

*RST Value: 20 ms

R-ACH Frame Offset

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:FOFFset?

Execute this command to set the frame offset value for the reverse access channel.

Range: 0 through 15

*RST Value: 0

R-ACH Power

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:POWer?

Execute this command to set the power for the reverse access channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

R-ACH State

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH[:STATe]?

Execute this command to set the operating state for the reverse access channel.

Choices: ON (1) or OFF (0)

*RST Value: OFF
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Reverse cdma2000 Setup

Data Clock Out for RC1 and RC2

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut CCLK|CLK20ms| 
CLK80ms|CLK4khz|CLK307khz
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut?

Execute this command to set the output of the DATA CLK OUT rear panel BNC/SMB 
connector.

*RST Value: Chip Clock

Data Clock Out for RC3 and RC4

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut CCLK|CLK5ms|
CLK10ms|CLK20ms|CLK40ms|CLK80ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut?

Execute this command to set the output of the DATA CLK OUT rear panel BNC/SMB 
connector.

*RST Value: Chip Clock

Data Out for RC1 and RC2

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:
DOUT LCODe|IOUT|QOUT
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DOUT?

Execute this command to set the output of the DATA OUT rear panel BNC/SMB connector.

*RST Value: Long code

Data Out for RC3 and RC4

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT LCODe|PILot|
RSCHcoded|RDCChcoded|RFCHcoded|RCCChcoded|REAChcoded|ZI|ZQ
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

Execute this command to set the output of the DATA OUT rear panel BNC/SMB connector.

*RST Value: Long code

Event 1 for RC1 and RC2

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:
EVENt DESecond|PNSync
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:EVENt?

Execute this command to set the output of the EVENT 1 rear panel BNC/SMB connector.

*RST Value: Delayed Even Second
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Event 1 for RC3 and RC4

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:EVENt DESecond|PNSync
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:EVENt?

Execute this command to set the output of the EVENT 1 rear panel BNC/SMB connector.

*RST Value: Delay Even Second

Long Code Mask

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCMask <0 - 0x3FFFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCMask?

Execute this command to set a unique serial number code to identify a mobile station.

Range: 0 through 0x3FFFFFFFFFF

NOTE The storage register for the long code mask allows a 42-bit binary number to 
be entered. However, it may be possible to enter a value larger than 42 bits, 
and in this instance, the register value would be unknown. 

*RST Value: 0

Long Code Generation Mode

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCGMode ARB|RT
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCGMode?

This command enables you to select the long code generation mode.

*RST Value: ARB

Long Code State

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCSTate <0 - 0x3FFFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCSTate?

Execute this command to set a unique code to address a mobile station.

NOTE The storage register for the long code state allows a 42-bit binary number to 
be entered. However, it may be possible to enter a value larger than 42 bits, 
and in this instance, the register value would be unknown. 

Range: 0 through 0x3FFFFFFFFFF 

*RST Value: 0

Radio Configuration

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCONfig <1 - 5>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCONfig?

Execute this command to select the radio configuration value for the reverse channels.
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Range: 1 through 5

*RST Value: 3

Symbol Synchronization Out for RC1 and RC2

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:SSOut EVENsecond|
LCSync
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:SSOut?

Execute this command to set the output of the SYMBOL SYNC OUT rear panel BNC/SMB 
connector.

*RST Value: Even Second

Symbol Synchronization Out for RC3 and RC4

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:SSOut EVENsecond|
LCSync
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:SSOut?

Execute this command to set the output of the SYMBOL SYNC OUT rear panel BNC/SMB 
connector.

*RST Value: Even Second

Trigger Advance

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TADVance <0 - 2457599>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TADVance?

Execute this command to select a number of chips to advance the trigger time slot. 

Range: 0 through 2457599

*RST Value: 18

Trigger Edge

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TEDGe RISing|FALLing
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TEDGe?

Execute this command to select a falling or rising trigger edge state.

*RST Value: Falling
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Reverse Common Control Channel Setup

R-CCCH Data

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA?

Execute this command to configure the data field for the reverse common control channel. 
The choices are the following:

PN9  Pseudorandom bit pattern

PN15  Pseudorandom bit pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file in the catalog of binary files

*RST Value: PN9

R-CCCH Data Rate

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:
RATE 9.6kbps|19.2kbps|38.4kbps
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:RATE?

Execute this command to adjust the data rate for the reverse common control channel. The 
choices are the following:

*RST Value: 38.4 kbps

R-CCCH FIX4

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA:FIX4?

Execute this command to select a fixed 4-bit data pattern to be repeated as necessary to fill 
the selected data area.

Range: 0 through 15

*RST Value: 0000

R-CCCH Frame Length

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:FLENgth 5ms|10ms|20ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:FLENgth?

Execute this command to set the frame length value for the reverse common control 
channel.

*RST Value: 20

RC3 or RC4: 9.6, 19.2, or 38.4 kbps
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R-CCCH Frame Offset

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:FOFFset?

Execute this command to set the frame offset value for the reverse common control 
channel.

Range: 0 through 15

*RST Value: 0

R-CCCH Power

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:POWer?

Execute this command to set the power for the reverse common control channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

R-CCCH State

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh[:STATe]?

Execute this command to set the operating state for the reverse common control channel. 

Choices: ON (1) or OFF (0)

*RST Value: OFF

R-CCCH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:WALSh <0 - 7>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:WALSh?

Execute this command to set the Walsh code for the reverse common control channel.

Range: 0 through 7

*RST Value: 2

Reverse Dedicated Control Channel Setup

R-DCCH Data

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA PN9|PN15|FIX4|
<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA?

Execute this command to configure the data field for the reverse dedicated control channel. 
The choices are the following:

PN9  Pseudorandom bit pattern

PN15  Pseudorandom bit pattern
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FIX4  4-bit repeating sequence data pattern

"<file name>"  A file in the catalog of binary files

*RST Value: PN9

R-DCCH Data Rate

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:RATE?

Execute this command to query the data rate for the reverse dedicated control channel. 

*RST Value: 9.6 kbps

R-DCCH FIX4

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA:FIX4?

Execute this command to select a fixed 4-bit data pattern to be repeated as necessary to fill 
the selected data area.

Range: 0 through 15

*RST Value: 0000

R-DCCH Frame Length

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:FLENgth 5ms|20ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:FLENgth?

Execute this command to set the frame length value for the reverse dedicated control 
channel.

Choices: 5 or 20 ms

*RST Value: 20 ms

R-DCCH Frame Offset

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:FOFFset?

Execute this command to set the frame offset value for the reverse dedicated control 
channel.

Range: 0 through 15

*RST Value: 0

R-DCCH Power

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:POWer?

Execute this command to set the power for the reverse dedicated control channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB
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R-DCCH State

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh[:STATe]?

Execute this command to set the operating state for the reverse dedicated control channel.

Choices: ON (1) or OFF (0)

*RST Value: OFF

R-DCCH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:WALSh <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:WALSh?

Execute this command to set the Walsh code for the reverse dedicated control channel.

Range: 0 through 15

*RST Value: 8

Reverse Enhanced Access Channel Setup

R-EACH Data

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA?

Execute this command to configure the data field for the reverse enhanced access channel. 
The choices are the following:

PN9  Pseudorandom bit pattern

PN15  Pseudorandom bit pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file in the catalog of binary files

*RST Value: PN9

R-EACH Data Rate

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:
RATE 9.6kbps|19.2kbps|38.4kbps
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:RATE?

Execute this command to adjust the data rate for the reverse enhanced access channel. 
The choices are the following:

*RST Value: 38.4 kbps (RC3)

RC3 or RC4: 9.6, 19.2, or 38.4 kbps
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R-EACH FIX4

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA:FIX4?

Execute this command to select a fixed 4-bit data pattern to be repeated as necessary to fill 
the selected data area.

Range: 0 through 15

*RST Value: 0000

R-EACH Frame Length

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:FLENgth 5ms|10ms|20ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:FLENgth?

Execute this command to set the frame length value for the reverse enhanced access 
channel.

*RST Value: 20 ms

R-EACH Frame Offset

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:FOFFset?

Execute this command to set the frame offset value for the reverse enhanced access 
channel.

Range: 0 through 15

*RST Value: 0

R-EACH Power

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:POWer?

Execute this command to set the power for the reverse enhanced access channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

R-EACH State

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh[:STATe]?

Execute this command to set the operating state for the reverse enhanced access channel.

*RST Value: OFF
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R-EACH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:WALSh <0 - 7>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:WALSh?

Execute this command to set the Walsh code for the reverse enhanced access channel.

Range: 0 through 7

*RST Value: 2

Reverse Fundamental Channel Setup

R-FCH Data

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA?

Execute this command to configure the data field for the reverse fundamental channel. 
The choices are the following:

PN9  Pseudorandom bit pattern

PN15  Pseudorandom bit pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file in the catalog of binary files

*RST Value: PN9

R-FCH Data Rate

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:
RATE <RC dependent: 1.2, 1.5, 1.8, 2.4, 2.7, 3.6, 4.8, 7.2, 9.6, or 
14.4kbps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:RATE?

Execute this command to adjust the data rate for the reverse fundamental channel. The 
choices are the following:

*RST Value: 9.6 kbps (RC3)

RC1: 1.2, 2.4, 4.8, or 9.6 kbps Default: 9.6 kbps

RC2: 1.8, 3.6, 7.2, or 14.4 kbps Default: 14.4 kbps

RC3: 1.5, 2.7, 4.8, or 9.6 kbps Default: 9.6 kbps

RC4: 1.8, 3.6, 7.2, or 14.4 kbps Default: 14.4 kbps
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R-FCH FIX4

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA:FIX4?

Execute this command to select a fixed 4-bit data pattern to be repeated as necessary to fill 
the selected data area.

Range: 0 through 15

*RST Value: 0000

R-FCH Frame Length

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:FLENgth 5ms|20ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:FLENgth?

Execute this command to set the frame length value for the reverse fundamental channel.

Choices: 5 or 20 ms

*RST Value: 20 ms

R-FCH Frame Offset

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:FOFFset?

Execute this command to set the frame offset value for the reverse fundamental channel.

Range: 0 through 15

*RST Value: 0

R-FCH Power

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:POWer?

Execute this command to set the power for the reverse fundamental channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

R-FCH State

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH[:STATe]?

Execute this command to set the operating state for the reverse fundamental channel.

Choices: ON (1) or OFF (0)

*RST Value: OFF
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R-FCH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:WALSh <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:WALSh?

Execute this command to set the Walsh code for the reverse fundamental channel.

Range: 0 through 15

*RST Value: 4

Reverse Pilot Channel Setup

R-PICH Gating

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:
GRATe FULL|HALF|QUARter|
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:GRATe?

This command enables you to configure the gating data field for the reverse pilot channel. 
The choices are the following:

FULL  Transmits all sixteen power control bits

HALF  Transmits eight power control bits

QUARter  Transmits four power control bits

*RST Value: FULL

R-PICH Power Control Bit

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:PCB <0 - 0xFFFF>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:PCB?

Execute this command to adjust the power control bit for the reverse pilot channel.

Range: 0 through 0xFFFF

*RST Value: 0000 kbps

R-PICH Power

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:POWer?

Execute this command to set the power for the reverse pilot channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB
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R-PICH State

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh[:STATe]?

Execute this command to set the operating state for the reverse pilot channel.

*RST Value: OFF

R-PICH Walsh Code

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:WALSh?

Execute this command to query the Walsh code for the reverse pilot channel.

Reverse Supplemental Channel Setup (RC1 and RC2)

R-SCH Data (RC1 and RC2)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA?

Execute this command to configure the data field for the reverse supplemental channel. 
The choices are the following:

PN9  Pseudorandom bit pattern

PN15  Pseudorandom bit pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file in the catalog of binary files

*RST Value: PN9

R-SCH Data Rate (RC1 and RC2)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:
RATE <RC dependent: 1.2, 1.8, 2.4, 3.6, 4.8, 7.2, 9.6, or 14.4kbps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:RATE?

Execute this command to set the data rate for the reverse supplemental channel. The 
choices are the following:

RC1: 1.2, 2.4, 4.8, or 9.6 kbps Default: 9.6 kbps

RC2: 1.8, 3.6, 7.2, or 14.4 kbps Default: 14.4 kbps
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R-SCH FIX4 (RC1 and RC2)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA:FIX4?

Execute this command to set a fixed 4-bit data pattern that repeats as necessary to fill the 
selected data area.

Range: 0 through 15

*RST Value: 00

R-SCH Frame Length (RC1 and RC2)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:FLENgth 20ms|60ms|80ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:FLENgth?

Execute this command to set the frame length value for the reverse supplemental channel.

*RST: 20 ms

R-SCH Frame Offset (RC1 and RC2)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:FOFFset?

Execute this command to set the frame offset value for the reverse supplemental channel.

Range: 0 through 15

*RST Value: 0

R-SCH Power (RC1 and RC2)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:
POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:POWer?

Execute this command to set the power for the reverse supplemental channel.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

R-SCH State (RC1 and RC2)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH[:STATe]?

Execute this command to set the operating state for the reverse supplemental channel.

*RST Value: OFF
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R-SCH Walsh Code (RC1 and RC2)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:WALSh <0 - 7>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:WALSh?

Execute this command to set the Walsh code for the reverse supplemental channel.

Range: 0 through 7

*RST Value: 1

Reverse Supplemental Channel Setup (RC3 and RC4)

The ESG, for RC3 and RC4, uses R-SCH0 and R-SCH1 to differentiate between the two 
supplemental channels. However, the SCPI command designations for the same two 
supplemental channels use RSCH1 and RSCH2 respectively. Table 5-1. shows the 
relationship and channel position for the SCPI R-SCH designations.

R-SCH Data (RC3 and RC4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA?

Execute this command to configure the data field. The choices are the following:

PN9  Pseudorandom bit pattern

PN15  Pseudorandom bit pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file in the catalog of binary files

*RST Value: PN9

Table 5-1. RC3 and RC4 Reverse Supplemental Channel Designation

ESG 1 ESG 2

Ch 1 Ch 2 Ch 3 Ch 4 Ch 1 Ch 2 Ch 3 Ch 4

R-SCH0 
(ESG)

R-SCH1 
(SCPI)

R-SCH1
(ESG)

R-SCH2 
(SCPI)
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R-SCH Data Rate (RC3 and RC4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:
RATE <RC and frame length dependent: 1.2, 1.35, 1.5, 1.8, 2.4, 2.7, 3.6, 
4.8, 7.2, 9.6, 14.4, 19.2, 28.8, 38.4, 57.6, 76.8, 115.2, 153.6, 230.4, or 
307.2kbps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:RATE?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:
RATE <RC and frame length dependent: 1.2, 1.35, 1.5, 1.8, 2.4, 2.7, 3.6, 
4.8, 7.2, 9.6, 14.4, 19.2, 28.8, 38.4, 57.6, 76.8, 115.2, 153.6, 230.4, or 
307.2kbps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:RATE?

Execute this command to set the data rate. The choices are the following:

*RST Value: 307.2 kbps (RC3)

R-SCH FIX4 (RC3 and RC4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA:FIX4?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA:FIX4?

Execute this command to set a fixed 4-bit data pattern that repeats as necessary to fill the 
selected data area.

Range: 0 through 15

*RST Value: 00

RC3 Frame Length Data Rate

20 ms: 1.5, 2.7, 4.8, 9.6, 19.2, 38.4, 76.8, 153.6, or 307.2 kbps

40 ms: 1.35, 2.4, 4.8, 9.6, 19.2, 38.4, 76.8, or 153.6 kbps

80 ms: 1.2, 2.4, 4.8, 9.6, 19.2, 38.4, or 76.8 kbps

Default: 307.2 kbps (20 ms frame length)

RC4 Frame Length Data Rate

20 ms: 1.8, 3.6, 7.2, 14.4, 28.8, 57.6, 115.2, or 230.4 kbps

40 ms: 1.8, 3.6, 7.2, 14.4, 28.8, 57.6, or 115.2 kbps

80 ms: 1.8, 3.6, 7.2, 14.4, 28.8, or 57.6 kbps

Default: 230.4 kbps (20 ms frame length)
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R-SCH Frame Length (RC3 and RC4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:FLENgth 20ms|40ms|80ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:FLENgth?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:FLENgth 20ms|40ms|80ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:FLENgth?

Execute this command to set the frame length value.

*RST Value: 20

R-SCH Frame Offset (RC3 and RC4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:FOFFset <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:FOFFset?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:FOFFset <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:FOFFset?

Execute this command to set the frame offset value.

Range: 0 through 63

*RST Value: 0

R-SCH Power (RC3 and RC4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:POWer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:POWer?

Execute this command to set the power level.

Range: 0 dB through –40 dB

*RST Value: 0.00 dB

R-SCH State (RC3 and RC4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1[:STATe]?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2[:STATe]?

Execute this command to set the operating state.

*RST Value: OFF
5-40 Real-Time cdma2000 Personality User’s and Programming Guide



ESG Family Signal Generators Remote Programming and Examples
Option 201 cdma2000 Subsystem SCPI Command Reference
R-SCH Turbo Coding (RC3 and RC4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:TCODe ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:TCODe?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:TCODe ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:TCODe?

Execute this command to enable turbo coding. Ensure that this function is being executed 
with the correct data rate.

*RST Value Off

R-SCH Walsh Code (RC3 and RC4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:WALSh <0 - 7>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:WALSh?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:WALSh <0 - 7>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:WALSh?

Execute this command to set the Walsh code.

Range: 0 through 7

*RST Value: 1

Spreading Rate

Forward:

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:SPReading:RATE?

Reverse:

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:SPReading:RATE?

Execute this command to return the value of the current spreading rate.
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Programming Examples
This section provides the following programming examples:

• A single-ESG setup on page 5-43.

• A two-ESG setup on page 5-45.
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Single-ESG Setup

Use this example to configure the single-ESG setup.

10 !**************************************************************
20 !
30 ! PROGRAM DESCRIPTION:  In this example, the instrument is
40 ! configured for a one-ESG setup.
50 ! 
60 ! Text within the ‘[]’ is optional. Lower case is also optional.
70 ! 
80 ! If this example is used with HP Basic, every line must start with
90 ! ‘OUTPUT < GPIB Address >,’.
100 ! 
110 !
120 !********************************************************* 

130 *RST 
140 [:SOURce]:FREQuency[:CW] 900 MHZ
150 [:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] -40 DBM
160 :OUTPut[[:STATe] ON
170 ! *********************************************
180 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:POLarity[:ALL] NORMal
190 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQRotation STANdard
200 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BBCLock INT
210 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer IS95 EQ
220 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:ESDelay 17.5
230 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LCSTate 1
240 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:PNOFfset 0
250 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:SCALe 0 DB
260 ! *********************************************
270 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh[:STATe] ON
280 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:POWer -7.00 DB
290 ! *********************************************
300 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc[:STATe] ON
310 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:POWer -13.00 DB
320 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:WALSh 32
330 ! *********************************************
340 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH[:STATe] ON
350 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:POWer -10.00 DB
360 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:WALSh 8
370 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:RCONfig 1
380 ! *********************************************
390 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH[:STATe] ON
400 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:POWer -10.00 DB
410 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:WALSh 1 
420 ! *********************************************
430 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:PADJust SCALe
440 [:SOURce]:RADio:CDMA2000[:BBG][:STATe] ON
450 [:SOURce]:DM:SOURce INTernal
460 END
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10 to 120: Program description.

130: Reset the signal generator.

140: Set the center frequency of the carrier.

150: Set the amplitude to –40 dBm.

160: Turn on the RF output operating state.

170:

180: Set the phase polarity to normal.

190: Set the IQ rotation to standard. 

200: Set the data clock to internal.

210: Set the filter type to IS95 EQ.

220: Set the seven second delay to 17.5 cps to align RF with trigger.

230: Set the forward sync channel long code state to 1.

240: Set the forward pilot channel PN offset to 0.

250: Set the total power output at IQ to 0.

260:

270: Turn on the forward pilot channel operating state.

280: Set the forward pilot channel power to –7.00 dB.

290

300: Turn on the forward sync channel operating state.

310: Set the forward sync channel power to –13.00 dB.

320: Set the forward sync channel Walsh code to 32.

330:

340: Turn on the forward fundamental channel operating state.

350: Set the forward fundamental channel power to –10.00 dB.

360: Set the forward fundamental channel Walsh code to 8.

370: Set the forward fundamental channel radio configuration to 1.

380:

390: Turn on the forward paging channel operating state.

400: Set the forward paging channel power to –10.00 dB.

410: Set the forward paging channel Walsh code to 1.

420:

430: Set the code domain power to scale current channel power to maintain 0 dB total power.

440 Turn on the cdma2000 operating state.

450 Set the I/Q to internal.

460 End of program.
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Two-ESG Setup

Use this example to configure the two-ESG setup.

CAUTION When programming two ESGs, each ESG must have a unique GPIB address.

10 !*******************************************************
20 !
30 ! PROGRAM DESCRIPTION:  In this example, the instrument, ESG 1, is
40 ! configured for the two-ESG setup.
50 ! 
60 ! Text within the ‘[]’ is optional. Lower case is also optional.
70 ! 
80 ! If this example is used with HP Basic, every line must start with
90 ! ‘OUTPUT < GPIB Address >’.
100 ! 
110 !
120 !********************************************************* 
130 !ESG 1
140 !*********************************************************
150 *RST 
160 [:SOURce]:FREQuency[:CW] 900 MHZ
170 [:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] -40 DBM
180 [:SOURce]:POWer:ALC[:STATe] ON
190 :OUTPut [:STATe] ON
200 ! *********************************************
210 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:POLarity[:ALL] NORMal
220 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQRotation STANdard
230 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BBCLock EXT
240 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer IS95_EQ
250 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:ESDelay 17.5
260 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LCSTate 1
270 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:PNOFfset 0
280 ! *********************************************
290 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh[:STATe] ON
300 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:POWer -7.00 DB
310 ! *********************************************
320 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc[:STATe] ON
330 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:POWer -13.00 DB
340 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:WALSh 32
350 ! *********************************************
360 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS[:STATe] ON
370 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:POWer -3.46 DB
380 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:WALSh 57
390 ! *********************************************
400 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH[:STATe] ON
410 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:POWer -10.00 DB
420 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:WALSh 1 
430 ! *********************************************
440 [:SOURce]:RADio:CDMA2000[:BBG][:STATe] ON
450 [:SOURce]:DM:SOURce EXTernal
460 END
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Program Comments

10 to 140: Program description

150: Reset the signal generator.

160: Set the center frequency of the carrier.

170: Set the amplitude to –40 dBm

180 Turn on the automatic level control operating state.

190: Turn on the RF output operating state.

200:

210: Set the phase polarity to normal.

220: Set the IQ rotation to standard. 

230: Set the data clock to external.

240: Set the filter type to IS95 EQ.

250: Set the seven second delay to 17.5 cps to align RF with trigger.

260: Set the forward sync channel long code state to 1.

270: Set the forward pilot channel PN offset to 0.

280:

290: Turn on the forward pilot channel operating state.

300: Set the forward pilot channel power to –7.00 dB.

310:

320: Turn on the forward sync channel operating state.

330: Set the forward sync channel power to –13.00 dB.

340: Set the forward sync channel Walsh code to 32.

350:

360: Turn on the forward orthogonal l channel noise simulator operating state.

370: Set the forward orthogonal channel noise simulator power to –3.46 dB.

380: Set the forward orthogonal channel noise simulator channel Walsh code to 57.

390:

400: Turn on the forward paging channel operating state.

410: Set the forward paging channel power to –10.00 dB.

420: Set the forward paging channel Walsh code to 1.

430:

440 Turn on the cdma2000 operating state.

450 Set the I/Q source to external.

460 End of program
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CAUTION When programming two ESGs, each ESG must have a unique GPIB address

10 !*******************************************************
20 !
30 ! PROGRAM DESCRIPTION:  In this example, the instrument, ESG 2,is
40 ! configured for the two-ESG setup.
50 ! 
60 ! Text within the ‘[]’ is optional. Lower case is also optional.
70 ! 
80 ! If this example is used with HP Basic, every line must start with
90 ! ‘OUTPUT < GPIB Address >,’.
100 ! 
110 !
120 !********************************************************* 
130 !ESG 2
140 !*********************************************************
150 *RST 
160 [:SOURce]:FREQuency[:CW] 1.2288 MHZ
170 [:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] 15 DBM
180 [:SOURce]:POWer:ALC[:STATe] OFF
190 :OUTPut:MODulation[:STATe] OFF
200 :OUTPut[:STATe] ON
210 ! *********************************************
220 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:POLarity[:ALL] INVerted
230 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQRotation STANdard
240 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BBCLock EXT
250 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer IS95_EQ
260 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:ESDelay 17.5
270 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LCSTate 1
280 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:PNOFfset 0
290 ! *********************************************
300 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH[:STATe] ON
310 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:POWer -10.00 DB
320 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:WALSh 10
330 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:RCONfig 4
340 ! *********************************************
350 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1][:STATe] ON
360 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]:SETup:POWer -10.00 DB
370 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]:SETup:WALSh 4
380 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]:SETup:RCONfig 4
390 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]:SETup:RATE 153.6kbps
400 ! *********************************************
410 [:SOURce]:RADio:CDMA2000[:BBG][:STATe] ON
420 END
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Program Comments

10 to 140: Program description

150: Reset the signal generator.

160: Set the frequency to 1.2288 MHz for the chip clock.

170: Set the amplitude to 15 dBm to provide near-TTL voltages to drive the data clock.

180: Turn off automatic level control.

190: Turn off the RF output modulation operating state.

200: Turn on the RF output operating state.

210:

220: Set the phase polarity to inverted.

230: Set the IQ rotation to standard. 

240: Set the data clock to external.

250: Set the filter type to IS95 EQ.

260: Set the s even second delay to 17.5 cps to align RF with trigger.

270: Set the forward sync channel long code state to 1.

280: Set the forward pilot channel PN offset to 0.

290:

300: Turn on the forward fundamental channel operating state.

310: Set the forward fundamental channel power to –10.00 dB.

320: Set the forward fundamental channel Walsh code to 10.

330: Set the forward fundamental channel radio configuration to 4.

340:

350: Turn on the forward supplemental channel operating state.

360: Set the forward supplemental channel power to –10.00 dB.

370: Set the forward supplemental channel Walsh code to 4.

380: Set the forward supplemental channel radio configuration to 4.

390: Set the forward supplemental channel data rate to 153.6 kbps.

400:

410: Turn on the cdma2000 operating state.

420: End of program
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Option 201 and Option H03 SCPI Language Comparison
Users with programs written for Option H03 signal generators will require changes to 
certain SCPI commands in order to utilize an Option 201 signal generator to provide the 
same solution as an Option H03 signal generator.

Option H03 offered only QPSK- (or OQPSK-) modulated data without IS-95 or IS-2000 
channelization. Because Option 201 provides IS-95 and IS-2000 channelization and 
improved performance, certain Option H03 commands no longer produce a result when 
applied to an Option 201 signal generator.

The following table provides a cross-reference between Option H03 SCPI commands and 
command queries and their equivalent Option 201 counterparts.

Table 5-2. Option 201 and Option H03 SCPI Command Cross-Reference

Option H03 SCPI Command Option 201 SCPI Command

[:SOURce]:RADio:CDMA[:BBG]:
BBCLock INT[1]|EXT[1]
[:SOURce]:RADio:CDMA[:BBG]:BBCLock?

[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard:BBCLock INT[1]|EXT[1]
[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:BBCLock?

[:SOURce]:RADio:CDMA2000[:BBG]:
REVerse:BBCLock INT[1]|EXT[1]
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:
BBCLock?

[:SOURce]:RADio:CDMA[:BBG]:
CRATe <value>
[:SOURce]:RADio:CDMA[:BBG]:CRATe?

[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:CRATe <50 cps - 1.3 Mcps>
[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:CRATe?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:
CRATe <50 cps - 1.3 Mcps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:
CRATe?

[:SOURce]:RADio:CDMA[:BBG]:
DATA PN9|PN15|FIX4|"<file name>"|
EXT|P4|P8|P16|P32|P64
[:SOURce]:RADio:CDMA[:BBG]:DATA?

No application. Data can be inserted into a 
Fundamental Traffic or Supplemental Traffic 
channel only. See “Forward Fundamental 
Channel Setup,” and “Forward Supplemental 
Traffic Channel Setup,” for similar applications.

[:SOURce]:RADio:CDMA[:BBG]:DATA:
FIX4 <0-15> 
[:SOURce]:RADio:CDMA[:BBG]:DATA:
FIX4?

[:SOURce]:RADio:CDMA[:BBG]:
EDCLock SYMBol|NORMal
[:SOURce]:RADio:CDMA[:BBG]:EDCLock?

No application. Option 201 does not support the 
use of an external data clock signal.
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[:SOURce]:RADio:CDMA[:BBG]:
EQUalizer ON|OFF|1|0
[:SOURce]:RADio:CDMA[:BBG]:
EQUalizer?

[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:FILTer IS95|IS95_MOD|
IS95_EQ|IS95_MOD_EQ
[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:
REVerse:FILTer IS95|IS95_EQ|
IS95_MOD|IS95_MOD_EQ
[:SOURce]:RADio:CDMA2000[:BBG]:
REVerse:FILTer?

[:SOURce]:RADio:CDMA[:BBG]:
FILTer STANdard|MODified
[:SOURce]:RADio:CDMA[:BBG]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:FILTer IS95|IS95_MOD
[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:
REVerse:FILTer IS95|IS95_MOD
[:SOURce]:RADio:CDMA2000[:BBG]:
REVerse:FILTer?

[:SOURce]:RADio:CDMA[:BBG]:
HICRest[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA[:BBG]:
HICRest[:STATe]?

No application. Spectral regrowth issues 
addressed by this command are addressed with 
filters in Option 201.

[:SOURce]:RADio:CDMA[:BBG]:IQ:
SCALe <value>
[:SOURce]:RADio:CDMA[:BBG]:IQ:
SCALe?

[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:IQ:SCALe <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:IQ:SCALe?

[:SOURce]:RADio:CDMA2000[:BBG]:
REVerse:IQ:SCALe <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:
REVerse:IQ:SCALe?

[:SOURce]:RADio:CDMA[:BBG]:
MODulation QPSK|OQPSK
[:SOURce]:RADio:CDMA[:BBG]:
MODulation?

No application. Option 201 uses QPSK 
modulation for forward link only. For reverse 
link, OQPSK and HPSK modulation are used.

Table 5-2. Option 201 and Option H03 SCPI Command Cross-Reference

Option H03 SCPI Command Option 201 SCPI Command
5-50 Real-Time cdma2000 Personality User’s and Programming Guide



ESG Family Signal Generators Remote Programming and Examples
Option 201 Option 201 and Option H03 SCPI Language Comparison
[:SOURce]:RADio:CDMA[:BBG]:POLarity
[:ALL] NORMal|INVerted
[:SOURce]:RADio:CDMA[:BBG]:POLarity
[:ALL]?

[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:POLarity[:ALL] NORMal|
INVerted
[:SOURce]:RADio:CDMA2000[:BBG]
[:FORWard]:POLarity[:ALL]?

[:SOURce]:RADio:CDMA2000[:BBG]:
REVerse:POLarity[:ALL]NORMal|
INVerted
[:SOURce]:RADio:CDMA2000[:BBG]:
REVerse:POLarity[:ALL]?

[:SOURce]:RADio:CDMA[:BBG]:
SPReading ON|OFF|1|0
[:SOURce]:RADio:CDMA[:BBG]:
SPReading?

No application. Spreading is always on.

[:SOURce]:RADio:
CDMA[:BBG][:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA[:BBG][:STATe]?

[:SOURce]:RADio:
CDMA2000[:BBG][:STATe] ON|OFF|1|0
[:SOURce]:RADio:
CDMA2000[:BBG][:STATe]?

Table 5-2. Option 201 and Option H03 SCPI Command Cross-Reference

Option H03 SCPI Command Option 201 SCPI Command
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Option 201
6 Programming Command 
Cross-Reference

This chapter lists the cdma2000 softkeys and data fields along with their corresponding 
SCPI commands. For a complete list of the signal generator hardkeys and softkeys and 
their corresponding SCPI commands, please refer to the programming guide.
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Table 6-1. Mode – cdma2000 Softkeys  

Key or
Data Field

SCPI Command

% Power This 
ESG

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:PPOWer?
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:PPOWer?

% Power Other 
ESG

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:PPOTher <0 - 4>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:PPOTher?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:PPOTher <0 - 4>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:PPOTher?

10ms Clock [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut CLK10ms

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut?

20ms Clock [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut CLK20ms

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut CLK20ms

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut?

307.2 Khz Clock [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut CLK307khz

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut?

40ms Clock [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut CLK40ms

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut?

4.8 Khz Clock [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut CLK4khz

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut?

5ms Clock [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut CLK5ms

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut?

80ms Clock [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut CLK80ms

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut CLK80ms

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut?

Adjust Code 
Domain Power

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:PADJust EQUal|SCALe
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:PADJust EQUal|SCALe

APCO 25 C4FM [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer AC4Fm
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer AC4Fm
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

BBG Data Clock
Ext Int

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BBCLock INT[1]|EXT[1]
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BBCLock?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BBCLock INT[1]|EXT[1]
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BBCLock?
6-2 Real-Time cdma2000 Personality User’s and Programming Guide



ESG Family Signal Generators Programming Command Cross-Reference
Option 201
CDMA2000
Off On

[:SOURce]:RADio:CDMA2000[:BBG][:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:STATe]?

CDMA Freq [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:
CFRequency <0 - 2047>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:CFRequency?

Channel State
Off On
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH[:STATe]?

Channel State
Off On
(F-PCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH[:STATe]?

Channel State
Off On
(F-PICH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh[:STATe]?

Channel State
Off On
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2[:STATe]?

Channel State
Off On
(F-SYNCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc[:STATe]?

Channel State
Off On
(OCNS)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS[:STATe]?

Channel State
Off On
(QPCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH[:STATe]?

Channel State
Off On
(R-ACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH[:STATe]?

Channel State
Off On
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh[:STATe]?

Channel State
Off On
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh[:STATe]?

Channel State
Off On
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh[:STATe]?

Channel State
Off On
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH[:STATe]?
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Channel State
Off On
(R-PICH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh[:STATe]?

Channel State
Off On
(R-SCH)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH[:STATe]?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1[:STATe] ON|{OFF}|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1[:STATe]?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2[:STATe] ON|{OFF}|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2[:STATe]?

Chip Clock [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut CCLK

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut CCLK

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut?

Chip Rate [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:CRATe <50 cps - 1.3 Mcps>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:CRATe?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:CRATe <50 cps - 1.3 Mcps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:CRATe?

Coded REACH [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT REAChcoded

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

Coded RCCCH [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT RCCChcoded

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

Coded RDCCH [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT RDCChcoded

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

Coded RFCH [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT RFCHcoded

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

Coded RSCH [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT RSCHcoded

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

Config Change [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:CCI <0 - 3>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:CCI?

Data
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA PN9|PN15|FIX4|
"<file name>"|EXT
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA?

Data
(F-PCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:DATA DEFault|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:DATA?

Data 
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA PN9|PN15|
FIX4|"<file name>"|EXT
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA?
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Data 
(R-ACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA?

Data 
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA?

Data 
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA?

Data 
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA?

Data 
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA?

Data 
(R-SCH)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA?

Data Clk Out [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut CCLK|CLK20ms|

CLK80ms|CLK4khz|CLK307khz

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DCOut?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut CCLK|CLK5ms|

CLK10ms|CLK20ms|CLK40ms|CLK80ms

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DCOut?

Data Out [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:DOUT PCRamp|D80Trigger

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:DOUT?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DOUT LCODe|IOUT|QOUT

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DOUT?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT LCODe|

PILot|RSCHcoded|RDCChcoded|RFCHcoded|RCCChcoded|REAChcoded|ZI|ZQ

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

Data Rate
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:
RATE <RC dependent:1.2, 1.5, 1.8, 2.4, 2.7, 3.6, 4.8, 7.2, 9.6, or 
14.4kbps>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:RATE?
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Data Rate
(F-PCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:RATE 4.8kbps|9.6kbps
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:RATE?

Data Rate
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:
RATE <RC dependent: 19.2, 28.8, 38.4, 57.6, 76.8, 115.2, 153.6, 230.4, or 
307.2kbps>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:RATE?

Data Rate
(QPCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:
RATE 2.4kbps|4.8kbps
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:RATE?

Data Rate
(R-ACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:RATE?

Data Rate
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:
RATE 9.6kbps|19.2kbps|38.4kbps
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:RATE?

Data Rate
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:RATE?

Data Rate
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:
RATE 9.6kbps|19.2kbps|38.4kbps
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:RATE?

Data Rate
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:
RATE <RC dependent: 1.2, 1.5, 1.8, 2.4, 2.7, 3.6, 4.8, 7.2, 9.6, or 
14.4kbps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:RATE?

Data Rate
(R-SCH)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:
RATE <RC dependent: 1.2, 1.8, 2.4, 3.6, 4.8, 7.2, 9.6, or 14.4kbps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:RATE?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:
RATE <RC and frame length dependent: 1.2, 1.35, 1.5, 1.8, 2.4, 2.7, 3.6, 
4.8, 7.2, 9.6, 14.4, 19.2, 28.8, 38.4, 57.6, 76.8, 115.2, 153.6, 230.4, or 
307.2kbps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:RATE?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:
RATE <RC and frame length dependent: 1.2, 1.35, 1.5, 1.8, 2.4, 2.7, 3.6, 
4.8, 7.2, 9.6, 14.4, 19.2, 28.8, 38.4, 57.6, 76.8, 115.2, 153.6, 230.4, or 
307.2kbps>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:RATE?

DAYLT [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:DAYLt <0- 1>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:DAYLt?

Default Message [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:DATA DEFault
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:DATA?

Delayed 20ms 
Trigger

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVENt D20Trigger

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVENt?
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Delayed 80ms 
Trigger

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:DOUT D80Trigger

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:DOUT?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVENt D80Trigger

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVENt?

Delayed Even 
Second

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVENt DESecond

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVENt?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:EVENt DESecond

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:EVENt?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:EVENt DESecond

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:EVENt?

Equal Powers [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:PADJust EQUal
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:PADJust EQUal

Even Sec 
Delay 

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:ESDelay <0.5 - 128.0>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:ESDelay?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:ESDelay <0.5 - 128.0>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:ESDelay?

Even Second [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:SSOut EVENsecond

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:SSOut?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:SSOut EVENsecond

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:SSOut?

Event 1 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVent DESecond|

D20Trigger|D80Trigger

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:EVent?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:EVENt DESecond|PNSync

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:EVENt?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:EVENt DESecond|PNSync

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:EVENt?

Ext
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA EXT
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA?

Ext
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA EXT
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA?

Ext Cdma Freq [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:
ECFRequency <0 - 2047>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:ECFRequency?

F-SYNCH Type [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:STYPe IS95|JSTD8|
IS2000
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:STYPe?

Table 6-1. Mode – cdma2000 Softkeys (Continued) 

Key or
Data Field

SCPI Command
Real-Time cdma2000 Personality User’s and Programming Guide 6-7



Programming Command Cross-Reference ESG Family Signal Generators
Option 201
Falling [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TEDGe FALLing
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TEDGe?

Filter
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer RNYQuist|NYQuist|
GAUSsian|RECTangle|IS95|IS95_EQ|IS95_MOD|IS95_MOD_EQ|AC4Fm|UGGaussian|
"<User FIR>"
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer RNYQuist|NYQuist|
GAUSsian|RECTangle|IS95|IS95_EQ|IS95_MOD|IS95_MOD_EQ|AC4Fm|UGGaussian|
"<User FIR>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

Filter Alpha [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:ALPHa <0 - 1.0>

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:ALPHa?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:ALPHa <0 - 1.0>

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:ALPHa?

Filter BbT [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:BBT <0 - 1.0>

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:BBT?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:BBT <0 - 1.0>

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:BBT?

FIX4
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA:FIX4?

FIX4
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA:
FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA:FIX4?

FIX4
(R-ACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA:FIX4 <0 - 15> 
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA:FIX4?

FIX4
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA:FIX4?

FIX4
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA:FIX4?
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FIX4
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA:FIX4?

FIX4
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA:FIX4?

FIX4
(R-SCH)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA FIX4
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA:FIX4?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA:FIX4?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA:FIX4?

Frame Length
R-ACH

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:FLENgth?

Frame Length
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:FLENgth 5ms|10ms|20ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:FLENgth?

Frame Length
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:FLENgth 5ms|20ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:FLENgth?

Frame Length
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:FLENgth 5ms|10ms|20ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:FLENgth?

Frame Length
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:FLENgth 5ms|20ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:FLENgth?

Frame Length
(R-SCH)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:FLENgth?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:FLENgth 20ms|40ms|80ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:FLENgth?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:FLENgth 20ms|40ms|80ms
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:FLENgth?

Frame Offset
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:FOFFset?

Frame Offset
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:FOFFset?
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Programming Command Cross-Reference ESG Family Signal Generators
Option 201
Frame Offset
(R-ACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:FOFFset?

Frame Offset
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:FOFFset?

Frame Offset
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:FOFFset?

Frame Offset
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:FOFFset?

Frame Offset
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:FOFFset?

Frame Offset
(R-SCH)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:FOFFset <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:FOFFset?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:FOFFset <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:FOFFset?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:FOFFset <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:FOFFset?

Full [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:GRATe FULL
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:GRATe?

Gating Rate [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:GRATe FULL|HALF|
QUARter
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:GRATe?

Gaussian [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer GAUSsian
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer GAUSsian
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

Half [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:GRATe HALF
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:GRATe?

I Out [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DOUT IOUT
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DOUT?

IQ Map Rotation
Std. Rotated

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQRotation STANdard|ROTated
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQRotation?

IQ Voltage 
Scale

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:SCALe <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:SCALe?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:SCALe <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:SCALe?

IS2000 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:STYPe IS2000
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:STYPe?

IS95 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:STYPe IS95
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:STYPe?
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ESG Family Signal Generators Programming Command Cross-Reference
Option 201
IS-95 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer IS95
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer IS95
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

IS-95 Mod [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer IS95_MOD
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer IS95_MOD
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

IS-95 MOD w/EQ [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer IS95_MOD_EQ
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer IS95_MOD_EQ
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

IS-95 w/EQ [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer IS95_EQ
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer IS95_EQ
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

JSTD8 [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:STYPe JSTD8
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:STYPe?

LC Generation

(Reverse Link)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCGMode ARB|RT
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCGMode?

LC Mask
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask:
ESN <0 - 0xFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask:ESN?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask:
HEADer <0 - 0x3FF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:LCMask:HEADer?

LC Mask
(F-PCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:
F1 <0 - 0x1FFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F1?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F2 <0 - 0x1F>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F2?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:
F3 <0 - 0xFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:LCMask:F3?
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Programming Command Cross-Reference ESG Family Signal Generators
Option 201
LC Mask
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask:
ESN <0 - 0xFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask:ESN?

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask:
HEADer <0 - 0x3FF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:LCMask:HEADer?

LC Mask
(Reverse Link)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCMask <0 - 0x3FFFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCMask?

LC State [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:
LCSTate <0 - 0x3FFFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LCSTate?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCSTate <0 - 0x3FFFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:LCSTate?

Link 
Forward Reverse

[:SOURce]:RADio:CDMA2000[:BBG]:LINK FORWard|REVerse
[:SOURce]:RADio:CDMA2000[:BBG]:LINK?

Long Code [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DOUT LCODe

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DOUT?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT LCODe

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

Long Code Sync [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:SSOut LCSync

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:SSOut?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:SSOut LCSync

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:SSOut?

LP_SEC [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LPSec <0 - 255>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LPSec?

LTM_OFF [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LTMoff <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:LTMoff?

MIN_P_REV [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:MPREv <0 - 255>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:MPREv?

Msg Type [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:MSGType <0 - 255>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:MSGType?

NID [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:NID <0 - 65535>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:NID?

Nyquist [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer NYQuist
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer NYQuist
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?
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ESG Family Signal Generators Programming Command Cross-Reference
Option 201
Optimize FIR For
EVM ACP

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:CHANnel EVM|ACP
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer:CHANnel?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:CHANnel EVM|ACP
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer:CHANnel?

P Puncturing [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:PPUNcture ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:PPUNcture?

P_REV [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:PREV <0 - 255>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:PREV?

Paging 
Indicator

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:PI <0 - 383>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:PI?

PC Ramp [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:DOUT PCRamp

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:BNCMux:DOUT?

PCB Data [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:PCB <0 - 0xFFFF>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:PCB?

PCntrl (Up/Dn) [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:PRAMp <1 - 80>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:PRAMp?

Phase Polarity
Normal Invert

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:POLarity[:ALL] NORMal|INVerted
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:POLarity[:ALL]?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:POLarity[:ALL] NORMal|INVerted
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:POLarity[:ALL]?

Pilot [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT PILot

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

PN15
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA?

PN15
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA?

PN15
(R-ACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA?

PN15
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA?

PN15
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA?

PN15
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA?

PN15
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA?
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Programming Command Cross-Reference ESG Family Signal Generators
Option 201
PN15
(R-SCH)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA PN15
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA?

PN9
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA?

PN9
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA?

PN9
(R-ACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA?

PN9
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA?

PN9
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA?

PN9
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA?

PN9
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA?

PN9
(R-SCH)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA PN9
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA?

PN Offset [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:PNOFfset <0 - 511>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:PNOFfset?

PN Sync [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:EVENt PNSync
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:EVENt?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:EVENt PNSync
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:EVENt?

Power
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:POWer?

Power
(F-PCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:POWer?

Power
(F-PICH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPICh:SETup:POWer?
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ESG Family Signal Generators Programming Command Cross-Reference
Option 201
Power 
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:
POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:POWer?

Power
(F-SYNCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:POWer?

Power
(OCNS)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:POWer?

Power
(QPCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:POWer?

Power
(R-ACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:POWer?

Power
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:POWer?

Power
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:POWer?

Power
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:POWer?

Power
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:POWer?

Power
(R-PICH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:POWer?

Power
(R-SCH)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:POWer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:POWer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:POWer <0 - -40dB>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:POWer?

PRAT [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:PRATe <0 - 3>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:PRATe?

QOF
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:QOF <0 - 3>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:QOF?

QOF
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:QOF <0 - 3>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:QOF?

Q Out - no 1/2 Chip 
Delay

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DOUT QOUT
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:DOUT?

Quarter [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:GRATe QUARter
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:GRATe?

Radio Config
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:RCONfig <1 - 5>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:RCONfig?
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Programming Command Cross-Reference ESG Family Signal Generators
Option 201
Radio Config
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:RCONfig <3 - 5>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:RCONfig?

Radio Config
(Reverse Link)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCONfig <1 - 4>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCONfig?

Rectangle [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer RECTangle
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer RECTangle
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

RESERVED [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:RESErved?

Rising [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TEDGe RISing
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TEDGe?

Root Nyquist [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer RNYQuist
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer RNYQuist
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

Scale to 0dB [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:PADJust SCALe
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:PADJust SCALe

Select File
(F-FCH Data)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:DATA?

Select File
(F-PCH Data)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:DATA?

Select File
(F-SCH Data)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:
DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:DATA?

Select File
(R-ACH Data)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RACH:SETup:DATA?

Select File
(R-CCCH Data)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:DATA?

Select File
(R-DCCH Data)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:DATA?

Select File
(R-EACH Data)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:DATA?

Select File
(R-FCH Data)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:DATA?
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ESG Family Signal Generators Programming Command Cross-Reference
Option 201
Select File
(R-SCH Data)

(R-SCH, RC1-2)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:DATA?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA "<file name>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:DATA?

Select File
(Filter)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer "<User FIR>"
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer "<User FIR>"
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?

SID [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:SID <0 - 32767>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:SID?

Spread Rate [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:SPReading:RATE?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:SPReading:RATE?

Symbol Sync Out [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:SSOut EVENsecond|

LCSync

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC12:SSOut?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:SSOut EVENsecond|

LCSync

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:SSOut?

SYS_TIME [:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:
SYSTime <0 - 0xFFFFFFFFF>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:SYSTime?

Trigger 
Advance

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TADVance <0 - 2457599>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TADVance?

Trigger Edge [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TEDGe RISing|FALLing
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:TEDGe?

Turbo Coding 
Off On

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:TCODe ON|OFF|1|0
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:TCODe?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:TCODe ON|{OFF}|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:TCODe?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:TCODe ON|{OFF}|1|0
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:TCODe?

UN3/4 GSM 
Gaussian

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer UGGaussian
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FILTer?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer UGGaussian
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:FILTer?
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Programming Command Cross-Reference ESG Family Signal Generators
Option 201
Voltage Other 
ESG

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:TVOTher <0 - 4V>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:IQ:TVOTher?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:TVOTher <0 - 4V>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:TVOTher?

Voltage This 
ESG

[:SOURce]:RADio:CDMA2000[:BBG][FORWard]:IQ:TVOLtage?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:IQ:TVOLtage?

Walsh
(F-FCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FFCH:SETup:WALSh?

Walsh
(F-PCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FPCH:SETup:WALSh?

Walsh
(F-SCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSCH[1]|2:SETup:WALSh?

Walsh
(F-SYNCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:FSYNc:SETup:WALSh?

Walsh
(OCNS)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:WALSh <0 - 63>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:OCNS:SETup:WALSh?

Walsh
(QPCH)

[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:WALSh <0 - 127>
[:SOURce]:RADio:CDMA2000[:BBG][:FORWard]:QPCH:SETup:WALSh?

Walsh
(R-CCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:WALSh <0 - 7>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RCCCh:SETup:WALSh?

Walsh
(R-DCCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:WALSh <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RDCCh:SETup:WALSh?

Walsh
(R-EACH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:WALSh <0 - 7>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:REACh:SETup:WALSh?

Walsh
(R-FCH)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:WALSh <0 - 15>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RFCH:SETup:WALSh?

Walsh
R-PICH

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RPICh:SETup:WALSh?

Walsh
(R-SCH)

(R-SCH1, RC3-4)
(R-SCH2, RC3-4)

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:WALSh <0 - 7>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH1:SETup:WALSh?

[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:WALSh <0 - 7>
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:RSCH2:SETup:WALSh?

Zi [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT ZI
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?

Zq [:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT ZQ
[:SOURce]:RADio:CDMA2000[:BBG]:REVerse:BNCMux:RC34:DOUT?
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Index
Symbols
% Power Other ESG data field, 3-2
% Power This ESG data field, 3-2

Numerics
10ms Clock softkey, 3-4
2 Box Setup softkey, 3-3
20ms Clock softkey, 3-4
307.2 Khz Clock softkey, 3-3
4.8 Khz Clock softkey, 3-3
40ms Clock softkey, 3-4
5ms Clock softkey, 3-3
80ms Clock softkey, 3-4

A
adjacent channel interference test, 2-24
adjacent channel selectivity, reverse link, 2-47
Adjust Code Domain Power softkey, 3-5
algorithm decoding tests, 2-25
APCO 25 C4FM softkey, 3-5
Apply Bit Errors softkey, 3-5
Arb softkey, 3-6
asynchronous paging message, 4-17
asynchronous paging message, forward link, 5-11

B
base station timing, synchronizing, 1-4
BBG Data Clock Ext Int softkey, 3-7
BER tests

forward link, 2-22, 2-25
reverse link, 2-47

Beta softkey, 3-7
Bit Errors softkey, 3-8
BLER tests, 2-22
block diagram, functionality

two-ESG setup, 4-4
BNC MUX Settings, 3-9
BNC/SMB connectors, 1-2, 4-9

ALT PWR IN, 4-10
BURST GATE IN, 4-10
DATA, 4-9
DATA CLK OUT, 4-11
DATA CLOCK, 4-9
DATA OUT, 4-11
EVENT 1, 4-12
EVENT 2, 4-12
forward link I/O timing relationships, 4-13
forward link timing diagram, 4-13

BNC/SMB connectors (Continued)
front panel inputs, 4-9
PATTERN TRIG IN, 4-10
rear panel inputs, 4-10
rear panel outputs, 4-11
reverse link I/O timing relationships, 4-14
reverse link timing diagram

RC1–2, 4-14
RC3–4, 4-15

SYMBOL SYNC OUT, 4-12
BTS Setup, 3-57
BTS setup editor, 2-4, 2-11, 2-13
BTS Setup softkey, 3-9

C
capabilities

single-ESG configuration
forward link, 4-2
reverse link, 4-2

two-ESG configuration
forward link, 4-3
reverse link, 4-4

Cdma Freq data field, 3-10
CDMA2000

knowledge of, 2-1
cdma2000

requirements, 1-1
CDMA2000 Off On softkey, 3-10
CDMA2000 softkey, 3-10
Channel Number softkey, 3-10
Channel Setup

Channel 1, 3-11
Channel 1, Forward Link, 3-11
Channel 1, Reverse Link, 3-11
Channel 2, Forward Link, 3-12
Channel 2, Reverse Link, 3-13
Channel 3, Forward Link, 3-14
Channel 3, Reverse Link, 3-15
Channel 4, Forward Link, 3-16
Channel 4, Reverse Link, 3-17

channel setup quick paging, 2-20
Channel State Off On softkey, 3-18
channel structure implementation, 4-6
channel structures

forward link
IS-2000 supported, 4-7
IS-95 supported, 4-6

reverse link
RC1 and RC2 supported, 4-8
RC3 and RC4 supported, 4-8
R-PICH gating, 4-19
Index I-1



Index
Channel Type F-FCH OCNS softkey, 3-19
Channel Type F-SYNCH F-SCH softkey, 3-20
Channel Type R-DCCH R-SCH softkey, 3-20
Channel Type softkey, 3-18
channel types

forward link, 1-2, 1-3
reverse link, 1-4

characteristics, option 201, 4-19
Chip Clock softkey, 3-20
Chip Rate data field, 3-21
chip rate field description, 2-4, 2-11, 2-32, 2-39
code power error

additional traffic channels, 4-3
IQ map rotation, 4-4
IS-95 and IS-2000 traffic channels, 4-3

Coded RCCCH softkey, 3-21
Coded RDCCH softkey, 3-21
Coded REACH softkey, 3-21
Coded RFCH softkey, 3-21
Coded RSCH softkey, 3-22
compatibility

IS-2000, 1-2
IS-95, 1-2

Config Change data field, 3-22
configuration

forward link
single-ESG source, 2-3
two-ESG sources, 2-8

reverse link
single-ESG source, 2-31

configure ESG 1 forward link, 2-10
configure ESG 1 reverse link, 2-38
configure ESG 2 forward link, 2-12
configure ESG 2 reverse link, 2-40
connectors, BNC/SMB, 1-2
convert two-ESG to a single-ESG configuration, 4-3
Copy File softkey, 3-22
couplings

definition, 4-20
forward and reverse link, 4-20
forward link, 4-20
reverse link, 4-20

Create File softkey, 3-23

D
Data Clk Out softkey, 3-24
data clock out

data clock out
RC 1 and RC 2, 5-25
RC 3 and RC 4, 5-25

Data data field, 3-24
data fields

% Power Other ESG, 3-2
% Power This ESG, 3-2
Cdma Freq, 3-10
Chip Rate, 3-21
Config Change, 3-22
Data, 3-24
Data Rate, 3-25
DAYLT, 3-27
Even Sec Delay, 3-33
Ext Cdma Freq, 3-34
Filter, 3-36
Frame Length, 3-40
Frame Offset, 3-41
F-SYNCH Type, 3-35
Gating Rate, 3-43
IQ Voltage Scale, 3-51
LC Mask, 3-56
LC State, 3-57
LC Generation, 3-56
LP_SEC, 3-59
LTM_OFF, 3-59
MIN_P_REV, 3-60
Msg Type, 3-61
NID, 3-62
P Puncturing, 3-66
P_REV, 3-66
Paging Indicator, 3-66
PCB Data, 3-67
PCntrl (Up/Dn), 3-67
PN Offset, 3-69
Power, 3-70
PRAT, 3-71
QOF, 3-72
R/F Bit, 3-76
Radio Config, 3-74
RESERVED, 3-75
selecting, 2-3, 2-10, 2-13
SID, 3-79
Spread Rate, 3-79
SYS_Time, 3-80
Tail Bits, 3-81
Trigger Advance, 3-81
Trigger Edge, 3-81
Turbo Coding, 3-81
Voltage Other ESG, 3-84
Voltage This ESG, 3-84
Walsh, 3-85

data out
SCPI commands, forward link, 5-6
I-2 Index 



Index
data out (Continued)
SCPI commands, reverse link

RC 1 and RC 2, 5-25
RC 3 and RC 4, 5-25

Data Out softkey, 3-24
Data Rate data field, 3-25
Data Rate ranges, 3-25
DAYLT data field, 3-27
Default Message softkey, 3-27
Define User FIR softkey, 3-27
Delayed 20ms Trigger softkey, 3-28
Delayed 80ms Trigger softkey, 3-28
Delayed Even Second softkey, 3-28
Delete All Rows softkey, 3-29
Delete Bits softkey, 3-29
Delete File softkey, 3-29
Delete Row softkey, 3-30
Delete softkey, 3-28
Delete To Beginning softkey, 3-29
Delete To End softkey, 3-29
diagram

forward link traffic channel, 1-2
reverse link spreading, 1-5
reverse, RC4 traffic channels, 1-4

diagram, I/O timing
forward link, 4-13
reverse link

RC1–2, 4-14
RC3–4, 4-15

Display FFT softkey, 3-30
Display Impulse Response softkey, 3-31
Display softkeys

Display FFT, 3-30
Display Impulse Response, 3-31

E
edit

chip rate, 2-4, 2-11, 2-32, 2-39
even sec delay, 2-3, 2-4, 2-11, 2-32, 2-39
filter, 2-3, 2-10, 2-32, 2-39
LC mask, 2-32, 2-39
LC state, 2-4, 2-11, 2-32, 2-39
PN offset, 2-4, 2-11
radio config, 2-31, 2-38
spread rate, 2-4, 2-11, 2-32, 2-39
trigger advance, 2-32, 2-39
trigger edge, 2-32, 2-39

edit BTS setup softkey, 2-4, 2-11
Edit File softkey, 3-32
Edit Item softkey, 3-9, 3-32, 3-60

editor, table reverse link, 2-31, 2-38
Equal Powers softkey, 3-32
equipment required

single-ESG forward link, 2-2
single-ESG reverse link, 2-30
two-ESG forward link, 2-8
two-ESG reverse link, 2-36

error message, settings conflict, 4-19
errors, viewing, 4-19
Even Sec Delay data field, 3-33
even sec delay field description, 2-4, 2-11, 2-32, 2-39
Even Second softkey, 3-33
event 1

event 1 SCPI command, reverse link
RC 1 and RC 2, 5-25
RC 3 and RC 4, 5-26

event 1 SCPI command, forward link, 5-6
Event 1 softkey, 3-33
Ext Cdma Freq data field, 3-34
Ext softkey, 3-33

F
fading and multi-path distortions test, 2-24
Falling softkey, 3-35
features

forward link, 1-3
reverse link, 1-5

FER tests
forward link, 2-22

sensitivity and dynamic range, 2-24
setup, 2-23

reverse link, 2-47
setup, 2-48

FER, reverse link troubleshooting, 2-51
Field1 softkey, 3-36
Field2 softkey, 3-36
Field3 softkey, 3-36
fields

chip rate, 2-4, 2-11, 2-32, 2-39
even sec delay, 2-4, 2-11, 2-32, 2-39
filter, 2-3, 2-10, 2-32, 2-39
LC mask, 2-32, 2-39
LC state, 2-4, 2-11, 2-32, 2-39
PN offset, 2-4, 2-11
radio config, 2-31, 2-38
spread rate, 2-4, 2-11, 2-32, 2-39
trigger advance, 1-4, 2-32, 2-39
trigger edge, 1-4, 2-32, 2-39

Filter Alpha softkey, 3-37
Filter BbT softkey, 3-38
Index I-3



Index
Filter data field, 3-36
Filter Factor N/A softkey, 3-39
filter field description, 2-3, 2-10, 2-32, 2-39
Filter Symbols softkey, 3-39
filters

APCO 25 C4FM, 3-5
Gaussian, 3-43
IS-95, 3-51
IS-95 and IS-2000, 3-52
IS-95 Mod, 3-52
IS-95 Mod w/EQ, 3-52
IS-95 w/EQ, 3-52
Nyquist, 3-62
Rectangle, 3-75
Root Nyquist, 3-77
UN3/4 GSM Gaussian, 3-83

filters, reverse link, 4-19
FIX4 softkey, 3-39
forward and reverse link channel structures, 4-6

implementation of, 4-6
forward link, 2-22

adjacent channel interference test, 2-24
algorithm decoding tests, 2-25
BER test, 2-22, 2-25
BLER test setup, 2-23
channel structures

IS-2000 supported, 4-7
IS-95 supported, 4-6

configure ESG 1, 2-10
configure ESG 2, 2-12
couplings, 4-20
creating a paging message user file, 2-29
fading and multi-path distortions test, 2-24
features, 1-3
FER test, 2-22
FER test setup, 2-23
generating a third traffic channel, 4-3
I/O timing diagram, 4-13
I/O timing relationships, 4-13
intermod spurious response attenuation test, 2-24
paging slot usage, 2-21
quick paging channel setup, 2-20
radio configuration and traffic channels, 4-4
radio configurations, 1-2
relative power mapping, 2-15
sensitivity and dynamic range, 2-24
shared parameters, 4-21
single tone desensitization test, 2-24
single-ESG

test configuration and measurement, 2-2
single-ESG capabilities, 4-2
troubleshooting, 2-50

forward link (Continued)
two-ESG capabilities, 4-3
two-ESG configuration, 2-8
user-defined paging messages, 4-18
VSA configuration

single-ESG, 2-6
two-ESG, 2-18

forward paging channel
default paging message file, 4-17
understanding, 4-17

F-PCH softkey, 3-35
Frame Length data field, 3-40
Frame Offset data field, 3-41
front panel BNC/SMB connectors, 4-9
F-SCH softkey, 3-35
F-SYNCH Type data field, 3-35
Full softkey, 3-42
functional testing of mobile receiver, 2-25

G
Gating Rate data field, 3-43
gating, R-PICH, 4-19
Gaussian softkey, 3-43
generate RF output, two-ESG

forward link, 2-17
reverse link, 2-44

Generate softkey, 3-44
generating a third traffic channel, 4-3
global forward and reverse link parameters, 4-21
Goto Bottom Row softkey, 3-44
Goto Middle Row softkey, 3-44
Goto Row softkey, 3-44
Goto softkey, 3-44
Goto Top Row softkey, 3-45

H
Half softkey, 3-46
half-gating, R-PICH, 4-19
Hamming softkey, 3-46
Hann softkey, 3-46
Header softkey, 3-47

I
I Out softkey, 3-48
I/O functionality, 4-9
I/O signal descriptions, 4-9
I/O timing diagram

forward link, 4-13
I-4 Index 



Index
I/O timing diagram (Continued)
reverse link

RC1–2, 4-14
RC3–4, 4-15

I/O timing relationships, 4-9
forward link, 4-13
reverse link, 4-14

implementation, channel structure, 4-6
Insert 0’s softkey, 3-49
Insert 1’s softkey, 3-49
Insert PN15 softkey, 3-50
Insert PN9 softkey, 3-49
Insert Row softkey, 3-50
Insert softkey, 3-48
intermod spurious response attenuation test, 2-24
intermodulation test

reverse link, 2-47
IQ distortion

additional traffic channels, 4-3
IS-95 and IS-2000 traffic channels, 4-3

IQ map rotation, 4-4
code power error correction, 4-4
problems with, 2-51

IQ Map Rotation Std. Rotated softkey, 3-50
IQ Voltage Scale data field, 3-51
IS-2000, 1-2

compatibility, 1-2
forward link, 1-2
forward link traffic channel diagram, 1-2
knowledge of, 2-1
radio configurations, 1-2
reverse link, 1-4

IS2000 softkey, 3-53
IS-95, 1-2

compatibility, 1-2
forward link, 1-2
reverse link, 1-4

IS-95 and IS-2000 softkey, 3-52
IS-95 Mod softkey, 3-52
IS-95 Mod w/EQ softkey, 3-52
IS-95 softkey, 3-51
IS95 softkey, 3-53
IS-95 w/EQ softkey, 3-52

J
JSTD8 softkey, 3-54

K
Kaiser softkey, 3-55

knowledge of
CDMA, 2-1
IS-2000, 2-1

L
LC Generation data field, 3-56
LC Mask data field, 3-56
LC mask field description, 2-32, 2-39
LC State data field, 3-57
LC state field description, 2-4, 2-11, 2-32, 2-39
link control setup editor, 2-12, 2-14
Link Control softkey, 3-57
Link Forward Reverse softkey, 3-57
Load Default FIR softkey, 3-57
Load From Selected File softkey, 3-58
Load/Store softkey, 3-58
long code generation mode

long code generation mode, 5-26
long code mask

long code mask, 5-26
Long Code softkey, 3-58
long code state

long code state, 5-26
Long Code Sync softkey, 3-58
LP_SEC data field, 3-59
LTM_OFF data field, 3-59

M
mapping, relative power, 2-15, 2-42, 4-16
measurement setup

single-ESG
forward link, 2-2
reverse link, 2-30

two-ESG
forward link, 2-9
reverse link, 2-37

measurements
forward link

BER, 2-22
BLER, 2-22
BLER setup, 2-23
FER, 2-22, 2-23
FER setup, 2-23
sensitivity and dynamic range, 2-24

reverse link
BER, 2-47
FER, 2-47
sensitivity and dynamic range, 2-47

menus
CDMA2000, 2-3, 2-10, 2-31, 2-38, 2-40
Index I-5
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message file, default forward paging, 4-17
Message, Default softkey, 3-27
MIN_P_REV data field, 3-60
Mirror Table softkey, 3-60
mobile receiver, functional testing, 2-25
Mobile Setup, 3-57
Mobile Setup softkey, 3-60
mobile setup table editor, reverse link, 2-31, 2-38
Msg Type data field, 3-61

N
NID data field, 3-62
None softkey, 3-62
Number of Bits softkey, 3-62
Nyquist softkey, 3-62

O
operation, theory of, 4-1
Optimize FIR For (N/A) softkey, 3-64
Optimize FIR For EVM ACP softkey, 3-64
option 201

BNC/SMB connectors, 1-2, 4-9
characteristics, 4-19
requirements, 1-1

option H03 SCPI language comparison, 5-49
Oversample Ratio softkey, 3-64

P
P Puncturing data field, 3-66
P_REV data field, 3-66
Page Down softkey, 3-66
Page Up softkey, 3-67
paging channel, forward understanding, 4-17
Paging Indicator data field, 3-66
paging message, forward link

asynchronous
SCPI command, 5-11
understanding, 4-17

synchronous
creating user file, 2-29
understanding, 4-17

user-defined, 4-18
paging slot usage, 2-21
parameters

selecting, 2-3, 2-10, 2-13
parameters, shared forward and reverse link, 4-21
PC Ramp softkey, 3-68
PCB Data data field, 3-67

PCntrl (Up/Dn) data field, 3-67
Permuted ESN softkey, 3-68
Phase Polarity Normal Invert softkey, 3-68
Pilot softkey, 3-68
PN Offset data field, 3-69
PN offset description, 2-4, 2-11
PN Sequence softkey, 3-70
PN Sync softkey, 3-70
PN15 softkey, 3-69
PN9 softkey, 3-69
Power data field, 3-70
power error, code

additional traffic channels, 4-3
IQ map rotation, 4-4
IS-95 and IS-2000 channel transmission, 4-3

power mapping, See relative power mapping
Power Puncturing Off On softkey, 3-71
PRAT data field, 3-71
programming command cross reference, 6-1
programming examples, 5-42

single-ESG setup, 5-43
two-ESG setup, 5-45

Q
Q Out-no 1/2 Chip Delay softkey, 3-72
QOF data field, 3-72
QPCH softkey, 3-72
Quarter softkey, 3-72
quarter-gating, R-PICH, 4-19
quick paging, 3-72

setting up, 2-20

R
R/F Bit data field, 3-76
R-ACH softkey, 3-73
Radio Config data field, 3-74
radio config field description, 2-31, 2-38
radio config SCPI command, reverse link, 5-26
radio configurations, 1-2

forward link, 4-2, 4-3
forward link traffic channel diagram, 1-2
reverse link, 4-2, 4-4
reverse link features, 1-5
single-ESG

forward link, 1-2
reverse link, 1-4

two-ESG
forward link, 1-2
reverse link, 1-4
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R-CCCH softkey, 3-73
R-EACH softkey, 3-73
Real Time softkey, 3-73
rear panel BNC/SMB connectors, 4-10, 4-11
receiver tests

mobile, functional testing, 2-25
using two ESGs, 2-8

Rectangle softkey, 3-75
relative power mapping, 2-15, 2-42

understanding, 4-16
remote programming, 5-2
Rename softkey, 3-75
required equipment

forward link
single-ESG measurement, 2-2
two-ESG measurement, 2-8

reverse link
single-ESG measurement, 2-30
two-ESG measurement, 2-36

RESERVED data field, 3-75
Reset Defaults softkey, 3-76
Restore Default Filter softkey, 3-76
reverse link

additional R-SCH, 1-4
capabilities

single-ESG configuration, 4-2
two-ESG configuration, 4-4

channel types, 1-4, 4-8
configure ESG 1, 2-38
configure ESG 2, 2-40
couplings, 4-20
features, radio configurations, 1-5
filters, 4-19
I/O timing diagram

RC1–2, 4-14
RC3–4, 4-15

I/O timing relationships, 4-14
mobile setup table editor, 2-31, 2-38
radio configurations, 1-2, 1-4
relative power mapping, 2-42
shared parameters, 4-21
single-ESG

test configuration and measurement, 2-30
spreading diagram, 1-5
supported channel structures, 4-8
tests, 2-47

adjacent channel selectivity, 2-47
BER, 2-47
FER, 2-47
intermodulation, 2-47
sensitivity and dynamic range, 2-47
setup, 2-48

reverse link (Continued)
trigger advance, 1-4
trigger edge, 1-4
troubleshooting, 2-50
two-ESG measurement, 2-36
VSA configuration

single-ESG, 2-34
two-ESG, 2-45

RF output, generate
two-ESG

forward link, 2-17
reverse link, 2-44

R-FCH softkey, 3-73
Rising softkey, 3-76
Root Nyquist softkey, 3-77
R-PICH gating, 4-19
R-SCH softkey, 3-74

S
Scale To 0dB softkey, 3-78
SCPI command reference, 5-2
SCPI commands

adjust code domain power, 5-2
BBG data clock external internal, 5-2
cdma2000 link, 5-3
cdma2000 state, 5-3
chip rate, 5-3
data out, forward link, 5-6
data out, reverse link, 5-25
even second delay, 5-3
event 1, forward link, 5-6
event 1, reverse link, 5-25, 5-26
F-FCH

data, 5-6
data rate, 5-7
fix4, 5-7
long code mask ESN, 5-7
long code mask header, 5-8
long code mask query, 5-8
power, 5-8
power control (up/down), 5-8
power puncturing state, 5-8
quasi-orthogonal function, 5-9
radio configuration, 5-9
state, 5-9
Walsh code, 5-9

F-FCH frame offset, 5-7
filter alpha, 5-4
filter BbT, 5-4
filter configuration, 5-4
filter optimization, 5-5
filter type, 5-5
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SCPI commands (Continued)
forward fundamental channel setup, 5-6
forward paging channel setup, 5-10
forward pilot channel setup, 5-12
forward supplemental traffic channel setup, 5-12
forward sync channel setup, 5-15
F-PCH

data, 5-10
data rate, 5-10
long code mask field 1, 5-10
long code mask field 2, 5-10
long code mask field 3, 5-10
long code mask query, 5-11
message, 5-11
power, 5-11
state, 5-11
Walsh code, 5-11

F-PICH
PN offset, 5-12
power, 5-12
state, 5-12

F-SCH
data, 5-12
data rate, 5-13
fix4, 5-13
frame offset, 5-13
long code mask ESN, 5-13
long code mask header, 5-14
long code mask query, 5-14
power, 5-14
quasi-orthogonal function, 5-14
radio configuration, 5-14
state, 5-15
turbo coding state, 5-15
Walsh code, 5-15

F-SYNCH
CDMA frequency, 5-15
channel state, 5-18
daylight savings time offset, 5-15
expanded frequency, 5-16
leap seconds, 5-16
local time offset, 5-16
long code state, 5-16
message type, 5-17
minimum protocol revision level, 5-16
network identification, 5-17
paging channel data rate, 5-17
power, 5-17
protocol revision level, 5-17
reserved field, 5-18
system identification, 5-18
system time, 5-18
type, 5-18
Walsh code, 5-19

IQ, 5-19
IQ map rotation, 5-19

SCPI commands (Continued)
IQ percent power other, 5-19
IQ percent power query, 5-20
IQ total voltage other ESG, 5-20
IQ total voltage query, 5-21
IQ voltage scale, 5-20
OCNS

channel state, 5-21
power, 5-21
Walsh code, 5-21

OCNS channel setup, 5-21
phase polarity, 5-21
QPCH

configuration change, 5-22
data rate, 5-22
paging indicator, 5-22
power, 5-22
state, 5-23
Walsh code, 5-23

quick paging channel setup, 5-22
R-ACH

data, 5-23
data rate, 5-23
fix4, 5-24
frame length, 5-24
frame offset, 5-24
power, 5-24
state, 5-24

radio config, reverse link, 5-26
R-CCCH

data, 5-28
data rate, 5-28
fix4, 5-28
frame length, 5-28
frame offset, 5-29
power, 5-29
state, 5-29
Walsh code, 5-29

R-DCCH
data, 5-29
data rate, 5-30
fix4, 5-30
frame length, 5-30
frame offset, 5-30
power, 5-30
state, 5-31
Walsh code, 5-31

R-EACH
data, 5-31
data rate, 5-31
fix4, 5-32
frame length, 5-32
frame offset, 5-32
power, 5-32
state, 5-32
Walsh code, 5-33
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SCPI commands (Continued)
reverse access channel setup, 5-23
reverse cdma2000, 5-25, 5-26, 5-27
reverse cdma2000 setup, 5-25
reverse command control channel setup, 5-28
reverse dedicated control channel setup, 5-29
reverse enhanced access channel setup, 5-31
reverse fundamental channel setup, 5-33
reverse pilot channel setup, 5-35
reverse supplemental channel setup (RC1 and 

RC2), 5-36
reverse supplemental channel setup (RC3 and 

RC4), 5-38
R-FCH

data, 5-33
data rate, 5-33
fix4, 5-34
frame length, 5-34
frame offset, 5-34
power, 5-34
state, 5-34
Walsh code, 5-35

R-PICH
gating, 5-35
power, 5-35
power control bit, 5-35
state, 5-36
Walsh code, 5-36

R-SCH (RC1 and RC2)
data, 5-36
data rate, 5-36
fix4, 5-37
frame length, 5-37
frame offset, 5-37
power, 5-37
state, 5-37

R-SCH (RC3 and RC4)
data, 5-38
data rate, 5-39
fix4, 5-39
frame length, 5-40
frame offset, 5-40
power, 5-40
state, 5-40
turbo coding, 5-41
Walsh code, 5-38, 5-41

spreading rate, 5-41
SCPI language comparison, 5-49
Seed softkey, 3-78
Select File softkey, 3-79
Select softkey, 3-79
sensitivity and dynamic range test

reverse link, 2-47

settings
conflict error, walsh codes, 4-19
walsh codes, 4-19

setup
single-ESG forward link, 2-2
single-ESG reverse link, 2-30
two-ESG forward link, 2-9
two-ESG reverse link, 2-37

setup editors
link control, 2-12, 2-14
selecting data field, 2-3, 2-10, 2-13

SID data field, 3-79
single tone desensitization test, 2-24
single-ESG

conversion from a two-ESG configuration, 4-3
forward link, 1-2

features, 1-3
measurement setup, 2-2
required equipment, 2-2
source configuration, 2-3
VSA configuration, 2-6

reverse link
IS-2000, 1-4
IS-95, 1-4
measurement setup, 2-30
required equipment, 2-30
source configuration, 2-31
VSA configuration, 2-34

single-ESG capability
forward link, 4-2
reverse link, 4-2

single-ESG configuration, understanding, 4-2
softkey descriptions, 3-1
softkeys

10 ms Clock, 3-4
2 Box Setup, 3-3
20 ms Clock, 3-4
307.2 Khz Clock, 3-3
4.8 Khz Clock, 3-3
40ms Clock, 3-4
5 ms Clock, 3-3
80ms Clock, 3-4
Adjust Code Domain Power, 3-5
APCO 25 C4FM, 3-5
Apply Bit Errors, 3-5
Arb, 3-6
BBG Data Clock Ext Int, 3-7
Beta, 3-7
Bit Errors, 3-8
BNC MUX Settings, 3-9
BTS Setup, 3-9
CDMA2000, 3-10
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softkeys (Continued)
CDMA2000 Off On, 3-10
Channel Number, 3-10
Channel Setup, 3-11, 3-12, 3-13, 3-14, 3-15, 3-16, 

3-17
Channel State Off On, 3-18
Channel Type, 3-18

F-FCH OCNS, 3-19
F-SYNCH F-SCH, 3-20
R-DCCH R-SCH, 3-20

Chip Clock, 3-20
Coded RCCCH, 3-21
Coded RDCCH, 3-21
Coded REACH, 3-21
Coded RFCH, 3-21
Coded RSCH, 3-22
Copy File, 3-22
Create File, 3-23
Data Clk Out, 3-24
Data Out, 3-24
Default Message, 3-27
Define User FIR, 3-27
Delayed 20ms Trigger, 3-28
Delayed 80ms Trigger, 3-28
Delayed Even Second, 3-28
Delete, 3-28

All Rows, 3-29
Bits, 3-29
File, 3-29
Row, 3-30
To Beginning, 3-29
To End, 3-29

Display FFT, 3-30
Display Impulse Response, 3-31
Edit File, 3-32
Edit Item, 3-32
Equal Powers, 3-32
Even Second, 3-33
Event 1, 3-33
Ext, 3-33
Falling, 3-35
Field1, 3-36
Field2, 3-36
Field3, 3-36
Filter Alpha, 3-37
Filter BbT, 3-38
Filter Factor N/A, 3-39
Filter Symbols, 3-39
FIX4, 3-39
F-PCH, 3-35
F-SCH, 3-35
Full, 3-42
Gaussian, 3-43

softkeys (Continued)
Generate, 3-44
Goto, 3-44

Bottom Row, 3-44
Middle Row, 3-44
Row, 3-44
Top Row, 3-45

Half, 3-46
Hamming, 3-46
Hann, 3-46
Header, 3-47
I Out, 3-48
Insert, 3-48

0’s, 3-49
1’s, 3-49
PN15, 3-50
PN9, 3-49
Row, 3-50

IQ Map Rotation Std. Rotated, 3-50
IS2000, 3-53
IS-95, 3-51
IS95, 3-53
IS-95 and IS-2000, 3-52
IS-95 Mod, 3-52
IS-95 Mod w/EQ, 3-52
IS-95 w/EQ, 3-52
JSTD8, 3-54
Kaiser, 3-55
Link Control, 3-57
Link Forward Reverse, 3-57
Load Default FIR, 3-57
Load From Selected File, 3-58
Load/Store, 3-58
Long Code, 3-58
Long Code Sync, 3-58
Mirror Table, 3-60
Mobile Setup, 3-60
None, 3-62
Number of Bits, 3-62
Nyquist, 3-62
Optimize FIR For (N/A), 3-64
Optimize FIR For EVM ACP, 3-64
Oversample Ratio, 3-64
Page Down, 3-66
Page Up, 3-67
PC Ramp, 3-68
Permuted ESN, 3-68
Phase Polarity Normal Invert, 3-68
Pilot, 3-68
PN Sequence, 3-70
PN Sync, 3-70
PN15, 3-69
PN9, 3-69
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softkeys (Continued)
Power Puncturing Off On, 3-71
Q Out-no 1/2 Chip Delay, 3-72
QPCH, 3-72
Quarter, 3-72
R-ACH, 3-73
R-CCCH, 3-73
R-EACH, 3-73
Real Time, 3-73
Rectangle, 3-75
Rename, 3-75
Reset Defaults, 3-76
Restore Default Filter, 3-76
R-FCH, 3-73
Rising, 3-76
Root Nyquist, 3-77
R-SCH, 3-74
Scale To 0dB, 3-78
Seed, 3-78
Select, 3-79
Select File, 3-79
Store To File, 3-80
Symbol Sync Out, 3-80
Turbo Coding Off On, 3-82
UN3/4 GSM Gaussian, 3-83
User File, 3-83
User FIR, 3-83
Window, 3-88
Zi, 3-89
Zq, 3-89

solutions
single-ESG, 1-3
two-ESG, 1-3

sources
configure ESG 1 forward link, 2-10
configure ESG 1 reverse link, 2-38
configure ESG 2 forward link, 2-12
configure ESG 2 reverse link, 2-40
configure single-ESG forward link, 2-3
configure single-ESG reverse link, 2-31

spread rate, 1-2
Spread Rate data field, 3-79
spread rate field description, 2-4, 2-11, 2-32, 2-39
Store To File softkey, 3-80
Symbol Sync Out softkey, 3-80
symbol synchronization

RC 1 and RC 2
symbol synchronization, 5-27

RC 3 and RC 4
symbol synchronization, 5-27

sync channel type
IS2000, 3-53

sync channel type (Continued)
IS95, 3-53
JSTD8, 3-54

synchronizing, base station, 1-4
synchronous paging message, forward link, 2-29, 

4-17
SYS_Time data field, 3-80
system functionality, 4-4

T
table editor, reverse link, 2-31, 2-38
table editors

BTS, 2-4, 2-11, 2-13
link control, 2-12, 2-14
selecting data field, 2-3, 2-10, 2-13

Tail Bits data field, 3-81
tests

forward link
adjacent channel interference, 2-24
algorithm decoding, 2-25
BER, 2-25
fading and multi-path distortions, 2-24
intermod spurious response attenuation, 2-24
receiver, using two ESGs, 2-8
sensitivity and dynamic range, 2-24
single tone desensitization, 2-24
single-ESG measurement, 2-2
single-ESG setup, 2-2
two-ESG setup, 2-9

reverse link
adjacent channel selectivity, 2-47
BER, 2-47
FER, 2-47
intermodulation, 2-47
sensitivity and dynamic range, 2-47
setup, 2-48
single-ESG measurement, 2-30
single-ESG setup, 2-30
two-ESG setup, 2-37

theory of operation, 4-1
timing diagram

forward link I/O connectors, 4-13
reverse link I/O connectors

RC1–2, 4-14
RC3–4, 4-15

timing relationships, I/O
forward link, 4-13
reverse link, 4-14

traffic channel
forward link diagram, 1-2

trigger advance, 1-4, 5-27
Trigger Advance data field, 3-81
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trigger advance field description, 2-32, 2-39
trigger edge, 1-4, 5-27
Trigger Edge data field, 3-81
trigger edge field description, 2-32, 2-39
triggering, 1-4
troubleshooting, 2-50

cannot see channels displayed on transmitter 
tester, 2-50

cannot turn on CDMA2000, 2-50
display values the same when programming 2 

ESGs, 2-51
ESG 10 MHz external reference will not lock, 2-50
I/Q map rotation problems, 2-51
reverse link FER, 2-51
tips and tricks, 2-50

Turbo Coding data field, 3-81
Turbo Coding Off On softkey, 3-82
two-ESG

conversion to a single-ESG configuration, 4-3
forward link, 1-2

configure ESG 1, 2-10
configure ESG 2, 2-12
features, 1-3
generate RF output, 2-17
measurement setup, 2-9
required equipment, 2-8
VSA configuration, 2-18

relative power mapping, 2-15, 2-42
reverse link, 1-4

configure ESG 1, 2-38
configure ESG 2, 2-40
generate RF output, 2-44
measurement setup, 2-37
required equipment, 2-36
VSA configuration, 2-45

two-ESG capability
forward link, 4-3
reverse link, 4-4

two-ESG configuration, understanding, 4-3
two-ESG setup

system functionality, 4-4

U
UN3/4 GSM Gaussian softkey, 3-83
understanding single-ESG configuration, 4-2
understanding the forward paging channel, 4-17
understanding two-ESG configuration, 4-3
User File softkey, 3-83
user file, synchronous forward link paging message, 

2-29
User FIR softkey, 3-83

V
viewing errors, 4-19
Voltage Other ESG data field, 3-84
Voltage This ESG data field, 3-84

W
walsh codes, 4-19
Walsh data field, 3-85
Window

Hamming, 3-46
Hann, 3-46
Kaiser, 3-7, 3-55
None, 3-62

Window softkey, 3-88

Z
Zi softkey, 3-89
Zq softkey, 3-89
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